NOTE 4: Wifi calling troubleshooting solution and tips





    I just spent the better part of the past 18 hours troubleshooting an issue with Wifi Calling. When I had Wifi Calling enabled, I could make and receive calls, I could hear the person on the other line, but they couldn't hear me. Also, if dialing a business with Wifi Calling enabled, when prompted to dial an extension the system on the other end was not registering my input. I started with simple things like restarting the device, checking e911 settings in the Tmobile Account app, cycling wifi calling on and off.


    I was pretty sure it wasn't my cellspot router but I proceeded last night to reset it and go through the setup process again so I could rule it out. I tested the speed of my ISP and also checked for packet loss to account for any issues there. Everything checked out. Finally defeated but still not wanting to initiate a hard reset I called Tmobile today, who filed a ticket with an engineer to get back with me early next week. Before filing the ticket, the nice representative ran through his list of troubleshooting recommendations, which were just rehashes of what I had already done.






    Fast forward to about an hour ago when I was getting ready to enter a meeting. I placed the phone in airplane mode. When the meeting was over, I turned airplane mode off, connected to the facility's Wii and to kill some time figured I'd play around with Wifi Calling some more. I threw the phone back into airplane mode, turned Wifi on and then attempted to turn on wifi calling from the Wifi calling preferences menu. This resulted in WiFi Calling freezing up on me. I restarted, enabled Wifi Calling and made a call and bam, it was working once more.


    So if you've tried everything else, here are the steps:


    1) Enable airplane mode.

    2) With airplane mode still on, enable Wifi, making sure that you are connected to a router and have Internet access.

    3) Long press WiFi Calling in the notification panel.

    4) Change Wifi Calling setting from Wifi preferred to Cellular Network preferred and then turn it on. It will turn all selections gray and pretty much just be stuck there like that.

    5) Reboot device. Connect to Wifi and after ensuring that airplane mode is off, long press WiFi Calling in the Notification Panel and select Wifi preferred and turn on Wifi Calling.


    After that you should be good to go. I didn't search the thread too deeply so hopefully this isn't old news (I did quite a bit of research last night on Google, though, and didn't find this advice anywhere.

      All replies

      • Unfortunely this is not how u fix the wifi calling issue, theres a service system file on the note 4 kitkat itself that bugs out if u connect to a different wifi hotspot WHILE wifi calling is still enabled. The wifi calling doesnt clear the cache automatically like its supposed to so the voice IP you are trying to talk through doesnt match the cache from the previous hotspot, causing people not to hear you or any automated phone systems getting amything from your end. To fix this either you find the wifi calling thru app manager and clear just the cache or restart your phone. However if you restart your phone be sure your wifi calling is disabled before you restart. Its a good thing they are fixing this cache issue in lollipop

          • That's interesting that you say that.  I had disabled WiFi while I was at the store getting my new Note 4 and didn't enable it till I got home so the only network it would have been connected to is mine.  I made a call to my ISP to make a payment and they couldn't hear me.  I then tried to make a call to my GF and she couldn't hear me.  I then made a test call to my Skype account and nothing would come out of my speakers when I talked.  I've been looking all over the place for fixes but nothing.  I'll try clearing the cache in the app manager cause that's one thing I haven't tried yet.  I'll update after I get home from work.

              • wmichaeli:

                Let us know what worked for you by all means. Knowledge is power. I will note that not only did I try to clear the Wifi Calling app's cache but also the system cache via the bootloader menu and that still didn't resolve it. It wasn't until I did what I described above that it started working for me again. And I use Wifi calling on 3 networks and this had never happened to me before. The issue the second poster describes was actually addressed by an update sent OTA several months ago, so unless you are still on the original release software, I doubt clearing cache will resolve your issue. But hey, I could be wrong. Wouldn't be the first time and won't be the last, so give it a go. For anyone out there who has tried clearing cache to no avail, though, give my troubleshooting guide a whack at your issue.

              • bpwdblue4:

                Wish it would have been as easy as clearing the Wifi Calling app's cache for me, but it wasnt. And I've read on XDA a lot of other people having the same problem and it not being fixed by clearing cache. That was obviously one of the first things I tried and it did not work. Trust me.


                Anyway. I'm not here to cause problems. Only attempting to help others in my situation. Happy trails.

              • steelystan

                I just started having this issue yesterday and it was working fine before that. I updated to lollipop a few weeks ago so I don't think it's just a lollipop problem. My router hasn't changed, my ssid hasn't changed, and I haven't installed or updated anything on my phone in the past week.


                I've tried everything suggested in this thread. I've tried everything I can find after doing a search on google. I've contacted TMobile and "everything looks good on our end" is what I was told.


                When I'm in good signal range or my router the Wifi Calling Settings page is stuck "enabling" and everything is greyed out, can't do anything. As soon as I go outside and my signal starts to degrade the menu items enable and I can make adjustments but instead of "enabling" it says "poor wifi signal or range" (or something like that). As soon as I go back inside the wifi call settings goes back to being greyed out and "enabling" until I either leave my home or turn it off.


                Very frustrating issue since I have terrible service at my home after switching to TMobile and the wifi calling option was a major influence for switching to TMobile (I know other providers have it, too, and better coverage but I wanted to go with TMobile and the wifi calling was what convinced me).


                Samsung Note 4

                Android 5.0.1

                  • Same issue here on My Note 4 running 5.0.1


                    WiFi calling used to be very reliable but since the 5.0.1 update it has become extremely intermittent.


                    The issue is that the WiFi calling feature does not always connect. Even when WiFi calling does connect it does not remain connected even though the WiFi retains a solid connection.


                    We have great internet at home (> 170mbps) , however the issue is the same at other WiFi locations.


                    I experience errors such as:

                    • REG99

                    • DNS Error

                    • Phone remains on “Enabling” for an infinite duration


                    Steps taken to correct the issue with no effect:

                    • Performed a Master Reset on the phone (extremely inconvenient)

                    • T-Mobile have sent OTA updates to the phones

                    • We have replaced our expensive ASUS R7000 Nighthawk router with the T-Mobile CellSpot router to ensure that everything we can do to optimize the WiFi calling connection is in place.

                    • Reset my e911 address

                    • Cleared the cache


                    None of these steps have improved the situation.


                    Any other suggestions would be greatly appreciated as my phone is pretty much useless at home as our cell signal is so poor.

                      • Well, I have an update regarding the Galaxy Note 4 WiFi calling issues.


                        I gave up on the forums and tried contacting T-Mobile Tech Support via Twitter.

                        This actually does solicit a response from T-Mobile, but the responses are an hour or so apart so it takes a while to get through a few questions but at least it's some response.


                        The Tech Support person said that T-Mobile are aware of the problem and are working on a patch that will be released on September 28th.


                        That's another ~6 weeks from now. I asked what should do in the interim and one response was to buy a new phone. That's a ridiculous response as it means I have wasted money on the current one.


                        I have therefore written a formal complaint and am awaiting the response.

                          • Received a callback from my letter yesterday.

                            Samsung have apparently been pushing a path out since mid August to correct the Galaxy Note 3 and Note 4 wifi calling issues.

                            Mine apparently was updated this week. I noticed my phone just randomly power down and reset which must have been when the path was issued.

                            Since then it seems to be working much better than it did prior to the Android 5.0.1 update which completely ruined wifi calling for me.

                            It's too early to tell if it is completely fixed but I definitely see an improvement.

                            To check if your phone has the patch look for the following 4 digits at the end of the baseband version:

                            Note 3:  F0B6

                            Note 4:  C0G2

                            I hope this info is useful to you.


                      • archie10

                        I changed to t-mobile because of wifi calling.  we live in the shadow of a large building that blocks most cell coverage.  we send/rcve txt msgs no problem.  phone calls go directly to voice mail.  I have spent countless hours working with t-mobile techs trying to solve this problem.  I have worked with Jason, Kevin, Roland, Sergio, Shane, Brandi and Jake from comcast.  still no phone calls over wifi.  one of the techs sent me a 4G LTE cellspot to fix the problem and naturally it will not connect properly.  if I power off/on the phone for about 10 minutes I can receive phone calls.  I know this because I can call myself with my wife's phone.  after about 10 minutes I no longer can receive wifi phone calls.  it looks to me as if the t-mobile network wakes up when my phone powers off but after those 10 minutes it kicks us off, de-registers us from their network.  with the number of people with this problem one would think t-mobile would solve this problem.  based on performance so far I'm not sure t-mobile cares.

                        1 of 1 people found this helpful
                        • magenta5452731

                          This may work on a T-Mobile device, but I'm using an unlocked AT&T device and the above procedure doesn't work. Trying to enable WiFi calling results in "Wi-Fi calling lets you make and receive calls over WI-Fi with your AT&T account." Well, I no longer have an AT&T account so when I try to proceed, I get "Wi-Fi Calling activation not successful. Try again later." Anyone have a work around for that? Thanks.

                          • archie10

                            Could not get the t-mobile cell spot to work no matter what order I turned things or tried.  I still had the leds blinking at me.  I did get the gps led to come on, finally.  According to the manual the blinking leds indicated the device could not connect to the server and I should make sure certain ports were open.  I had talked with my ISP, comcast, and they said the ports were open.  Finally dawned on me to check my router.  I opened all the ports and the cell spot started working.  Now have excellent cell reception.  So the problem was me.