Update:

    **This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is. Follow all steps below!**

    I live in the Chicago area, and have T-Mobile.

    I use Textra as well since the Z3's stock messenger app clearly CANNOT handle MMS (group/photo text messages) properly. This is what worked for me....................

    1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

    Name: T-Mobile Data 2
    APN: fast.t-mobile.com
    Proxy: not set
    Port: not set
    Username: not set
    Password: not set
    Server: not set
    MMSC:
    http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS proxy: not set
    MMS port: not set
    MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)
    MCC: 310
    MNC: 260
    Auth Type: not set
    APN type: default,mms,supl,admin,hipri
    APN proto: IPv4/IPv6
    APN roaming proto: IPv4/IPv6
    APN enable/disable: enable
    Bearer: unspecified

    2) Disable Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

    3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

    4) In Phone settings, under Call Settings, uncheck/disable: VoLTE, Microphone noise suppression, and Speaker voice enhancement. Under Date & time, uncheck Automatic date & time, and Automatic time zone as well. And disable Stamina mode (under Power management) COMPLETELY, including all sub-options.


    If you have any questions, let me know.

    P.S. For whatever reason, if you're getting an MMS message from someone with an iPhone, and they have "iMessage" turned on, the Z3 will NOT receive the message. So you have to ask people who have iPhones and are sending you MMS messages to kindly turn it off, and then all should be fine.


    Rock2005Star

      All replies

      • Z3 settings that worked for me

         

         

        I use Textra as well since the Z3's stock messenger app clearly CANNOT handle MMS properly. This is what worked for me....................

         

        1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

         

        Name: T-Mobile Data 2
        APN: fast.t-mobile.com
        Proxy: not set
        Port: not set
        Username: not set
        Password: not set
        Server: not set
        MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
        MMS proxy: not set
        MMS port: not set
        MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)
        MCC: 310
        MNC: 260
        Auth Type: not set
        APN type: default,mms,supl,admin,hipri
        APN proto: IPv4/IPv6
        APN roaming proto: IPv4/IPv6
        APN enable/disable: enable
        Bearer: unspecified

         

        2) Disable Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

         

        3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

         

        4) In Phone settings, under Call Settings, uncheck/disable: VoLTE.

         

        5) You can leave STAMINA mode on, however...... only enable the "Extended Standby" option and of course Activation should be at 100%/Always on. I would white list the following apps too (though not sure if you have to): Your stock text messaging app (IF it shows up on the list; it didn't for me), any third party text msg app like Textra, etc, and another app under "All others" called "Phone/Messaging Storage". Keep "Extended usage" & "STAMINA clock" off (I guess?). The one you must DEFINITELY leave disabled/unchecked is "Queue background data". That will def block incoming (and prob outgoing) MMS, at least it did for me during my tests.

         

        P.S. This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is.

         

        P.P.S. For whatever reason, if you're getting an MMS message from someone with an iPhone, and they have "iMessage" turned on, the Z3 will NOT receive the message. So you have to ask people who have iPhones and are sending you MMS messages to kindly turn it off, and then all should be fine.

         

        RockStar2005

          • Update:

             

            I use Textra as well since the Z3's stock messenger app clearly CANNOT handle MMS properly. This is what worked for me....................

             

            1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

             

            Name: T-Mobile Data 2

            APN: fast.t-mobile.com

            Proxy: not set

            Port: not set

            Username: not set

            Password: not set

            Server: not set

            MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

            MMS proxy: not set

            MMS port: not set

            MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)

            MCC: 310

            MNC: 260

            Auth Type: not set

            APN type: default,mms,supl,admin,hipri

            APN proto: IPv4/IPv6

            APN roaming proto: IPv4/IPv6

            APN enable/disable: enable

            Bearer: unspecified

             

            2) Disable Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

             

            3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

             

            4) In Phone settings, under Call Settings, uncheck/disable: VoLTE.

             

            5) You can leave STAMINA mode on, however...... only enable the "Extended Standby" option and of course Activation should be at 100%/Always on. You must DEFINITELY disable/uncheck "Queue background data". That will def block incoming (and prob outgoing) MMS, at least it did for me during my tests.

             

            Is anyone who's reading this living in a country OUTSIDE of the U.S.? If so, please reply to this post. If not, then I believe it's T-Mobile's fault b/c no other country is having this issue, and T-Mobile already has a reputation for certain phones to have MMS issues.


            It seems that MMS messages will def show up if Wi-Fi is on, but it will def take longer to show up if screen is off. Maybe 3-5 minutes longer. I would also set "Keep WiFi on during sleep" to "only when plugged in (under WiFi's Advanced Settings)", and make sure everything else on that page is unchecked/disabled.

             

            If you have any questions, let me know. I'm still testing this out so I may make more changes. We'll see.

             

            P.S. This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is.

             

            P.P.S. For whatever reason, if you're getting an MMS message from someone with an iPhone, and they have "iMessage" turned on, the Z3 will NOT receive the message. So you have to ask people who have iPhones and are sending you MMS messages to kindly turn it off, and then all should be fine.


              • **DISREGARD ALL PREVIOUS POSTS!!**


                I use Textra as well since the Z3's stock messenger app clearly CANNOT handle MMS properly. This is what worked for me....................

                 

                1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

                 

                Name: T-Mobile Data 2

                APN: fast.t-mobile.com

                Proxy: not set

                Port: not set

                Username: not set

                Password: not set

                Server: not set

                MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

                MMS proxy: not set

                MMS port: not set

                MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)

                MCC: 310

                MNC: 260

                Auth Type: not set

                APN type: default,mms,supl,admin,hipri

                APN proto: IPv4/IPv6

                APN roaming proto: IPv4/IPv6

                APN enable/disable: enable

                Bearer: unspecified

                 

                2) Disable Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

                 

                3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

                 

                4) In Phone settings, under Call Settings, uncheck/disable: VoLTE. For WiFi to work, you must also disable anything else you have enabled on this screen (i.e. Microphone noise suppression, Speaker voice enhancement, etc).

                 

                5) You can leave STAMINA mode on (under Power management), however...... only enable the "Extended Standby" option and of course Activation should be at 100%/Always on. You must DEFINITELY disable/uncheck "Queue background data" (also under Power management). That will def block incoming (and prob outgoing) MMS, at least it did for me during my tests. When Wi-Fi is on, you must also have whitelisted 2 specific apps in STAMINA under the "Apps active in standby" list: The text msg app you're using (i.e. Textra, etc) and I would also whitelist one under "All others" entitled "Phone/Messaging Storage". Again, this is only for when you have Wi-Fi on. Keep the other stuff disabled in here.

                 

                It seems that MMS messages will def show up if Wi-Fi is on, but it will def take longer to show up if screen is off. Maybe 3-5 minutes longer. I would also set "Keep WiFi on during sleep" to "Always", and make sure everything else on that page is unchecked/disabled.

                 

                Is anyone who's reading this living in a country OUTSIDE of the U.S.? If so, please reply to this post. If not, then I believe it's T-Mobile's fault b/c no other country is having this issue, and T-Mobile already has a reputation for certain phones to have MMS issues.

                 

                If you have any questions, let me know. I'm still testing this out so I may make more changes. We'll see.

                 

                P.S. This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is.

                 

                P.P.S. For whatever reason, if you're getting an MMS message from someone with an iPhone, and they have "iMessage" turned on, the Z3 will NOT receive the message. So you have to ask people who have iPhones and are sending you MMS messages to kindly turn it off, and then all should be fine.

                  • I use Textra as well since the Z3's stock messenger app clearly CANNOT handle MMS properly. This is what worked for me....................

                     

                    1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

                     

                    Name: T-Mobile Data 2

                    APN: fast.t-mobile.com

                    Proxy: not set

                    Port: not set

                    Username: not set

                    Password: not set

                    Server: not set

                    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

                    MMS proxy: not set

                    MMS port: not set

                    MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)

                    MCC: 310

                    MNC: 260

                    Auth Type: not set

                    APN type: default,mms,supl,admin,hipri

                    APN proto: IPv4/IPv6

                    APN roaming proto: IPv4/IPv6

                    APN enable/disable: enable

                    Bearer: unspecified

                     

                    2) Disable Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

                     

                    3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

                     

                    4) In Phone settings, under Call Settings, uncheck/disable: VoLTE. For WiFi to work, you must also disable anything else you have enabled on this screen (i.e. Microphone noise suppression, Speaker voice enhancement, etc).

                     

                    5) You can leave STAMINA mode on (under Power management), however...... only enable the "Extended Standby" option and of course Activation should be at 100%/Always on. You must DEFINITELY disable/uncheck "Queue background data" (also under Power management). That will def block incoming (and prob outgoing) MMS, at least it did for me during my tests. When Wi-Fi is on, you must also have whitelisted 2 specific apps in STAMINA under the "Apps active in standby" list: The text msg app you're using (i.e. Textra, etc) and I would also whitelist one under "All others" entitled "Phone/Messaging Storage". Again, this is only for when you have Wi-Fi on. Keep the other stuff disabled in here.

                     

                    It seems that MMS messages will def show up if Wi-Fi is on, but it will def take longer to show up if screen is off. Maybe 3-5 minutes longer. On WiFi Advanced menu page, make sure everything else on there is unchecked/disabled.

                     

                    If you have any questions, let me know. I'm still testing this out so I may make more changes. We'll see.

                     

                    P.S. This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is.

                     

                    P.P.S. For whatever reason, if you're getting an MMS message from someone with an iPhone, and they have "iMessage" turned on, the Z3 will NOT receive the message. So you have to ask people who have iPhones and are sending you MMS messages to kindly turn it off, and then all should be fine.

                     

                    RockStar2005

                      • I've tried this and while my smart call handling has improved, my MMS is still buggy. More specifically, it's the incoming MMS texts that I either do not receive or I receive hours/ a day later.

                         

                        I am beginning to wonder if T-Mobile even cares about this WELL known issue with Sony Phones MMS issues.

                          • tidbits

                            You need to bring it up with SONY not T-Mobile.  if you go to Sony care if affects ALL Xperias.  Sony knows of the issues and has not fixed it since the original Z.  I have owned all 3 of them as well as the Z2 which was never released on T-Mobile.  T-Mobile can't help you or give you information as it's not their software and hardware.  You are going up the wrong "chain" so to speak

                              • Tidbits,

                                 

                                I don't know if I agree with you. Maybe you're right about it being Sony's fault, but you say the previous Z phones have had MMS issues? I think T-Mobile should be held responsible just as much as Sony b/c when they make the decision to sell Sony's phones, they should be making sure the phones work properly for at least something BASIC like texting SMS & MMS as well. But they clearly are not.

                                 

                                Last year I owned the HTC One M8.........another great phone like the Z3. But guess what, the M8 (which I also got through T-Mobile) ALSO had MMS issues as well. I had to turn off Wi-Fi Calling cuz that is just the MMS killer, but I also had to replace my stock texting app once again with another. I found Chomp SMS to work well with the M8, so I used that. I had less issues with MMS on the M8 than I have had with the Z3. It's ridiculous that I'm STILL even working on this matter.

                                 

                                Since you said the Z2 also had an MMS issue and yes T-Mobile did not carry it (I should know....why do you think I got the M8 last year? lol), then I guess Sony is at fault too, at least partially. T-Mobile should've made it work though, or else refused to sell the phone. Instead, like the M8, they sold it to people to make money b/c they either didn't know (which is bad) or else didn't care (which is also bad) and just wanted to make a profit despite how ppl would react.

                                 

                                Steve

                                  • tidbits

                                    Install this Messenger - Android Apps on Google Play and magically group messaging works like a charm

                                     

                                    https://talk.sonymobile.com/t5/Xperia-Z3-Z3-Dual/Xperia-Z3-Group-MMS-group-messaging/td-p/838131/highlight/true/page/3

                                     

                                    that thread you'll find various users not all are on T-Mobile.

                                     

                                    It's not up to T-Mobile to fix broken code.  They don't touch code at all like people perceive.  Sony needs to fix it and owning all of the Z line used on various carriers I always had trouble unless using a different app.

                                      • I see. I suspected other carriers may be having the same issue with their Z3, or just ppl using unlocked Z phones on their networks.

                                         

                                        Then what is the point of T-Mobile running these "network tests" if they don't resolve the issues? What good are they, except for checking if the phone part of the smartphone works? Why can't they refuse the phones and send them back to Sony saying "Hey, fix this issue so we don't get blamed for it?" Because that is exactly what's happening here.

                                         

                                        Steve

                                          • tidbits

                                            Carrier testing isn't what people think it is. They test the connection and security of the device and call quality. Group messaging has the same security as any MMS sent so it doesn't really need testing. It's Sony job to fix it.

                                             

                                            It is a worldwide problem for Sony and blaming the carrier isn't going to fix the issue. Europe has shown this more than a handful of times. Look at HTC, and Motorola and how their companies changed thanks to European sales numbers.

                                              • I think they should be checking on the MMS then too. It's 2015, texting for many people is utilized more often than calling is. Sony should fix the problem, but to me T-Mobile (and all carriers really) is still not doing enough to help either by just selling it as is.

                                                 

                                                What do you mean "changed thanks to European sales numbers"?

                                                 

                                                Well yeah, I hope/expect the Lollipop update to also include Sony updates too. A T-Mobile store rep told me the Z1s (U.S. variant of the Z1), which was released by T-Mobile 14 mos ago, didn't have a functioning Smart Call Handling option either, but that the first major update that came out a few months after its release made it work. So when it didn't work on mine, I was told the same would prob happen. But luckily on my own I figured out why it wasn't working. Hopefully though the update coming very soon from T-Mobile for Lollipop will resolve the MMS issue for ppl so they don't have to go through all this, but I'm not holding my breath.

                                                  • tidbits

                                                    They SHOULDN'T that's why we are in the problem we are in, and will always be in.

                                                     

                                                    European sales numbers made Motorola lose so much money they were sold off to Google and then finally to Lenovo. HTC until the HTC One M7 had poor sales and we're in the black. The company thinking changed and have gotten a whole lot better at supporting their own products. They even went as far of not using the it's  out of our hands and up to the carrier canned responses. They broke down their update process and showed how little carriers actually do.

                                                     

                                                    If carriers stopped subsidizing device and go unbranded devices only like BYOD carriers would still be blamed for anything. You can see it on these forum.

                                                      • I agree about Sony needing to own up to their issues and fix them. I know Sony does A LOT better in sales in Europe than they do here. That's cuz there every carrier sells Xperia phones, not just 1 or 2 like here. They ACTUALLY advertise in Europe. Here they don't advertise squat. You ever see an Xperia TV ad? Nope. lol They also need to sell the phones at the right price. You can't sell a premium phone at sub-premium prices. You're ignoring your target customer group. They won't see the phone as great if it costs hundreds less than an iPhone. Sony had to layoff a ton of people b/c they weren't making enough to keep them. It's bad business on their part. I know a friend in Sweden who told me that Sony sells just as many phones, if not more, than Samsung does there. That further proves my statements as true.

                                                          • tidbits

                                                            Those numbers are based on the entire lineup and not their flagship lineup. If you take away their bottom and mid tier they don't hold a candle to their competition.

                                                            This is one of the reasons why Android wants to bundle all devices over by manufacturer. It makes it look like Android is top dog while Apple sales blow away their competition under the same user group.

                                                             

                                                            Sony spends advertising money in Europe not here. It's notime the carriers fault. Samsung, LG, and Apple do their own advertising. HTC and Motorola which were smaller in market share were able to get their devices on various carriers in the US. Sony can do it but chose to go exclusive because they don't take the US market seriously.

                                                              • You got THAT right! And not taking the U.S. market seriously is seriously stupid on their part.

                                                                 

                                                                Yeah but all companies do the most advertising for their flagships. You never hear or see any ads for Samsung's lesser phones, etc. But Sony doesn't even advertise for the flagship series, which is taking it too far.

                                                                 

                                                                I agree..........Android's weakness is no accountability. Any fool can release an app on Google Play Store and even though many are great, there are still too many that suck, or that only work with certain Android phones and not all. There's just pros and cons when it comes to Android vs Windows/iOS/Blackberry's OS.

                                                              • **DISREGARD ALL PREVIOUS POSTS!!**


                                                                I use Textra as well since the Z3's stock messenger app clearly CANNOT handle MMS properly. This is what worked for me....................

                                                                 

                                                                1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

                                                                 

                                                                Name: T-Mobile Data 2

                                                                APN: fast.t-mobile.com

                                                                Proxy: not set

                                                                Port: not set

                                                                Username: not set

                                                                Password: not set

                                                                Server: not set

                                                                MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

                                                                MMS proxy: not set

                                                                MMS port: not set

                                                                MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)

                                                                MCC: 310

                                                                MNC: 260

                                                                Auth Type: not set

                                                                APN type: default,mms,supl,admin,hipri

                                                                APN proto: IPv4/IPv6

                                                                APN roaming proto: IPv4/IPv6

                                                                APN enable/disable: enable

                                                                Bearer: unspecified

                                                                 

                                                                2) Disable Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

                                                                 

                                                                3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

                                                                 

                                                                4) In Phone settings, under Call Settings, uncheck/disable: VoLTE. For WiFi to work, you must also disable anything else you have enabled on this screen (i.e. Microphone noise suppression, Speaker voice enhancement, etc).

                                                                 

                                                                5) You can leave STAMINA mode on (under Power management), however...... only enable the "Extended Standby" option and of course Activation should be at 100%/Always on. When Wi-Fi is on, you must also have whitelisted 2 specific apps in STAMINA under the "Apps active in standby" list: The text msg app you're using (i.e. Textra, etc) and I would also whitelist one under "All others" entitled "Phone/Messaging Storage". Again, this is only for when you have Wi-Fi on. Keep the other stuff disabled in here. With regards to STAMINA mode.......

                                                                 

                                                                First, put Keep Wi-Fi on during sleep to "Only when plugged in" (Settings, Wi-Fi, Advanced). Also, make sure everything else on that page is unchecked/disabled. Turn off STAMINA mode. Go into Settings, Apps, All, Extended Standby Mode Controller, Clear Data AND Cache. Then go to your text app's (Textra, etc) "App info" page (on same Apps "All" screen) and clear ONLY the cache, then close out the app itself (3D button to the right of the virtual Home button, swipe the text app off the screen). Reset. When you come back, follow what I said above, including turning STAMINA mode back on (note the removal of having to leave "queue background data" off.) Make sure that when you turn STAMINA mode on that the pop-up shows up describing it. If it doesn't at any point, then repeat this paragraph's instructions. What I just said here MAY resolve any lingering MMS issues, and also resolve any issues regarding with STAMINA mode not kicking in too. When I did this my phone spit out a few "missed" incoming MMS messages out all at once. And the battery seems to be last longer too.

                                                                 

                                                                It seems that MMS messages will def show up if Wi-Fi is on, but it will take longer to show up if screen is off. Maybe 3-5 minutes longer.

                                                                 

                                                                If you have any questions, let me know. I'm still testing this out so I may make more changes. We'll see.

                                                                 

                                                                P.S. This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is.

                                                                 

                                                                P.P.S. For whatever reason, if you're getting an MMS message from someone with an iPhone, and they have "iMessage" turned on, the Z3 will NOT receive the message. So you have to ask people who have iPhones and are sending you MMS messages to kindly turn it off, and then all should be fine.


                                                                Steve

                                                              • I like the idea of unbranded devices and BYOD.  However, Android phone maker don't have to power like Apple does.  In order for them to put their phones on the carrier's store, they have to put carrier's apps on it, sometimes even carriers's logo.  Take T-Mobile for example, you can bring an unlocked phone in their network but you'll miss out on WiFi calling.  But unlocked iPhone can still have WiFi calling.  When Apple push out update for their iPhone, all carriers get the same update at the same time.  Not the case for Android.  Why there are different treatment between iPhone and Android?

                                                          • tidbits

                                                            if they do... then all the people wanting Lollipop and what not update start crying and flailing their arms that they have to wait for an update. It's a catch 22 for them. They are to blame either way in the US.

                                                    • ares,

                                                       

                                                      I'm glad at least your Smart Call Handling is back up. I really like that feature.

                                                       

                                                      Regarding the MMS issue though, it may be STAMINA mode that's still hindering it from working. Do you have STAMINA mode on? If so, it and your text msging app may both need their caches cleaned out (and also data for STAMINA, not text app though). I'll update my main post again in a bit, and when I do, look it over. It may or may not help, but can't hurt. If you follow everything I say and are still having issues, I'd honestly consider a replacement (or even different?) phone. I'm questioning doing that myself, but I love this phone, so I don't want to do that just yet. It's also possible that the next update may fix these issues too, but how knows?

                                                       

                                                      RockStar2005

                                                  • **DISREGARD ALL PREVIOUS POSTS!!**

                                                     

                                                    I use Textra as well since the Z3's stock messenger app clearly CANNOT handle MMS properly. This is what worked for me....................

                                                     

                                                    1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

                                                     

                                                    Name: T-Mobile Data 2

                                                    APN: fast.t-mobile.com

                                                    Proxy: not set

                                                    Port: not set

                                                    Username: not set

                                                    Password: not set

                                                    Server: not set

                                                    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

                                                    MMS proxy: not set

                                                    MMS port: not set

                                                    MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)

                                                    MCC: 310

                                                    MNC: 260

                                                    Auth Type: not set

                                                    APN type: default,mms,supl,admin,hipri

                                                    APN proto: IPv4/IPv6

                                                    APN roaming proto: IPv4/IPv6

                                                    APN enable/disable: enable

                                                    Bearer: unspecified

                                                     

                                                    2) Disable Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

                                                     

                                                    3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

                                                     

                                                    4) In Phone settings, under Call Settings, uncheck/disable: VoLTE. For WiFi to work, you must also disable anything else you have enabled on this screen (i.e. Microphone noise suppression, Speaker voice enhancement, etc).

                                                     

                                                    5) You can leave STAMINA mode on (under Power management), however...... only enable the "Extended Standby" option and of course Activation should be at 100%/Always on. When Wi-Fi is on, you must also have whitelisted 2 specific apps in STAMINA under the "Apps active in standby" list: The text msg app you're using (i.e. Textra, etc) and I would also whitelist one under "All others" entitled "Phone/Messaging Storage". Again, this is only for when you have Wi-Fi on. Keep the other stuff disabled in here. With regards to STAMINA mode.......

                                                     

                                                    First, put Keep Wi-Fi on during sleep to "Always" (Settings, Wi-Fi, Advanced). Also, make sure everything else on that page is unchecked/disabled. Turn off STAMINA mode. Go into Settings, Apps, All, Extended Standby Mode Controller, Clear Data AND Cache. Then go to your text app's (Textra, etc) "App info" page (on same Apps "All" screen) and clear ONLY the cache, then close out the app itself (3D button to the right of the virtual Home button, swipe the text app off the screen). Reset. When you come back, follow what I said above, including turning STAMINA mode back on ("queue background data" will be enabled. Leave it that way!) Make sure that when you turn STAMINA mode on that the pop-up shows up describing it. If it doesn't at any point, then repeat this paragraph's instructions. What I just said here MAY resolve any lingering MMS issues, and also resolve any issues regarding with STAMINA mode not kicking in too. When I did this my phone spit out a few "missed" incoming MMS messages out all at once. And the battery seems to be last longer too.

                                                     

                                                    It seems that MMS messages will def show up if Wi-Fi is on, but it will take longer to show up if screen is off. Maybe 3-5 minutes longer.

                                                     

                                                    If you have any questions, let me know. I'm still testing this out so I may make more changes. We'll see.

                                                     

                                                    P.S. This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is.

                                                     

                                                    P.P.S. For whatever reason, if you're getting an MMS message from someone with an iPhone, and they have "iMessage" turned on, the Z3 will NOT receive the message. So you have to ask people who have iPhones and are sending you MMS messages to kindly turn it off, and then all should be fine.

                                                     

                                                    RockStar2005

                                                      • I'm having the exact same issue as OP, and cannot receive any text messages.

                                                         

                                                        I followed your instructions to the T, and still am not receiving any.

                                                         

                                                        I'm not sure what else to do...

                                                          • rockstar2005

                                                            ebonilm,

                                                             

                                                            I'm gonna update my instructions shortly. Apparently my STAMINA mode is not working but I'm hoping the Lollipop update will fix that, or else a factory reset or even replacement? We'll see.

                                                             

                                                            The downside of this is that STAMINA mode may NOT work so well when you disable certain option within it. At least for me it's like that, but again, the Lollipop update may fix that. But if you don't use it anyway then don't worry about it. Just keep it off. The changes SHOULD make MMS work again. Let me know. 

                                                             

                                                            RockStar2005

                                                  • rockstar2005

                                                    **DISREGARD ALL PREVIOUS POSTS!!** (Note changes to #2 & 5.1)

                                                     

                                                    I use Textra as well since the Z3's stock messenger app clearly CANNOT handle MMS properly. This is what worked for me....................

                                                     

                                                    1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

                                                     

                                                    Name: T-Mobile Data 2

                                                    APN: fast.t-mobile.com

                                                    Proxy: not set

                                                    Port: not set

                                                    Username: not set

                                                    Password: not set

                                                    Server: not set

                                                    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

                                                    MMS proxy: not set

                                                    MMS port: not set

                                                    MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)

                                                    MCC: 310

                                                    MNC: 260

                                                    Auth Type: not set

                                                    APN type: default,mms,supl,admin,hipri

                                                    APN proto: IPv4/IPv6

                                                    APN roaming proto: IPv4/IPv6

                                                    APN enable/disable: enable

                                                    Bearer: unspecified

                                                     

                                                    2) ENABLE Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

                                                     

                                                    3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

                                                     

                                                    4) In Phone settings, under Call Settings, uncheck/disable: VoLTE. For WiFi to work, you must also disable anything else you have enabled on this screen (i.e. Microphone noise suppression, Speaker voice enhancement, etc).

                                                     

                                                    5) You can leave STAMINA mode on (under Power management), however...... only enable the "Extended Standby" option and of course Activation should be at 100%/Always on. When Wi-Fi is on, you must also have whitelisted 2 specific apps in STAMINA under the "Apps active in standby" list: The text msg app you're using (i.e. Textra, etc) and I would also whitelist one under "All others" entitled "Phone/Messaging Storage". Again, this is only for when you have Wi-Fi on. Keep the other stuff disabled in here. With regards to STAMINA mode.......

                                                     

                                                    5.1) First, put Keep Wi-Fi on during sleep to "Always" (Settings, Wi-Fi, Advanced). Also, make sure everything else on that page is unchecked/disabled. Turn off STAMINA mode. Go into Settings, Apps, All, Extended Standby Mode Controller, Clear Data AND Cache. Then go to your text app's (Textra, etc) "App info" page (on same Apps "All" screen) and clear ONLY the cache, then close out the app itself (3D button to the right of the virtual Home button, swipe the text app off the screen). Reset. When you come back, follow what I said above, including turning STAMINA mode back on ("queue background data" will be enabled. TURN IT OFF!) Don't enable any of other options there. Make sure that when you turn STAMINA mode on that the pop-up shows up describing it. If it doesn't at any point, then repeat this paragraph's instructions. What I just said here MAY resolve any lingering MMS issues, and also resolve any issues regarding with STAMINA mode not kicking in too. When I did this my phone spit out a few "missed" incoming MMS messages out all at once. And the battery seems to be last longer too.

                                                     

                                                    It seems that MMS messages will def show up if Wi-Fi is on, but it will take longer to show up if screen is off. Maybe 3-5 minutes longer.

                                                     

                                                    If you have any questions, let me know. I'm still testing this out so I may make more changes. We'll see.

                                                     

                                                    P.S. This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is.

                                                     

                                                    P.P.S. For whatever reason, if you're getting an MMS message from someone with an iPhone, and they have "iMessage" turned on, the Z3 will NOT receive the message. So you have to ask people who have iPhones and are sending you MMS messages to kindly turn it off, and then all should be fine.

                                                     

                                                    RockStar2005

                                                      • rockstar2005


                                                        **DISREGARD ALL PREVIOUS POSTS!!** (Note: SEVERAL changes made)


                                                        All,

                                                         

                                                        I use Textra since the Z3's stock messenger app clearly CANNOT handle MMS properly. This is what worked for me....................

                                                         

                                                        Before setting up your Z3 to be able to handle MMS messages correctly, as well as enabling Smart Call Handling to ACTUALLY work, you must do the following which will do both a factory reset AND re-update your phone. My software must’ve been corrupted at some point because after doing this, my phone worked much better. The battery life had gotten really bad but now it’s back to incredible again. My phone works 100% for the first time ever (just no VoLTE ((for now at least)), but who cares, I don't get it in my area yet anyway!!

                                                         

                                                        ** Sony PC Companion Instructions:

                                                         

                                                         

                                                        We have an extended guide that should help you fix the issue on your phone, please follow the instructions carefully:

                                                        Visit this link:

                                                        http://www.sonymobile.com/us/tools/pc-companion/

                                                        Click on Download PC Companion

                                                        Run the software and install it

                                                        Turn the phone off and disconnect it from the computer

                                                        1. 1. No matter what the program says do not connect the phone until you complete step 9
                                                          2. In the welcome screen you will see the different modules available for you including the "Support Zone" option. Click on "Start" below it.
                                                        2. 3. On the next page Click on "Start" under "Phone Software Update"

                                                        At this point if you get an error stating that "Unable to install update components" or "Server is busy" , then please proceed to step 12

                                                        1. 4. The program will say that there is no phone connected. Click on the option below that reads: "Repair my phone" the program will issue you a warning about the content that you will lose during the update
                                                          5. Choose the option to continue.
                                                          6. The program will issue a final message warning you of possible data lost during the update. Click on the checkmark and then on "Next".
                                                          7. After that, the program will download the necessary information (5 to 6 minutes) and it will present you with a list of phones.
                                                          8. Choose your phones model from the list then click on "Next" then you will see a new section telling you how to connect the phone. (don't connect it yet) (YOU CAN FIND YOUR PHONE’S MODEL # BY DOING THIS: SETTINGS
                                                          -->ABOUT PHONE-->MODEL NUMBER)

                                                        At this point the phone must be off and disconnected from the PC.

                                                        1. 9. Connect the cable to the PC not to the phone, then while pressing and holding the indicated button (in the steps on screen an specific button will be shown for you to press on the phone) connect the cable to the phone and keep holding the indicated button until the program says "the update of your phone has started..." (in some cases a message of "Installing drivers" will appear before the message of "the update of your phone has started..."  is shown.)
                                                          10. If you failed to follow the steps correctly the phone will turn on and it will request that you "Proceed with the following steps, slide down the notification bar", If this happens disconnect the phone from the cable, turn it off and repeat from step 9).
                                                          11. If the phone is connected properly, PC Companion will proceed with the update ( It will tell you to let go of the back key) then wait for the update to finish and follow instructions on screen to disconnect the unit.

                                                          Dear Customer,
                                                          12. If "Unable to install update components"
                                                          1. Close PC Companion
                                                          2. Install Java from:
                                                          http://www.java.com
                                                          3. Start PC Companion again and try to do the software unlock process once more.

                                                        Note: If you wish only to update the unit wait for the program to open and then select the quick link on the upper left corner that says "Update Phone/Tablet" and follow the instructions to perform the update. (the PC may request for the phone to be placed in Mass Storage mode. Do this by going into Settings>Xperia>Connectivity>USB connection mode)





                                                        Now that you have completed the PC Companion part, follow these instructions carefully to restore MMS and Smart Call Handling:

                                                         

                                                        1) Add a NEW APN (Settings-->More-->Mobile networks-->Access Point Names ((APN))-->push the + sign button) using these settings (and make sure to select it after creating and saving it):

                                                         

                                                        Name: T-Mobile Data 2

                                                        APN: fast.t-mobile.com

                                                        Proxy: not set

                                                        Port: not set

                                                        Username: not set

                                                        Password: not set

                                                        Server: not set

                                                        MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

                                                        MMS proxy: not set

                                                        MMS port: not set

                                                        MMS protocol: WAP 2.0 <---(DOES NOT APPLY TO THE Z3, BUT OTHER PHONE USERS MAY WANNA TRY IT)

                                                        MCC: 310

                                                        MNC: 260

                                                        Auth Type: not set

                                                        APN type: default,mms,supl,admin,hipri

                                                        APN proto: IPv4/IPv6

                                                        APN roaming proto: IPv4/IPv6

                                                        APN enable/disable: enable

                                                        Bearer: unspecified

                                                         

                                                        2) ENABLE Stock Messenger app, making sure in "App info" screen (in Settings) that the "Notifications" box is unchecked. (Not sure if unchecking it matters, but I'd do it anyway to avoid double notification of incoming texts.) Also, under Stock Messenger's settings, make sure ALL boxes are unchecked as well.

                                                         

                                                        3) In Textra (download this great text SMS/MMS messaging app if you haven't already from Google Play Store), make sure it's your default app, under Settings, "Use MMS for Group Chats" should be checked, MMS Settings: No Limit, and check the T-Mobile Wifi Calling Fix box too.

                                                         

                                                        4) In Phone settings, under Call Settings, uncheck/disable: VoLTE. (VERY IMPORTANT!) (Note: Maybe after Lollipop is deployed you can try enabling it and see if MMS and Smart Call Handling work again, but there’s no guarantee of that.)

                                                         

                                                        5) You can leave STAMINA mode on (under Settings-->Power management), however...... only enable the "Extended Standby" option and of course Activation should be at 100%/Always on. Also make sure “Queue background data” is enabled too. You must also have whitelisted 2 specific apps in STAMINA under the "Apps active in standby" list: The text msg app you're using (i.e. Textra, etc…. the stock app will NOT be listed though) and I would also whitelist one under "All others" entitled "Phone/Messaging Storage". Keep the other stuff disabled in here. With regards to STAMINA mode:

                                                         

                                                        5.1) OPTIONAL: IF AT ANY POINT STAMINA MODE IS NOT WORKING (i.e., WITH IT ON AT 100% POWER, IT SAYS ON STAMINA MODE SETTINGS PAGE THAT YOU HAVE ANYTHING LESS THAN 5 DAYS AND 3-4 HOURS FOR ESTIMATED BATTERY TIME), THEN FOLLOW THESE INSTRUCTIONS: Turn off STAMINA mode. Go into Settings, Apps, All, Extended Standby Mode Controller, Clear Data AND Cache. Then go to your text app's (Textra, stock, etc….do it for all texting apps you have) "App info" page (on same Apps "All" screen) and clear ONLY the cache, then close out the app itself (3D button to the right of the virtual Home button, swipe the text app(s) off the screen). Reset. When you come back, follow what I said above, including turning STAMINA mode back on. Then do as instructed in “5)” above.

                                                         

                                                        6) Put “Keep Wi-Fi on during sleep” to "Only when plugged in" (Settings--> Wi-Fi--> Advanced). Also, make sure everything else on that page is unchecked/disabled.

                                                         

                                                        7) OPTIONAL: IF HAVING ISSUES RECEIVING TEXTS FROM IPHONE USERS WHO HAVE iMessage ENABLED ON THEIR IPHONE, THEN FOLLOW THIS: And lastly, there’s the “iMessage” issue ppl like myself are/were having (also those with LG G2 I’ve heard have this issue too) where when someone with an iPhone sends you an MMS pic text msg while their iMessage option is on, you don’t get the text…….. try this (a T-Mobile store rep told me this and it worked!): send YOURSELF an MMS photo text msg but include at least one other phone # as well too. If you’re using Textra or anything besides just the stock text app, then do this for EACH app. If that is the case, then do it via stock app first then Textra (easier this way). If you receive the pic successfully, then ask anyone you know with an iPhone to send you an MMS message (preferably having a 3rd phone # in on it too, but not sure if you need to) with iMessage ON. If you receive it, then it worked. If not, try this again.

                                                         

                                                        What I just said here MAY resolve any lingering MMS issues, and also resolve any issues regarding STAMINA mode not kicking in too.

                                                         

                                                        It seems that MMS messages will def show up if Wi-Fi is on, but it will take longer to show up if screen is off. Maybe 3-5 minutes longer.

                                                         

                                                        If you have any questions, let me know.

                                                        P.S. This ALSO fixed my Smart Call Handling issue where it wasn't working, but now is.

                                                         

                                                        RockStar2005

                                                      • seriously??? all this needs to be done because Sony and Tmobile dont have their acts together enough to create a phone that can communicate correctly with other phones? The phone only cost $700 brand new its not like it should work or something

                                                          • rockstar2005

                                                            I couldn't agree with you more. As much as I LOVE this phone, and I do, I don't see why I had to go through this extra work just to make my phone work properly. Now, there are prob many people who DON'T have to deal with this. I was just unlucky and therefore did.

                                                             

                                                            Still, I wouldn't trade this phone for anything else, not even the new phones coming out now. Now that it's working, it's IMHO the BEST phone out there............maybe it doesn't have the fastest processor anymore at this point in time, but still......... it has the best interface, a fantastic screen, it's the best looking, it arguably has the best camera (or at least equal to Samsung.....of course Samsung USES Sony parts, as does Apple lol)........ just remember to always use manual mode (for best settings, see my xda post here), arguably the best call & sound quality (including front facing stereo speakers...... I had the M8 and they were great too, so it's close)........ and without ANY doubt, hands down........the BEST battery! Being able to whitelist apps in Stamina mode is the KEY to that. Neither Samsung's S6 nor even HTC's One M9 have that added feature. It allows you to get what you want right away (MMS texts, IMs, etc), and the rest can just wait. I left my phone on standby for 9 1/2 hours the other night (fully charged, unplugged). The next day I checked it and it was only down to like 98-99%, and that's with Location (Battery Saver option) on!! SICKK!!!

                                                             

                                                            Again, if you're not having any issues, and I doubt everyone is, you won't need to do this. But if you are, this will fix it...... at least it did for me. It should really be a one-time thing. I notice that Stamina Mode's battery life projection sometimes may be off, so I just repeat Step 5.1 for that. My hope is that when Lollipop 5.0 gets deployed to my phone from T-Mobile, it will include a FIX for this once and for all. But even with the projection going off sometimes, the battery life remains unchanged, so it's really no big deal. 

                                                             

                                                            If anyone has any questions, please post them here.

                                                             

                                                            RockStar2005