Hello. So this explanation will be a bit long winded but please bear with me. I'll try to make it brief.

     

    My friend recently bought a new phone, and he asked me if I wanted his old Galaxy S4. I said yes. It was on T-Mobile(he lived in Hawaii). He said he would unlock it before he sent it. He contacted Tmo, and had to wait a few days. Then he said "they unlocked it." He sent it. That was back in early December. Flash forward to today, when I finally decided to get service. I bought an AT&T SIM card. When I got home and inserted it, it says "SIM Network Unlock PIN" and has a place to enter that, with two buttons "Unlock" and "Dismiss."

     

    First I contacted AT&T about it. They told me the phone was locked to another carrier, and to contact them. Since I've never personally had service with T mobile, I talked to my friend. He said he was never given a code, and that they just told him it was unlocked. I told him I was pretty sure you needed a code. So I gave him all the relevant info like the IMEI and such, and he contacted T mobile support. Shortly later, he forwarded me an email that contained the unlock code(I starred out the IMEI and code):

     

    _____________________________________________

     

    Thank you for contacting T-Mobile!

    Unlock Request ID= 7518688

    IMEI= 359*******************

    Code = ********

     

    Thank you for taking the time to contact T-Mobile. Below you will see the Instructions for unlocking your Samsung device.  Please be advised a non T-Mobile SIM card MUST be used to unlock this device.

     

    1. Insert a NON T-Mobile SIM & turn Device on

    2. The Device will automatically prompt you to enter code into an empty field.

    3. Click/Tap in the empty field above the "Unlock & Dismiss" options (this will display a key pad on the screen).

    4. Using the key pad input the Unlock Code provided by T-Mobile.

    5. Press the Back button to remove the keyboard from screen.

    6. Click/Tap the "Unlock" option; handset should display "Network Unlock Successful".

    Please note that if you are unlocking a flip device please use steps 1, 2, 4 and 6.

     

     

     

    ____________________________________________

     

    Except it doesn't work. I've tried and tried, and I've read all over the forums. Things I can tell you that I've already checked:

     

    Yes, The IMEI on the support request matches the one on my phone. In "About Phone," with the keypad code to bring it up, and on the phone itself under the battery.

     

    Yes, the AT&T SIM card is inserted.

     

    Yes, I have signal where I am.

     

    Yes, Wifi is off.

     

    Neither him nor I know what else to try. It's kind of a complicated situation, since he had the service with T-mobile, and I have the phone. He is now in Washington, and I am in Alabama. So even if he calls again, he doesn't have the phone with him to do anything and we kind of have to back and forth, which is tricky with him already on the phone with T mobile.

     

    The phone is a Galaxy S4, model SGH M919, running Android 4.4.4 Kitkat

      All replies