Alcatel One Touch Fierce won't turn on?

    i plugged my phone into my laptop to charge it while it was off so it would charge faster. then when i was done i unplugged it and now it won't turn on. i've tried multiple techniques like pressing the power button for 30 seconds while holding the volume up and volume down buttons at separate times. it's fairly new, anyone know what happened and how can i fix it?

     

     

    -oh and i've tried using different chargers but, my phone has a blue light at the top left corner, a charging sign, but it won't turn on.

      All replies

      • tforce_erika

        Re: Alcatel One Touch Fierce won't turn on?

        Hi, thank you for reaching out! Can you please confirm if you've tried charging it on alternate charges in the wall as well as USB, and if you've left it to charge on an alternate charger for at least 10 minutes before trying to boot it up? If so, can you also please try:

         

        Press and hold both the Power and Volume Up key

        In the Boot mode, use Volume Up key to navigate and select Normal Boot

        Press the Volume Down key to select and reset the device

         

        If this doesn't resolve the issue, if there is no physical or liquid damage, and it's fairly new, you are probably in warranty! Please  Contact Us

         

        -Erika

        • tforce_erika

          Re: Alcatel One Touch Fierce won't turn on?

          Hello! It's been more than 36 hours since our last comment so we are now marking this post as assumed answered. You can continue to post, and other community users may respond, but if you would like assistance from T-Mobile or T-Force please create a new discussion.