I'm on a Family account with the 500MB Data Plan. For some reason, my phone switched to 2G and won't go back to 4G. I checked my data settings and the connection is fine. I can get on the internet, but I have an issue sending and receiving MMS messages now. Could it be from going over the 500MBs, or is there any other reasons?

      All replies

      • sneakymoose

        Re: 4G to 2G

        Another thing that will prevent MMS messages from working is Wi-Fi Calling. The WFC software on your Lumia 521 doesn't support MMS/picture messages... Try turning that off and see if it helps. Swipe left from start to see the list of apps, open the Wi-Fi Calling app, and turn it off.

          • Re: 4G to 2G

            Actually, I can send and receive MMS messages, but during phone calls I can't send or receive them. The Wi-Fi Calling feature was already off when this started happening. My phone still says 2G at the top of the screen instead of 4G. Is it because I may have went over the monthly 500MBs, and how can I find out how much I used?

              • sneakymoose

                Re: 4G to 2G

                You can use the My Account app on the phone or log in my.t-mobile.com from your PC browser to check your usage.

                 

                As far as I know, the phone should still say 4G if you are able to get a 4G connection, even when you use up your allotment of high speed data. They just throttle the data over that connection. I could be wrong, though.

                 

                If you go to settings > cellular+SIM, do you see an option to set the connection info? On my Lumia 925 with 8.1 Update, I have a SIM settings screen in there with a "highest connection speed" option set to LTE and a "network selection" option set to Automatic. You should have something very similar on yours, except instead of LTE it should be set to 4G.

                 

                If that's all good, do give a reboot a try. You just hold the power button for a few seconds and then slide down to power off, then power it back on.

                  • Re: 4G to 2G

                    I found the cellular network settings and everything was fine, data connection on and the network selection set to automatic. I restarted my phone and the 4G symbol finally came up.

                    Thanks for the help.