Branched to a new discussion.

Solution to Picture/Group MMS on WiFi

    This was specifically for the Galaxy Note 3, but I am posting it here for the possibility it may be helpful for other Android Phones besides this one. While viewing the HTC One, Galaxy S4 and other pages I saw many people were experiencing Picture and Group (MMS) messaging problems. Obviously the steps may vary slightly depending on your specific phone model but I believe the APN settings should be relevant? If your phones APN settings differ from what is written below, retain your APN setting and only change the two lines that corrected the issue for my new phone.

     

    This is how I fixed my Note 3 from not sending or receiving Group Messages and Picture Messages while connected to WiFi. My phone would not Activate Data to send or receive those while connected to WiFi, resulting in error. The message or picture would try to download but would fail or would not send.

     

    Copy/Paste from my original Discussion.

     

    After two months I have found a solution to Group and Picture messages not being sent or received while connected to WiFi.

     

    It involves the Phones APN settings and was a very easy fix.

     

    Go to /System settings/Connections/More networks/Mobile networks/Access Point Names. Here you will see the APN "T-Mobile US LTE" Click this and copy down all of the information. For the Note 3 it should say

    Name - " T-Mobile US LTE "

    APN - " fast.t-mobile.com "

    Proxy - Not set

    Port - Not set

    Username - Not set

    Password - Not set

    Server - Not set

    MMSC - " http://mms.msg.eng.t-mobile.com/mms/wapenc "

    Multimedia message proxy - Not set

    Multimedia message port - Not set

    MCC - " 310 "

    MNC - " 260 "

    Authentication type - Not set

    APN type - " default,mms,supl "

    APN protocol - " IPv6 " <----------------This is what I changed

    APN roaming protocol - " IPv4 "  <--------This is what I changed

    Turn APN on/off - " APN turned on " checked

    Bearer - " Unspecified "

    Mobile virtual network operator type - " None "

    Mobile virtual network operator value - " Not set "

     

    Under the list of "APNs" at the bottom of the screen you see a "+" sign. Click that and created a new APN using the same exact Settings as the "default" TMO Note 3 APN. But you are going to make a change to theAPN protocol and the APN roaming protocol. For both of those you are going to change to " IPv4/IPv6 "

     

    As soon as I created a new APN and used IPv4/IPv6 for both of those my phone was able to send and receive picture messages and send and receive group messages while still connected to WiFi. I tested this a great deal. I even tested it on different public WiFi.

      All replies

      • I forgot to mention, in order for this to work I had to Change WiFi Calling preference to "Cellular Preferred" or off completely fixed it also. If WiFi Calling was selected as preferred the phone would try to send the MMS through WiFi resulting in error. This was happening because the phone needs an Active Data Connection to send MMS but with WiFi Calling turned on and "preferred" the Data Connection is disabled

        1 of 1 people found this helpful
          • radiocycle

            Re: Solution to Picture/Group MMS on WiFi

            Ah, exactly what I found with respect to the wifi preference.  I kept resending an MMS pic and it kept failing while I was set to WiFi Calling.  As soon as I changed to 'Cell Preferred' it went through.  Pity that, as I love using the WiFi calling feature and made sure the phone I bought had WiFi calling.  Guess I'll just have to turn it off every time I'm here at the house and want to send an MMS pic.  It sure seems like this could be ironed out so it would work in WiFi mode...  I wonder if T-Mo explains this 'quirk' anywhere on the site.  And I hope they will make some effort to make this work in a transparent way so that we don't hve to keep switching back and forth!

             

            Thanks again ravoz for your research and sharing!

             

            radio

            • So basically your APN settings did nothing.  Setting the thing to wifi-preferred means you are not really sending MMS over wifi, you are sending it over the mobile network which is totally not the point of this exercise.  Somebody needs to point this out because your post comes up  on Google when searching this issue and your post is worthless.

                • I apologize for you feeling this post is worthless. A lot of people have been helped by this info and have said thanks, especially on the Note 3 forums and Galaxy S4 forums. Even the new HTC M8.

                   

                  Never has it been said that this was a solution to get MMS to send over wifi. But rather a solution to being able to send and receive MMS group messages and picture/media while being connected to a wifi network. A lot of people, including myself found it quite inconvenient having to choose between being connected to wifi, or turn it off completely to do MMS.

                   

                  I'm no expert in these matters. But from what I read after months of searching is that MMS will not send over wifi. It gets sent exclusively through an active Data connection. SMS can go over wifi. But the actual data portion needs a Data connection.

                   

                  In the months after posting my original thread I've come across numerous post on the internet with people experiencing this problem. Post on Android Central and Reddit for example. From what I've seen is that any phone on T-Mobile that has the wifi calling ability, experiences this problem. The problem falls with T-Mobile ultimately. I was just happy to have found a way to do MMS while in my home and connected to my wifi at the same time.

                   

                  Anyone who brings this problem up on these forums are greeted with Copy and Paste answers by T-Mobile sending them on a wild goose chase of problem solving steps that has nothing to do with this problem at all.

                   

                  I am happy to have helped and hopefully this has helped many many people get past the frustration of not receiving/sending MMS on T-Mobile. Never correlating the problem with the wifi, and wifi calling feature. Exchanging their Sim cards, exchanging their "faulty" phones for another, factory data reseting and generally wasting countless hours and heart ache trying to do something as simple as send a picture to a friend. 

                   

                  Take care and if you do happen to find a method to send and recieve MMS over wifi, please do share in this thread or the others. I would love to be able to do this!

                   

                  Thanks.

                  1 of 1 people found this helpful
                    • I had just purchased a Samsung Galaxy S5 and experienced failure in sending MMS through both my stock messaging and through GoSMSPro.

                       

                      I tested with WiFi on and WiFi off = MMS could be sent with WiFi off.

                      I did the Cellular Preferred = didn't matter but choose to have Cellular Preferred because I noticed I didn't have any cell bars (which is odd where I live)

                       

                      Finally I tried this APN setting and it worked with the WiFi connection on.

                       

                      I'm sorry to the person who said the OP was worthless, but I would like to vouch that it finally worked for me and the instructions were very easy to follow. Thank you ravoz for taking the time to help others with your solution. I don't believe your post is worthless.

                      • While this post states that any phone on the TMobile network experiences this problem, that should probably be amended to say, any Android phone.  My wife has the iPhone 6 and she can send/receive MMS messages over a wifi connnection while having wifi calling enabled.  I have an LG G3...I'm waiting for my 3rd one after the first two had this problem.  Appreciate the info posted here.

                         

                        I am also having issues with wifi connectivity in general and have also missed calls while on wifi calling.  Clearly wifi calling is problematic...a shame since this feature was one of the key reasons I left my prior carrier for T-Mobile.

                  • Thanks for such a detailed post Ravoz, way more helpful than chatting with tech support! Unfortunately for me, this trick did not work for my GS4, but I'm  hoping maybe you can help? Per your notes:

                     

                    APN protocol - " IPv6 " <----------------This is what I changed

                    APN roaming protocol - " IPv4 "  <--------This is what I changed


                    On my phone, both settings were defaulted to "IPv4".


                    I'm wondering, do i just need to tweak them separately (instead of making both say IPv4/IPv6 ?

                     

                    Curious to hear your thoughts, thanks!

                    • Thank you so much!  This completely fixed my problem,  which was so annoying and hampering my work as well.  Thank you for posting!

                      • Will this fix recover messages already received with an error if they were not deleted.  I just received a couple messages that would not download, but they are still in my group messages.  Should I be able to re-download them?

                        • ***This post works!!!*****

                          I created an account only to say this method works. I brought a non-Tmobile phone over from ATT, so no WIFI calling options exist on it. Changing those two settings to IPv4 / IPv6 allowed me to send/receive MMS while connected (but not over) a WIFI network. Thank you for this. Now is there any way to contact T-Mobile's tech support in Bangladesh and tell them to provide this answer in English when calling for help???

                          • WOW..great work..I was having a problem with my phone getting mms and now all is good..Thank you,Outstanding help for us all.

                            • Samsung Galaxy S5 G900V on T-Mobile sim & plan.

                               

                              MMS and text messaging had stopped working for me over data. This did the trick for me and now working!

                               

                              "Under the list of "APNs" at the bottom of the screen you see a "+" sign. Click that and created a new APN using the same exact Settings as the "default" TMO Note 3 APN. But you are going to make a change to theAPN protocol and the APN roaming protocol. For both of those you are going to change to " IPv4/IPv6 "

                              • Was having the same problem on a brand new Samsung Galaxy S6(Non-Edge). This APN setting/New APN corrected the little Network error Bubble when I tried to send an mms/picture message . Thank you very much ravoz, I'm grateful you found a solution.

                                • Just signed up for T-Mob this week and I am having the issue on my LG G3 but in the settings it does not have the following...

                                   

                                  APN roaming protocol - " IPv4 " 

                                  Turn APN on/off - " APN turned on " checked

                                  Bearer - " Unspecified "

                                  Mobile virtual network operator type - " None "

                                  Mobile virtual network operator value - " Not set "

                                   

                                  APN protocol is my last box in the settings.

                                   

                                  I am almost ready to go back to Verizon....

                                    • Ok I have it solved... for now. LG G3

                                       

                                      I have only had the phone for a week and have had this issue. I now have it working again and I can tell you how I did this.. Maybe it is just a coincidence but I had to go in setting > Tethering & networks >mobile networks >access point names. Tap T-Mobile LTE and copy the settings down. Go back to the Acess point names screen and tap the menu button (top right) and create a new APN. Place all of the settings the same as the T-Mobile LTE one except give it a different name and change APN type to default,mms,supl (in this order). Click the menu and save this. Tap the circle to hilight this new acess point. My wife had these settings on her S4 and it was working

                                       

                                      Now go to settings > storage > Cached data > ok

                                       

                                      Restart phone and try texting yourself a SMS and MMS message.

                                    • Ravoz,

                                       

                                      Your consideration is still paying it forward! Thank you. So much frustration for so long gone, because of you.

                                      • I had the same problem and here what I did to fix it and it works great:

                                         

                                        Set APN to: web.omwtoday.com OR fast.t-mobile.com

                                        my wife's phone works with fast.t-mobile.com, mine works with either one

                                         

                                        MMSC: http://wirelessfour.mmsmvno.com/mms/wapenc

                                        my wife's phone works with http://mms.msg.eng.t-mobile.com/mms/wapenc

                                         

                                        APN type: default,mms,supl,fota

                                          • ifert531

                                            Re: Solution to Picture/Group MMS on WiFi

                                            This is what finally worked for me! Thank you!!

                                             

                                            I have a new Google Pixel and am using chomp SMS. These are my settings:

                                             

                                            Name - " T-Mobile US LTE "

                                            APN - " fast.t-mobile.com "

                                            Proxy - Not set

                                            Port - Not set

                                            Username - Not set

                                            Password - Not set

                                            Server - Not set

                                            MMSC - " http://mms.msg.eng.t-mobile.com/mms/wapenc "

                                            Multimedia message proxy - Not set

                                            Multimedia message port - Not set

                                            MCC - " 310 "

                                            MNC - " 260 "

                                            Authentication type - Not set

                                            APN type - " default,mms,supl,fota "

                                            APN protocol - " IPv6/IPv4

                                            APN roaming protocol - " IPv6/IPv4

                                            Turn APN on/off - " APN turned on " checked

                                            Bearer - " Unspecified "

                                            Mobile virtual network operator type - " None "

                                            Mobile virtual network operator value - " Not set "

                                             

                                            After I changed the settings, I cleared the cache and restarted. This is important!

                                             

                                            Hope this helps!!

                                          • gemnof

                                            Re: Solution to Picture/Group MMS on WiFi

                                            The cellular connection settings specified by ravoz did not work for me. The following settings did work for me and is how the TMobile tech support rep told me to do it:

                                             

                                            In Android 5.1.1 (Coolpad Rogue) on TMobile (prepaid):

                                             

                                            1. Disable cellular data (settings -> data usage -> cellular data)

                                            2. Connect to wifi network

                                            3. Enable wifi calling (settings -> more -> wifi calling)

                                            4. Specify "Prefer wifi over cellular" (settings -> more -> wifi calling -> connection preferences)

                                            5. Send MMS message (e.g. Photos -> pick photo -> Send -> Messaging)

                                             

                                            Note: Of course, also enable mms receiving on the recipient's phone.

                                            • ktanaqui

                                              Re: Solution to Picture/Group MMS on WiFi

                                              Thank you so much! This actually let me send my texts - although now we're waiting to see if they arrived to the recipient. My phone /really/ doesn't like sending pictures when I'm at the school. It's very aggravating.

                                              • decqu

                                                Re: Solution to Picture/Group MMS on WiFi

                                                Can someone help me, i'm using LG V20, i can't fix it like u said!!

                                                • danamac

                                                  Re: Solution to Picture/Group MMS on WiFi

                                                  Does anyone know how to resolve this issue with the iPhone 7 Plus? I just transferred over from ATT today, and I can't send group texts or photos.   When I go to cellular and then cellular data options, I do not have the option to modify or even view the APN settings on my iPhone. In the past I was able to view and modify these settings, but not now. I had this issue while I was at Ting for one week as well (Ting uses T-Mobile's network). This is so frustrating. Sigh.

                                                  • jilliansthoughts

                                                    Re: Solution to Picture/Group MMS on WiFi

                                                    This instantly solved my problem!!! Thank you for sharing!

                                                    • derkp621

                                                      Re: Solution to Picture/Group MMS on WiFi

                                                      hi, i signed in just to say thank you and your post is not worthless at all. i didnt bother reading all the other responses, but i use wifi calling. i turn on airplane mode, turn on wifi, and now my phone works through the tower in my bedroom, not down the street. for the longest time, i couldnt send or receive mms messages unless i had some sort of connection to tmobile, meaning, not in airplane mode with wifi calling activated (it says tmobile wifi calling under neath the signal bars in my google pixel notification shade, for those unaware of how to see it), and thought it was the weirdest thing.

                                                       

                                                      your post allows me to now send and receive pictures while in airplane mode and on wifi with tmobile wifi calling activated.

                                                       

                                                      thanks.

                                                      • norgoth

                                                        Re: Solution to Picture/Group MMS on WiFi

                                                        This worked for me, so thank you. I have the new Essential phone and I could not  receive any mms unless I turned off wifi altogether. If wifi was on, then LTE+ symbol would disappear and I could not receive nor send an mms. If I turned off wifi, the LTE+ symbol would return and mms would work. Obviously, I did not want to have to turn off my wifi, so I made the changes listed here AND kept Wifi Preferred under Wifi Calling. Now I can receive and send mms at home while wifi is on. So I guess ,though I am no expert, that having wifi on was disabling my data connection?

                                                         

                                                        Clairification: It was not the issue that wifi was actually on, it was the issue that wifi was on and connected to a wifi signal. Once I left the house and lost the wifi connection, the mms would work again. Just wanted to clarify that.

                                                        • mmcd488

                                                          Re: Solution to Picture/Group MMS on WiFi

                                                          I just changed the APN settings on my new Moto G5s Plus and MMS finally works with WiFi calling enabled! I made sure to clear the cache and restart my phone after changing the APN settings and I was able to send and receive MMS with WiFi calling enabled and set to WiFi preferred. Thanks so much for this!

                                                          • larcodding

                                                            Re: Solution to Picture/Group MMS on WiFi

                                                            I have a Samsung S7 and it worked for me.

                                                            • crescentsaturn7

                                                              Re: Solution to Picture/Group MMS on WiFi

                                                              Great post! This fix worked for the new Google Pixel 2 I have with a few caveats. In the APN type line, I have "mms,supl,ia,hipri,fota,ims,cbs". I tried to add in the default,mms,supl but it wouldn't let me save the new APN with "default" in this line. And then it auto-populated with everything except mms. I added that back in but not sure if that made a difference. I'm hoping this fix sticks. Before finding this post, I had called T-Mobile and was unsuccessful. Looks like they don't have a protocol for dealing with these issues right now and changing the default APN can only be done on their end. You have to add in the fix new locally. The other thing is if you restart (at least for the Pixel 2), it toggles back to the old default APN (the one that doesn't work), but you can't delete that one since it isn't local. You have to manually select the newly created, local APN. Maybe they'll have a fix for that one day too. I'm thinking of calling them back with the new settings and having them update the default APN so I don't have to worry about having to do that all the time.

                                                              • munsellfamily6@gmail.com

                                                                So not sure what my issue is as tried OP suggestion, cleared cache and restarted and no go, so tried ifert431's suggestion and still no go. I have an LG V30, we are new to t-mobile. Service is very limited where we are but I already knew that and was actually just counting on the fact that in our house at least we could use wifi calling with t-mobile. So I am wondering if our issue here is not the same and is a matter of not getting a good signal but I do see 2 bars quite frequently so not sure why mms doesn't work when I have some bars? It doesn't really seem to matter if I have wifi calling on or off either. Maybe the bars are something else? There is no 4G or LTE signal ever here. Any help appreciated.

                                                                T-mobile did try to help and sent out a signal booster which did work a bit but only one spot in house that we could get a bar to show up and so it didn't get good coverage to rest of house when placed the receiver part far enough away for maximum strength. Anyway, I chatted and they are going to send me a 4G LTE cellspot which if I understand right is cell tower that gets signal via your wifi? I'm hoping that will fix all our issues but we'll see. Any thoughts appreciated.