12 Replies Latest reply: Jul 2, 2016 8:58 AM by kathleenmelville60@gmail.com RSS

    Unfortunately, System UI has stopped.

      Hi there how are you doing?

      Thanks for reading this thread. Just recently my 2-month new Samsung t989 started to give me this error messages from time to time:


      Unfortunately, System UI has stopped.


      Anyone experience this before? I'm running the stock ICS ROM (using odin to flash) and did not root the phone. I have about 20 applications installed on the phone, with a 32GB SD card installed. I did not have such error messages before but just started getting this error message since a week ago. Thanks!

        • 1. Re: Unfortunately, System UI has stopped.

          ok never got that befor but then i may have gotton it when i had the htc hd2 and runing android from the sd card, since you used odin only and not kies? to do the ICS update then i would go do it again seems something got missing from the update maybe you had unplug it to soon it will only take a second of lost info to make a rom update become unstabold this did happen to me with the hd2 when downloading android i just re did the download and waiting a bit more then befor and yup work fine afther, you can also do a systems cache clean up to see if that helps frist, to do so just turn phone off i say take the battery out then the sim card and sd card then wait 15 seconds put sim back then sd then battery then hold down upand down volume i say put your finger right in the middle then hold power when you see the samsung come up on screen let go the power but keep holding the volume up and down then a green android will show up then let go volume then you will also see blue wording use the voulme down to go to clear cache pertition then hit power botton let it clear you will see it in green saying its done then make sure reboot is highlighted in the blue if not volume to go there then hit power then it will reboot.

          • 2. Re: Unfortunately, System UI has stopped.

            I'm assuming a simple reboot/battery pull doesn't fix this, so I'd try a factory reset before reflashing the whole ROM.

            • 3. Re: Unfortunately, System UI has stopped.

              Yes a simple reboot/battery pull did not fix this. If I go ahead with factory reset what data would I lose? thanks!

              • 4. Re: Unfortunately, System UI has stopped.

                you will lose all data email sign in text messages music pictures you have saved in the phones memory, so if you have stuff you have not saved to the sd card i would do so befor reset, but then in setting go to back up and reset there you will have the options to back up some data, but if you do you may end up backing up to the same as you have now and may still have the problem, so a clean reset with out back up may help so for that unmark all backups.        note i always try other options but then when all fails yup a clean reset always help.

                • 5. Re: Unfortunately, System UI has stopped.

                  I did one experiment. I pulled the 32GB microSD card and now I don't see the "Unfortunately, System UI has stopped" message... Maybe that's related to the fact that I had way too many apps installed? I think I had over 40-50 apps installed in the phone memory and the microSD card...Did anyone experience similar behavior and were you able to get it fixed? Thanks

                  • 6. Re: Unfortunately, System UI has stopped.

                    Update: the "unfortunately system ui has stopped" error message usually come with the "TwLauncher is not responding" message as a follow up, so I replaced the twlauncher with the Go Launcher and so far so good... seems that the problem is much better now. I gotta say that I'm really impressed with Go Launcher.. almost feel like I upgraded to a new phone.. came with many features.. I would highly recommend it..

                    • 7. Re: Unfortunately, System UI has stopped.

                      IF you're running ICS, check out Apex Launcher. It's similar to GO, except based off the ICS/Jelly Bean launcher.

                      • 8. Re: Unfortunately, System UI has stopped.

                        @jaylanphnx, thanks for your tip. I will definitely try it out!

                        Another quick update, after switching to Go Launcher I'm still getting that System UI has stopped working message. So I guess I really need to do a factory reset.... will update later

                        • 9. Re: Unfortunately, System UI has stopped.

                          OK, so I tried to uninstall about 10 - 15 apps (most of them games that I don't use), and now it seems that it's more stable now (less "system UI has stopped" message poping up). However, when I unlock the phone, sometimes it's still not really responsive, and everytime when I get a notificication (e.g. a new email or a new update is available for one of the app that I have), that weird ringtone "Faint" will still go off with loud sound like crazy, which I still can not resolved. I tried Menu-->Settings-->Sound-->Default notifications and the current notification sound is set to "moonbeam" and NOT "Faint" and there is NO references anywhere that I set to use any notification or sound with "Faint" but somehow it's just chosen... does anyone has such experience?? Thoughts or comments?


                          Sorry to get devolved... the origial thread about this "Faint" is here.

                          • 10. Re: Unfortunately, System UI has stopped.

                            After I tried all different solutions, I finally decided to do a factory master reset and that totally fixed this problem. I learned an important lesson which is NOT to download too many Android Apps all at once... maybe try out 1~2 (at most) every day, instead of installing whole bunch of them in one day

                            • 11. Re: Unfortunately, System UI has stopped.

                              Thanx so much!  Your the MASTER!  Fixed it perfectly!!!  Thanx so much again!!!

                              • 12. Re: Unfortunately, System UI has stopped.

                                In so sorry!! I know in not in the right forum nor am I replying to you specifically. In about to go out of my mind!! I switched from metro pecs due to extreme poor service on my device and with customer service. Went to t mobile. In getting error message...eE911error. I need to check the 911 address. On my phone and make sure its correct. I cant access any place on any t mobile area any addtess to do this! I followed all directions about updating billing and 911 address but I cant access or edit or post or check anything. In a month to month customer. Not on any contract. Don't know if that has anything to do with it. Honestly guys. What am I suppose to do?