Home Internet - Port Forwarding not working

magenta7828038

    I received and configured my LTE Gateway, TM-RTL0102 about a week ago. It works almost perfectly. Speeds are solid, both up and down. Only problem is that port forwarding isn't working. I've got the virtual servers configured on the Gateway for my home security cameras and RDP to my office computer, but neither is working. Is this a feature that's not available yet? If not, I might have to hold up on using the service as it's definitely something I'd like to have working, especially the security cameras.

      All replies

      • tmo_chris

        I cannot find any settings for port forwarding in the GUI. I do see NAT, UPnP and, ALG https://support.t-mobile.com/docs/DOC-39518#app8

         

        Where specifically are you configuring the port forwarding?

        • magenta10158371

          The virtual server/NAT settings are port forwarding. For the internal IP just put the port you are forwarding. If it is a range I usually do 30 below the highest number.

           

          It works. My xbox now has full upnp as well ad open nat unlike on the mobile hotspot through my phone. Port forwarding for mobile hotspot would be great

            • tmo_chris

              Glad you could get it working! Not sure we are gonna be able to do advanced network config stuff on a smartphone mobile hotspot as it is simply designed to provide internet to other devices and not networking.

                • magenta7828038

                  Still not working for me. I've got ports 8080-8080 forwarding to port 80 of my desktop PC's static IP address. And 4009-4009 forwarding to port 3389 of the same IP for remote desktop access. These worked perfectly fine using my Spectrum coax cable modem/router, but not working on the LTE Gateway.

                  • aes

                    Re: Home Internet - Port Forwarding not working

                    Chris,

                    I was offered T-Mobile Home Internet Friday evening. The sales rep was very nice but could not answer some of my pressing questions. I understand as she wasn't trained at that level. I would prefer bridge mode for the gateway. I was told Sunday by Tech Support the Gen 1 gateways do not support. It is "rumored" that the next gen will support bridge mode but no confirm rumor or expected date. I access a single board controller and Node-Red from the outside now with a land DSL service. No problems there but T-Mobile is much faster at a lower cost if I change to VOIP. Tech Support told me they could not give me a static public IP as I have now. My after the sale research shows that LTE type Internet doesn't work the same and that's not going to happen. Even with a static public DHCP and a DDNS it looks like double NAT'ing is the only remote possible option. The bottom line is I need to be able to log into my Raspberry Pi and Node-Red port from anywhere. It looks like even with bridge mode the lack of an IP address I am still out of luck. I would not be so terribly opposed to a DDNS service but search engine research indicates this is not possible with T-Mobile LTE Home Internet. l I just don't think this is prime time unless unless you want to play on social media and check email. Please tell me I'm missing something. Regards, Alvin

                      • tmo_chris

                        Re: Home Internet - Port Forwarding not working

                        Hey aes 

                         

                        The folks over the phone are gonna know more about the service than I do personally and if they are saying that it is not going to work for what your needs, it may be best to hold off on our service

                         

                         

                        magenta10158371 - I posted the direct line to the home internet support folks above. Please give them a call for some advanced troubleshooting.

                  • magenta10158371

                    A fee other things I have noticed is when I change the internal IP address in the virtual server, it locks all entries in to whatever I entered last. Ie. 7 entries for xx.x.130 to the xbox and 1 entry x.131 for the switch ranges. The 7 entries will all lock to .131.

                     

                    Additionally, port forwarding does seem to work if I only have the 7 xbox entries and no other device connected to the network. They seem to work, even if double nat'd.