Coolpad Snap: browser fails after day 3 of new phone (solution?)

pyatrus5145

    All in all, happy with Coolpad Snap, but of course, there are issues (mine, Coolpad's, & T-Mobile's, right?)  ;-)

     

    Not sure whose issue this is: Browser stopped working on day 3. Starts up briefly but closes/crashes in a blink. Restarting phone doesn't help. Did NOT change any browser setting since it worked last (earlier today). Now I cannot access anything within the browser (e.g., settings, bookmarks, clear cache, etc.).

     

    Did I mess up a setting somehow or? 

     

    Thanks in advance.

     

    PS  If anyone learns of a source for the Coolpad battery ("Coolpad CPLD-194"), please let me know. It appears there are none (yet) in any supply channel.

      All replies

      • gramps28

        What browser? Have you tried to uninstall the re-install it?

         

        I had a Coolpad phone on an MNVO and I couldn't even find a case for it so

        good luck finding any accessories.

          • pyatrus5145

            The Coolpad Snap (flip-phone aka feature phone) is said to come with Android 8 (Linux 3.18 core), and of course is very stripped down -- for Android. (It's only been available since March on T-Mobile, AFAIK.  There is no editor, other browsers, access to much of anything. etc.)  I was able, however, to import my Contacts list from Google Contacts (with all of the fields coming through), which I thought was pretty nice. The phone itself came out Oct-Nov. 2018; mine was manufactured in January 2019.

             

            There is also an "HTML viewer" app (that's its name) that allows you to view local html and .txt files (no PDFs and also had trouble w/log files, it seems, which should be simple text files), but not access the Internet.

             

            The Web browser is "Ume browser version FP 1.33."

             

            There is no Google Play store access or other access to anything. The only way to contact anything "Internet" was through the Ume browser, and that doesn't work (can you say "Catch 22"?).   ;-)

             

            I guess I'll check with Coolpad support. Best.

            1 of 1 people found this helpful
          • pyatrus5145

            Short answer: No fix yet (AFAIK), though Coolpad (the mfr) appears to be working on it.

             

            Long answer:

             

            I tried two different phones (one I purchased direct from T-Mobile online & one at a T-Mobile storefront) with the same results (no sense in exchanging for another Coolpad Snap, IMHO; they all have the issue, AFAIK). I've also contacted Coolpad Snap support and Ume Web browser support. Only Coolpad Support has responded. I also filed a "trouble ticket" with them on this issue. They actually phoned me this morning and after going through all of this info with them again, they said they would escalate the issue with management.  :-)

             

            The following lets me "workaround" whatever is broken, and access the Internet for one "time/one event" (e.g., such as a search, checking e-mail, reading the news or weather). The next time I start the browser, the browser crashes, and I have to complete the following steps again. (I can live with this for now. I didn't buy the phone for Internet access; the phone has some very nice features for a great price (thank you T-Mobile!), though I am not sure about its durability.

             

            A Coolpad Snap "Community Manager" offered the following suggestion (on clearing the memory so the Ume Web browser can restart).

             

            "Give this a try: Go to app, settings, device, storage. Scroll down. Select other apps. Select browser. Clear data. Clear cache."

             

            If you have installed a microSD memory card, there will be a sub-menu after Storage. Choose "internal shared storage." To select "browser," you will probably have to scroll up (you are not at the top of the list; apps are listed in order of memory used, with most used at the top. Once you clear the data (it will also clear the cache at the same time; you don't need to select "Clear Cache"), it will be listed in a different order (if you happen to go back into this list.

             

            The Ume browser should start. You will have lost all bookmarks, browser history, and settings. I found that changing, in the browser settings menu (left soft key while in the browser), from the default Bing search engine to the Google search engine (the only other choice), makes the Ume browser a bit more reliable. Sometimes Bing searches would come up "Web page not found," etc. Every time I exit the Ume Web browser and try to access it again, I have to go through this little process.

             

            Yes. Whatever is broken, misconfigured, etc., is still that way, but this process works for the time being (a fix is on the way?  Let's hope so.)

             

            Best wishes!

              • jaykay2323

                Thanks so much!  That workaround is the same for me.  browser works as a one time event.  I put in a ticket to Coolpad as well. Let's see what they say!  I tried the display Coolpad Snap phone in a T-mobile store the other day and the browser worked.  I think I exited and went back in fine. But I'll go back to the store and check again.

                  • pyatrus5145

                    In the past week, I have tried the Ume Web browser (version FP 1.33, original distributed SW) on two T-Mobile Coolpad Snap phones:

                     

                    1) The browser worked for 2 & 1/2 days on the first one. Then the pattern of failure we've been discussing (& the workaround) is the only way to get it (one time, etc.) to work.

                     

                    2) I tried another out-of-the-box Coolpad Snap at a T-Mobile retail store; no working display model there (at that time considering exchanging my bad phone, but of course, changed my mind since it's apparently NOT a specific device issue). Once I set up this second phone (my SIM, etc.), it failed right away.

                     

                    Let's hope Coolpad has received enough feedback to get them to fix this issue (wherever the issue may be: they may need to get the Ume Web browser folks to fix it, or recompile/patch/etc., the Linux Kernel/Android OS, or wherever. I'm sure they can find and solve this issue).  :-)

                     

                    best wishes

                      • tmo_mike_c

                        Yikes, that's pretty strange for this to happen. I don't see any known issues like what you're describing. Have you tried a complete factory reset? That could help bring it back to normal and get the browser working.

                          • jaykay2323

                            Yes, I also contacted coolpad. they called me and we did a factory reset. still doesn't work.  they said they'd call me back in a few days. 

                            • pyatrus5145

                              Yup.  It's a known issue if you look at the online discussions including Coolpad Snap's support forum.  IMHO, these days, it's hard to give feedback since few formal channels exist (as far as I can find). 

                               

                              Also, I would make a wild guess that 99% of Coolpad Snap users (also a very small group as it became available in March 2019), buy the phone NOT for the Ume browser/Internet access, but the other very nice features (form factor, LTE, VoLTE, Wi-Fi calling, easier text messaging (thru the Android OS), price, etc. Therefore few people are testing ALL features of these feature phones.

                               

                              I tried a factory reset on TWO out-of-the-box new phones (as did someone else reporting to the online forums), after each phone failed to connect to the Internet browser after one success or not at all. Each phone would connect one time, then fail. the steps of clearing the browser's data allows us to use the browser, again for ONE TIME, then need to be reset (i.e., Ume app, memory data "clear data", etc.).

                               

                              I've discussed this with Coolpad Support. A community manager on that forum states Coolpad acknowledges the issue and it is being addressed ("we are investigating this and working on a fix"). Stay tuned.  :-)

                               

                              I personally encourage any other Coolpad Snap users to contact Coolpad Snap support since the more feedback they receive (on this or any issue you experience), the faster they can address and fix (if needed) whatever the issue is.  (IMHO, ever since we switched from the development model of desktop PC and software to the world of mobile devices and apps, it seems to me Q/A testing has been "shortcut" (or missing entirely?) and app and device makers depend on end users as their Q/A testers.)

                               

                              Best.

                                • tmo_mike_c

                                  Bummer, but thanks for testing the reset. I'm gonna reach out to my internal folks and see if I can find more info on this issue. Can you tell me what version of software your phone is showing?

                                    • pyatrus5145

                                      regarding HW/SW (firmware version): AFAIK, there is only the out-of-the-box version (as well as for hardware). I hope there will be an update "soon" from Coolpad, BUT the browser/Internet access is NOT one of the most important features of the phone.

                                       

                                      manufactured 2019/01/22

                                       

                                      Baseband Version: 909_GEN_PACK-1.183452.5.186908.2

                                       

                                      Kernel Version:

                                      3.18.71-perf (gcc version 4.8 (GCC)

                                      builder2@builder178 #1

                                      Wed Jan 23 16:40:26 CST 2019

                                       

                                      Build Number: 8.1.3911A.TMO.190121.33

                                       

                                      Hardware Version: V1

                                       

                                      Ume browser version FP 1.33

                                       

                                      a side note. NO batteries are available anywhere (which is NOT great planning on someone's part; it's not unusual for such batteries to need replacement):

                                      battery: Coolpad CPLD-194  (mfr date: 2018/11/14)

                                       

                                      another side note: 5G, Wi-Fi, i.e., 802.11a, is NOT supported (only 2.4G, 802.11 b/g/n). I had difficulty setting up Wi-Fi because I assumed ALL 2018-2019 devices would support 5G.  silly me!  ;-)