After latest update, GS9 keeps defaulting to Cellular Preferred over Wi-Fi calling

drinktigermilk

    I have very poor (but existent) cellular coverage in my home.  I had no problems with setting Wi-Fi preferred for all of my calls/texting prior to the latest (large) update.  Now, I can select Wi-Fi preferred under Wi-Fi calling, however it never seems to save that setting.  As I am typing this, I have two outgoing messages that aren't sending (spinning circle) because the phone can't decide whether it wants to use Cellular or Wi-Fi.  I want it to use Wi-Fi because I know my Cellular coverage is horrible at my location.  I called into customer service today (somehow without a dropped call) and they made some adjustments on their end, however it fixed nothing. 

     

    Even after selecting Wi-Fi preferred, I will go back to check a few minutes later and the phone has already switched itself back to Cellular preferred.  This is very frustrating.  What can I do to ensure that Wi-Fi preferred will be the default setting?

     

     

    Thank you

      All replies