MMS not working for my one + 6

sjoe

    First off let me start by saying, T-mobile, your website disgusts me. rarely do i have the displeasure of navigating such an asteroid field of incompetency of UX. my first note on that is your little "message us on my T-Mobile" button is worthless, since THERE'S NO WAY TO MESSAGE YOU FROM "MY T-MOBILE"... Second, there's the /community/contact-us page. a couple things about this page, is there's no reason whatsoever for a "self service" section. it's a contact us page, not a fix my own problem page. if it were possible for me to fix my own problem, i wouldn't need to contact you would I? The other thing is your "message us" link is SUPPOSED TO send you to my.t-mobile/contact-us.html however that webpage doesn't exist and it redirects you to prepaid.t-mobile.com/account-landing, with a message that says "!bad request". yup, back to that useless pre-paid my tmobile garbage webpage. 

     

    yall need back end and front end teams that both speak the same language, because this is obviously the work of having to talk amongst yourselves using google translate.  

     

     

    onto my real problem which shouldn't have to exist in the first place due to the absolute ludicracy of being one of probably 50 people on earth who have had this problem with yo.... 

     

    I'm unable to send or receive pictures by text message. in other words my MMS isn't working. the only way i can send a picture, is to go into airplane mode, and then connect to wifi.

     

    before you suggest the cookie cutter troubleshooting solutions, I have: 

     

    • restarted my phone (hard and soft)
    • factory reset my phone
    • tried from different wifi networks
    • tried from 4g
    • I've tried the solution as described here BYOD T-Mobile data & APN settings which did not work
    • I've tried a different messaging app like google's messenger

     

    It's worked for the past several month, however a few days ago i just woke up to a barrage of failed-to-receive pictures and i'm incredibly pissed at the user unfriendly website that you have and the lack of usefulness of the <10 mentions of this problem on the entire internet.

      All replies