Is there a fix for visual voicemail (VVM) for Moto x4 with Android 9?

tiredangel

    I spent 3 hours on the phone with both T mobile tech support and Motorola.  The conclusion seems to be because Android 9 installed its own version of Visual Voicemail, it seems to have disabled access to the third party app by T-mobile.  However, the native Android app won't connect to visual voicemail either.  T-mobile tech support stated they are not willing to look into it because none of the phones they offer allow android 9 to be installed at this time, so since I use a factory unlocked phone... sorry about your luck .  They also will not file a ticket for it to be addressed by their engineering team until T-mobile rolls out Android 9 compatability regardless of the number of phones impacted which from looking at other threads is a fair number.  I actually like T-mobile and don't want to jump ship... but I need a functional voicemail and even if I bought a new phone... it still won't be compatible with this issue since they all come with Android 9 now.  Anyone of you come up with a solution?

     

    Yes... I've tried "turning it on and off again" i.e. install, reinstall, settings changes, reboots and more.

      All replies

      • snn555

        Take a look at these screenshots.  I don't remember ever setting a voicemail PIN.

        Screenshot_20190129-043745.pngScreenshot_20190129-043755.pngScreenshot_20190129-043826.pngScreenshot_20190129-044038.pngScreenshot_20190129-044114.png

         

        The only other help I could give would be to download the T-Mobile vm app, which will disable the Moto vvm and then set up tmo vvm app, then uninstall it.  That seems to trigger the Moto vvm. Lastly, the X4 community on Moto support community may help as well.

         

        I have not had an issue with Moto vvm since I got the phone with Android 7.

        2 of 2 people found this helpful
        • tmo_chris

          Hey tiredangel 

           

          Just checking in here to see how things are going? Did the suggestions and screen shots from snn555 posted help you at all? With the x4 supporting Android 9, it is tough since we do not yet fully support that SW on any of our devices. The X4 community may have more information on this as snn suggested. 

          1 of 1 people found this helpful
          • magenta7754050

            Hey Tiredangel,

             

            In reading your post, i see you are having issues with VVM - however, i'd like to ask if you do get notified of the existence of a voice message - waiting to be picked up (even though it may not be a VVM motification)?

            The reason i'm asking is that - i have the same X4 & upgraded to Pie - but in my case along with the VVM (from motorola) not working; i simply do not know if there is a VM waiting. So i have to call into the VM service blind every time i have a missed call.

            Depending on your response, i may pursue this with Chris or some SME here. Thanks.

            • magenta5036904

              This irks me. I don't use visual voicemail but apparently it is an integral part of the voice to text feature in the phone. So I lost my voice to text when the last update came in about May 2019. TMobile told me it was because I had an old phone and my Android version was too old. I almost bought a new phone, but when I checked the google play store site, I saw literally thousands of complaints exactly similar to mine. It is all because of the latest update. Every person who had problems said they had just updated and that was it, it didn't work anymore. Tmobile wants us to think it is a problem with our phones, I dont think so, there is something wrong with the code of the update. That needs to be fixed. The big problem is, not updating is not an option. That feature won't work anyway if you don't update, and it won't work if you do. Come on Tmobile you need to fix this, at least make it so we can un-install and go back to what we had.