Can't send and recieve mms messages on Moto g6 help please?

magenta5771629

    I have followed threads for help, called T-Mobile support, Best Buy did nothing for me where I got the phone, and I finally found did this: BELOW,

     

    BUT STILL NOT WORKING

     

    Can anyone help me please?

     

    Thank You in advance

     

     

    [Solved] Tmobile Moto G6 phone will not send or receive MMS messages

     

    I had this problem on a my new phone. Found the solution on a T-Mobile forum but it was difficult to find. This post is to link back to the correct solution so it’s easier to find and to save the correct solution:


    https://support.t-mobile.com/thread/146169

    The problem has to do with the phone’s APN settings – which need to be tweaked.

    1. Access your Android phone’s settings (gray settings icon that looks like a gear).

    2. On the settings menu – select “Network & Internet”

    3. On the “Network and Internet” menu – select “mobile network” (which should say “t-mobile” beneath the words “mobile network”)

    4. On the “mobile network” menu – select “Access Point Names” (often abbreviated APN).

    5. On the “APNs” menu – you should see two options: “T-mobile US” and “Tmobile MMS”. There should be a green dot next to “T-Mobile US”. Select that “T-Mobile US” option (NOT the Tmobile MMS).

    6. This will open an “edit access point” menu, and you will need to make the following edits:

    First – click on the MMSC option and add the following text: mms.msg.eng.t-mobile.com/mms/wapenc

    Second – click on the “APN type” option. It will probably say something like: “default,supl,hipri,fota” (without the quotation marks). You will need to tweak the end of it so the whole thing instead reads “default,supl,hipri,fota,mms” (without the quotation marks). As indicated here – there are no spaces between these commas.

    Third – after making these two adjustments to your APN – make sure you click on the menu dots (three vertical dots) at the top right hand part of the “edit access point” menu. This will open up a drop down menu – and then you should select “Save”. If you don’t do this – the settings will not take effect.

      All replies