Not receiving text messages from Verizon customers

getoffmylawn

    Hello,

     

    I switched from Verizon to T-Mobile a little over a week ago. Number ported in fine, and I've been able to make and receive calls fine. I've been able to make and receive texts fine. EXCEPT for with Verizon carriers. With Verizon customers I can text them, but cannot for the life of me receive texts from them (excluding iMessages of course). The only caveat to this is I do receive them in a group chat.

     

    I've worked in the cell phone industry for quite a few years, and overall am pretty tech savvy. I can confirm this is definitely not a hardware or software issue on my phone. I've called T-Mobile support multiple times... and bless them, they really do want to help, but their limited scripts focus on my phone (which is not the issue). They're rebroadcasted, rebooted, even reset my account, all to no avail.

     

    I'm convinced this is some back end issue with the SMS aggregators (more than likely because this number was ORIGINALLY from a google voice line). I can't for the life of me seem to move up the chain of support with T-Mobile to somebody who understands the backend. Unfortunately, this is my work number, and I can't afford to loose this number. This is my last ditch effort to get this thing working. Please help!! Much thanks.  PS - I've never had a ticket filed or anything, so if we could get that rolling I'd appreciate it.

    And 

    Thanks again,

     

    Nick

      All replies

      • smplyunprdctble

        Transfer your phone number to T-Mobile

        Sounds suspiciously like Dual Service.  But, that should happen for only 24 hours max.

         

        Have you contacted Verizon to verify your port fully went through?  It sounds like Verizon hasn't updated their system to show your number moved.

        1 of 1 people found this helpful
        • tmo_mike_c

          I agree. It could be an unusually long dual service situation. If you've contacted Verizon already and they confirm the port completed on their end, you'll want to have our Team of Experts or T-Force team file that Trouble Ticket for this issue. You can get to either group using the options on our Contact Us page.

          • arthurnip

            Hi, I was wondering if you had this resolved? I am currently facing the same issue for 5 days now after I ported my number from Google Voice. I'm able to sms Verizon users fine but can't receive any sms from them. Mms works both ways.

             

            If you got this fixed please let me know what you did.

              • getoffmylawn

                Hey there. I’m sorry you’re having this issue, it sucks! And t-mobiles front end support kinda sucks... I did get it working though. I eventually had to plead to open a ticket and get it sent up to the engineers to work their magic. Within about 48 hours I got a message saying it should be fixed. Sure enough, I was able to receive messages. Get it sent up the chain of support to engineers though! Front end support does not have the capability to fix this, no matter how many reprovisions, resets, resetting of network setting, rebroadcasting they do. Good luck to you!!!

                 

                Nick

                 

                Sent from my iPhone

                  • arthurnip

                    Well, they opened up a ticket to their engineers 3 days ago with a few Verizon numbers I provided them and someone today told me it was fixed and those numbers are coming through the network. However when I checked I'm still not getting SMS from Verizon. They then got me to get a new sim from the store which I just did and that didn't work. Then they cancelled my line and reactivated it and that didn't work... So i'm still stuck... Not sure what to do but I'm still talking to T-Mobile help online and doing everything they say.

                     

                    Also if it's not even showing up as Incoming text in my Phone Usage online, doesn't that mean those numbers aren't making it to the network? Or does it not show up online unless my phone actually receives the text?

                • magenta5215715

                  I am having a similar issue (number ported from Google Voice & not getting SMS messages from Verizon users). Spoke with one of the T-Mobile network engineers, and they confirmed that SMS messages from Verizon are not reaching the T-Mobile gateway (maybe still going to Google Voice?). As a solution, they said that one of my friends on Verizon should call customer support to report this. Had a friend do this, but Verizon reported that they are experiencing no issues on their end. So I am stuck.

                   

                  Nick (getoffmylawn), do you happen to have contact information for the person at T-Mobile that got it working for you?

                    • magenta5215715

                      I'm happy to report the issue has finally been resolved! For those still having similar issues, have T-Mobile create a trouble ticket to the intercarrier messaging group. It is my understanding that two attempts were made with the intercarrier messaging group. During the first attempt, Verizon informed T-Mobile to have a Verizon customer create a trouble ticket. However, during the second attempt, "forceful" messaging was used to finally fix the issue. Hope this helps others!

                      • arthurnip

                        I also got it resolved, after numerous rebroadcasts, account deletions, etc. they then told me to get my friend to call Verizon which resulted in Verizon saying nothing was wrong on their side. Then they finally fixed it the next day and told me they "resubmitted the port over to be redone" which I'm sure is just a layman's description. So I'm not exactly sure what they did. But it took them 5 days since the original complaint to get it resolved..

                        • getoffmylawn

                          I don’t know who it was. The key for me was simply opening a ticket. I’ve had multiple issues with T-Mobile since I’ve joined, and every single time, “opening a ticket” solved the problem within 48 hours. I just had to be very adamant with front end support that I don’t need their help... they always send me through a loop of things that didn’t work. Good luck!

                           

                          Nick

                           

                          Sent from my iPhone