How to enable WiFi calling overseas?

magenta6656415

    We use our iPhone 8s overseas a lot.  We are very good about making sure the WiFi is on before accepting or initiating a phone call.  However we still wind up spending money if the WiFi drops even for a moment.  When I make or receive a WiFi call overseas, I don't want overseas cellular to hijack the call.  I'd rather the call drop then have the convenience of spending a lot more money than I intended.

     

    So whether it is on my iPhone or my T-Mobile profile, how do I set it up so I never incur charges for using overseas cellular carries.  Please don't say check the phones before each call because my phone bill is proof that approach isn't working.

      All replies

      • tmo_mike_c

        Re: How to enable WiFi calling overseas?

        Hmm, that's a tough one. The only thing I can think of is if you have an option to turn off cellular entirely. One thing that could help make sure you stay connected to Wi-Fi is to stay within a reasonable proximity to the router. Sometimes even a reboot of the router could help as well as rebooting the phone and reconnected to Wi-Fi after it restarts.

        • drnewcomb2

          One way is to put the phone into airplane mode then turn WiFi back on. I don't know if the iPhone has the setting to use WiFi always, prefer WiFi or prefer cellular.

           

          I generally set the phone/network to forward all incoming calls to voicemail, except when I'm on WiFi. This prevents charges for unanswered calls. Also, it's good to have a backup VoIP app that allows calling out. I find that T-Mobile's WiFi Calling sometimes doesn't work when other VoIP solutions do.

          • tmo_mike_c

            Re: How to enable WiFi calling overseas?

            Hey there!

             

            I think the airplane mode is a good idea. Please test that out and let us know if that helps.

            • tmo_amanda

              Hey there!

               

              I wanted to chime in to add one more thing to the list of recommendations. You can disable cellular by turning off the below setting found in the drop-down command center:

               

               

              This should force you into WiFi only mode and prevent those extra charges.

                • magenta6656415

                  Re: How to enable WiFi calling overseas?

                  The airplane mode is the way to go to avoid cellular calls.  However there is one downside in that I can't access cellular data while in airplane mode.  So if I am going back and forth between WiFi and Cellular Data, I run the risk of either A) Leaving Airplane Mode ON when not in WiFi Coverage and not having access to Data or B) Leaving Airplane Mode OFF when in WiFi coverage and having accidental cellular calls even when I'm supposed to be covered.  Or I could accidentally answer a phone call when I'm outside WiFi coverage.

                   

                  Going forward, I'll rely on Airplane Mode (and hopefully remember to turn on/off at the right times), but there should be a third way of blocking cellular phone calls but not cellular data at the same time.

                   

                  I wasn't specific enough in my original title.  It should be "How to Enable WiFi ONLY Calling?"  Sorry for any confusion.

                    • stevetjr

                      Re: How to enable WiFi calling overseas?

                      From everything I have heard (since I have never had an iPhone) from when Apple finally added the option for Wi-Fi calling they didn't add the option like the Android's have which is to set which is the Preferred so it will always try to use one over the other.  I have heard from friends similar issues when overseas that it will randomly sometimes switch back over to cellular without warning thus leading to a surprise $$.  But in my years helping on the forum I have never heard anything other than the airplane mode trick or disabling the cellular altogether.  

                       

                       

                      Screenshot_20181121-144359_Wi-Fi Calling Settings.jpg

                      1 of 1 people found this helpful