Samsung Galaxy S6: missed calls, straight to voicemail. Data works

ltcmddata

    I have a Samsung Galaxy S6 (SM-G920F), and for the past months (at least) I have been having the problem that incoming calls go straight to voicemail. The phone does not even ring. I have full reception, and I can make calls. It's just incoming calls that miss. Data works fine, too, so incoming Whatsapp messages arrive just fine.

     

    Checking my phone, I run modem version G920FXXU6ERC4, so that is up to date.

     

    Any idea what could be going on?

      All replies

      • em_just_helping

        Use your short codes to determine if you are forwarding unconditionally:

         

        Self-service short codes

         

        Go to the Call Services section

        1 of 1 people found this helpful
        • trmcmu

          I've been having this problem as well.  For me I have a custom rom on my note 3 that doesn't support VOLTE.  I notice when I'm on lte and phone has it's screen off (sleep mode) sometimes I don't get incoming calls.  No notification or anything.  Tmobile basically says they won't really do much because it's not a TMOBILE branded phone anymore.

           

          try to switch the network to 3g/2g only and see if it works.  Or make sure you're using volte.  If it's turned off on your phone, you might be having the same problem as me.  The LTE won't switch to 3g when a call comes in.

           

          Between tmobiles website (this one) and reddit, it seems to be rather widespread.  the only solution seems to be either don't use lte or have a phone capable of VOLTE

          1 of 1 people found this helpful
          • ltcmddata

            Yes, it is like trmcmu says. The T-Mobile store people used my IMEI number to verify my connectivity. Apparently, they say, I don't have support for the newer frequency bands they have been rolling out (the 700 and 600MHz bands). Band 12 was mentioned specifically, although see online that the Galaxy S6 international version should have support for that. Regardless, setting my phone to 3G does make it accept calls, so it is a connectivity issue.

             

            Nothing to do though, since I didn't get my phone through T-mobile, so I'm SOL.

              • trmcmu

                It just sucks, because it should drop to h+ (3g) to take the call.  Which mine does some of the time.  But if I sit my phone on a desk at home and don't touch it, sometimes it won't "wake up" and connect correctly.

                 

                So that SEEMS to basically means, that any "bring your own device" phone will not work reliably with incoming calls and LTE. So you're stuck with a tmobile branded phone or you better hope you have good 3g in the area.

                 

                I don't mind at all not having VOLTE.  I would be totally fine with it going down to 3g to make calls, but I can't have people not being able to get ahold of me reliable because of tmobiles network

                • tmo_amanda

                  Hey, ltcmddata!

                   

                  I'm glad a store was able to give you more info on why this is happening. It's a bummer you didn't have this info beforehand. You mentioned this is primarily happening in two areas -- have you talked with tech support about the areas yet? It's highly likely that the phone is the issue but could also be the network. Do you know of any other T-Mobile users in either areas that have the same issue with receiving calls?

                • tmo_mike_c

                  Amanda asked a great question that'll help us determine if this is device or area related. do you know of other folks that may be having the same issue where you are?