iPhone X Not Receiving Group Texts

christinky

    Yesterday, I was receiving group texts just fine, with a mix of iPhone and Android users, on both my iPhone X and MacBook. Today, not so much. I have 3 different convos going on, and they each have a unique problem.

    Ex 1: 1 Android on AT&T and 5 iOS [2 AT&T, 2 Sprint, and 1 T-Mobile (me)]: I would receive texts from the 2 Sprint iPhone users in real time, and everyone else would come in different spurts hours later.

    Ex 2: 2 iPhone on AT&T, my phone, and 1 Android on AT&T: Received 1 iPhone and the Android in real life, but didn't receive texts from the other iPhone, WHO HAPPENS TO BE ON THE SAME CARRIER AND IN THE SAME HOUSE AS THE OTHER IPHONE USER!!

    Ex 3: 3 Androids (not sure the carriers) and my iPhone on T-Mobile: I received all their texts in real time!

     

    This is getting so frustrating and I've spent so much time researching and on the phone with T-Mobile and Apple with no solution. Oddly enough, I am also not receiving these missing texts on my MacBook. I don't mean to sound snarky, but yes, I've done a hard reset, deleted the threads and started new ones, turned off and on Set Automatically Time, have the latest iOS, and Reset Network Settings. I'm traveling next week and would REALLY love a solution! HELPPP!

      All replies

      • tmo_chris

        Re: iPhone X Not Receiving Group Texts

        Hey christinky 

         

        We have actually seen some reports of this issue here in the community in the past. This issue is on the network side and we would need to gather some examples of this and open up an engineers trouble ticket to have it investigated. If you have some time, please contact us so our tech care folks can get the ball rolling on this for you.

        • davidcraig

          Re: iPhone X Not Receiving Group Texts

          I finally convinced my Fiancee to switch over from Verizon.  She got the Apple XR.  She can send group texts but responses are delayed anywhere from 30 minutes to 48 hours.  We have spoken to T-Mobile tech support (ended up telling us to call Apple), Apple Support (told us it is a network issue), and replaced the SIM card. Resetting the network settings seems to help for a few minutes, but it ends up reverting back to the delayed responses within minutes.  There is not a correlation between T-mobile only vs. other carriers and doesn't seem to be a correlation between ios and Android. T-Mobile tech support has been stumped and I'm trying to figure out how to move a couple levels higher in their organization to get someone who might have a little more creativity.