Cellspot incompatible with Spectrum (Charter, Brighthouse, TW)

magenta5456487

    After two years my cellspot would not sync. I returned it and was sent another V.1 although I requested a V.2. I spoke with a tech advisor at T-Mobile last night and he confirmed that Spectrum Cable and similar companies have been doing digital upgrades across the country rendering existing Cellspots incompatible. I was told that they are awaiting parameters from the Spectrum so that the cellspots can work again.

    FYI:

    The Tech advisor said it was possible that it would sync after a few days if I left it on and didn't reset anything on the modem, router or cellspot.

    Anyone else having this problem ?

    When returning a cellspot, the instructions indicate you can send it back via a UPS shipping label or to a T-Mobile store. The latter was not possible as this was tried yesterday. Apparently they cannot input a device that did not come from their store since they did not have a code for the main warehouse and could not get one from customer service.

      All replies

      • smplyunprdctble

        Setting up 4G LTE Cellspot

         

        Someone else was having problems.

         

        This is interesting.  I don't understand digital upgrades are causing problems... unless these cable companies are trying to be cheap and run their cabletv over their routers (which sounds both like a great idea and horrible idea)

          • irbrenda

            I just called t-mobile because that is my issue this morning. My Cellspot is back to the blinking power and blinking amber internet lights w a solid green GPS.   they Just told me same thing about the digital upgrades and blah blah w Spectrum.   So now starts the forever waiting game of days n days of annoying blinking lights and no Cellphone calling from my house.  Thank goodness for WiFi calling on the iPhone.

             

            I too had my Cellspot replaced recently and asked for V2 but was resent V1.   It worked until now.  But it did take 20 hours to initialize.

             

            Well who who knows what the deal is with Spectrum as it seems the PSC has ruled to throw them out of New York for failure to meet their obligations.   My service has been fine though other than the Cellspot issues.

             

            PS:  As far as returning the Cellspot to the T-Mobile store, that didn't work for me because I didn't get in a store.  So, UPS was the only way to return it.

          • ekeyauto@gmail.com

            I am also having the same problem with very little help from t mobile support.  They did not have any explanation but said they would get back to me in 72 hours.  The first thing they said was that my asus t mobile router was not compatible with the cellspot.  However it has been working fine until we had a power outage few days ago. We have spectrum and the cell spot continues to blink green and yellow meaning that it cannot get to the mother ship.

            • tigerrvt

              This is very frustrating. I have Spectrum as well. I just switched to T-Mobile 4 days ago - not getting good service in my house and requested a CellSpot. They just sent it to me today and I'm having the same issues. Everyone is being told just to leave it on and wait until it's possibly fixed?

              • irbrenda

                So, I'm on Day 2 and counting.  This is the longest re-initalization so far.  Spoke to tech support last night.  I was told until the Internet light turns green, not much to do but let it go, which I already know.  Once that internet light turns solid green, they said it can take up to another 4 days, which I doubt.  For me, once that internet light turned green, within 2 hours, all lights were green.   Just trying to be patient.  But whatever anyone does, don't restart anything because that will only start you at Day One again!   I learned that lesson on previous occasions, the last being power failure to the device, and I kept rebooting everything.  Big mistake.

                • stevetjr

                  Quite a while back some AT&T DSL customers were having an issue with Wi-Fi calling that wouldn't work (this was when TMO was the only one with Wi-Fi calling) turns out that it was a DNS issue and I am sure AT&T would play stupid and say it wasn't us but as soon as folks would sign up for a separate DNS service like OpenDNS which is free (and does't hold any biases) the problem when away and it worked fine. 

                   

                  Curious if anyone just starting and is having issues it they try non TW/Charter DNS service.  Just a thought.   I had sites a long time ago that would have issues and switched to OpenDNS and have never looked back.

                  • droidmir

                    I also have Spectrum as ISP and my download speed dropped from 120 Mb to 20 Mb. What happened? Any suggestion to fix it?

                    • kjbob1852

                      I was told the same thing about it taking 4 days in most cases to link with Spectrum because of them updating their system. I called back yesterday which was my 4th day with no luck. The Rep told me this time that in most cases its 4 days but he has seen it take as long as 8. Well today # 5 and it is up and running. Just wait and be patient is the key I guess.

                        • magenta5687381

                          I have a new Cellspot which has yet to be activated for the first time over my Spectrum internet connection. I'm going on 2 weeks without it functioning. Here are some questions for T-Mobile support:

                           

                          1. What is the real issue? It looks like Spectrum triggered it with their upgrade. But, every other internet connected device never had any issue at all. Can T-Mobile / Nokia issue a FW update to fix the compatibility issue?

                           

                          2. Is the process different for the first time a Cellspot activates compared to unplugging one that has been working?

                           

                          3. Once activated, what should I expect if we have a power outage or internet outage? Another 4 - 8 days of blinking lights, or 2 hours?

                           

                          Thanks in advance.

                            • irbrenda

                              Oh well, I was rolling along here so good......until lightning struck and blew out everything.   So yeah I’m back at the beginning.   Except maybe worse.   I can’t believe it will be days and days and days again, if ever.

                              • irbrenda

                                Well it took me 30 hours to re-initialize it due to power failure. And now

                                I’ll be at it again!  We had a severe thunderstorm with power outage.  And

                                so here I go again!   The wait.   Yes 4-8 days is what I hear with

                                Spectrum.  I have Spectrum. So I’m getting used to its issues with

                                T-mobile.  Supposedly they are being booted out of NY. Hope not. I have no

                                issues.

                                • david0979

                                  Same question here.  Anyone use those"window unit boosters". Maybe take the internet out of the equation.  Idk I can't believe this should take 4 days to sync that doesn't make any sense.  Everything else in my house is working properly.  I actually had a solid green internet light but talking to chat they said after 3 hours to reboot.  So I'm back at square1.  Other problem, I have 3 of these devices to set up all 3 houses have spectrum. Is there any resolution on the fix.  I just switched 3 weeks ago (6 lines from att) I thought this thing would solve my issues but seems to just be causing more issues. 

                                    • irbrenda

                                      I had asked the support team the same thing about the window boosters. I was told it won’t make that much difference since my signal is so poor to start with.  I have basically zero bars to one bar at most. Usually it’s no service at all.  I keep WiFi calling on now.  At least that works as long as I have WiFI working from Spectrum.  When the storm knocked that out too, I had nothing. 

                                      Not sure why Spectrum and T-mobile seem to have this compatibility issue.  I never had this issue with AT&T. 

                                       

                                      Maybe that reboot will help speed connection to the Cellspot.

                                       

                                      I was told not to reboot but yes that it would take up to 4-8 days to activate.  Ridiculous.  

                                        • kjbob1852

                                          Syncing should get better shortly. Spectrum just finished going all digital

                                          fiber as of yesterday. So now they can work on the syncing problems they

                                          were having with Tmobile. Just be patient. Set it up and leave it do its

                                          thing. Once up and running its fantastic.

                                            • david0979

                                              What do you mean all digital. They did an all digital in my area (Albany) back in April.  However there internet has always been digital so the all digital channel changes shouldn't effect their internet service. If anything it opened up more room on their Network to allow for faster speeds.  Not trying to argue it, just trying to make sense as to what is going on.  I have all kinds of internet connected devices and nothing else is having an issue

                                              • david0979

                                                I do hope once it starts working it's worth the wait lol

                                                  • kjbob1852

                                                    Just because your area was finished ahead of everyone else has nothing to

                                                    do with it. They converted their entire system over and now that that is

                                                    complete they can work on this problem. The way I see it you can be patient

                                                    like the rest of us were or you can change ISP or cell service. It took 5

                                                    days for mine to sync here in Florida where we had 0-1 bar of service and

                                                    now I have 5 and am extremely happy.

                                                    • irbrenda

                                                      It will be worth the wait.   Once up and running, I have full bars and service even in my basement.  Like I said, the window booster would do not much for me since service is that bad.  They said it might add one bar, but for sure, I'd have zero in the basement area.

                                                       

                                                      Of course, as it has been said before, when I lose power, I start the process all over again.  I was lucky last time that it took several hours rather than days. I've acclimated to the wait now.   I'm in Staten Island, and I'm sure NYC has been all digital for a long time, so that had no bearing at all on why it takes so long to activate a Cellspot here.  It's just an issue between Spectrum and T-Mobile, which may or may not ever resolve here.   Right now, Spectrum has bigger issues to deal with in the State of New York and the Public Service Commission.   I'm sure their focus is not on Cellspot service here, but rather, maintaining its base in New York.  Who knows if what replaces them would be better or worse.  And I don't want to find out.  My service has been terrific.  But it's NYC.  That's why.

                                                        • kjbob1852

                                                          From what I was told until their system was totally converted which it is

                                                          supposed to be now it would remain a problem. It took me 5 days on the

                                                          initial sync but only a few hours after loosing power.

                                                            • david0979

                                                              Finally got my hotspot working.   Once I got all my ports forwarded and left it connected it took about 24-36 hours.  Set up the 2nd one at my dad's house (also spectrum) took about 30 hours. Going to try the last one at my brother's tomorrow.  I think the quickest way for initial set up is get all the ports forwarded and then hook it up and let it do its thing.  I kept playing with it at first because it wasn't getting on line as long as I expected.  Not sure how much is this is related to spectrum vs TMobile but it's certainly quite aprocess.  And I'm not rebooting to see how long it takes, hoping a little shorter next time since it's been on and registered with their Network now.  All I can say is I agree with everyone else, it's worth the wait, full bars everywhere now.  Everyone's happy.  Love this forum, makes me feel a little better knowing I wasn't alone in The what the heck is going on here camp.. .

                                              • kjbob1852

                                                Just so you know I just got my cellspot up and running yesterday after waiting 5 days for it to sync with Spectrum. Well as we would have it the storm yesterday knocked out the power. Figured I would have to wait 4 days or longer for it to come back up but it took about 12 hours so not so bad.

                                                  • irbrenda

                                                    Well, I got lucky too!  The storm knocked out all my power, which of course came back in a few minutes,but knocked out the Cellspot.  I also lost phone service even though my UbeeDVW32CB  has the backup battery installed, which didn't work.  With no Cellspot and no wifi calling now, I had no phones at all.  (Silence is wonderful sometimes!)

                                                     

                                                    Took 4 hours for the  Cellspot to come back.  My rebooted my Ubee and my Apple Time Capsule router, as a last resort, but somehow that kicked it all back into gear, even though Spectrum rebooted the modem themselves a few hours prior.

                                                     

                                                    I think I am going to now connect that Time Capsule with the Cellspot to an APC UPS Backup battery, as I do my computers so that if power goes it, the battery will kick in for about 30 minutes.

                                                  • magenta5687381

                                                    Finally activated and working !!

                                                    • iridenc

                                                      I Have Spectrum/TW and my own LInksys 1900AC Router.  Having worked and researched for over two weeks I can share the absolute bottom line. IF you set-up the Cellspot and it connects, congratulations!  For some customers (apparently a lot) it just will NEVER work no matter what you do.  The Cellspot is supposed to be PLUG 'n PLAY.  It just is not at least on a universal basis. There are so many ISP's, brands of routers and people's individual home network configurations that are incompatible with the Cellspot.  T-Mobile can only address issues with the Cellspot device itself and not interaction or settings with specific routers.  If you install the Cellspot and it works within two (2) hours, you are golden.  If still not established after two (2) hours, box it up and send it back.  Period.  You would not believe how deep a hole you can dig for yourself IF you try to make this thing work if it does not automatically plug and play.

                                                       

                                                      I got one and read all literature before the device actually arrived. So I called Spectrum after reading this forum. Spectrum assured me they block nothing and T-Mobile assured me that all problems with Spectrum were resolved (early August 2018). Next I called Linksys and we decided it best to wait until the Cellspot was received and connected to walk through port forwarding. Later with a Linksys Tech Support agent we reserved the IP address for the now discovered Cellspot, then one by one forwarded the three UDP ports. Done!  The Cellspot Power Blinked Green, Internet blinked Amber more than three (3) days. Stupidly, I had faith in T-Mobile and their insistence to wait that I actually wall-mounted the Cellspot and took great pains to route and hide wires. Finally T-Mobile agreed the Cellspot was defective and shipped a replacement.  After two hours, same result.  It's so difficult to get through to an actual trained technical person at T-Mobile I called Linksys again.  Linksys said as a last resort/test I could put the Cellspot in DMZ on my router which absolutely, positively opens every possible port and communication from anyone on the Internet to the Cellspot. Nothing.  I relented and took the necessary 2 hours and multiple transfer route to talk to T-Mobile. I actually got a very nice and competent support agent, We tried (my bad) hooking the Cellspot up directly to the Spectrum Cable Modem then the LInksys Router to the Cellspot LAN.  Well, that created some kind of hardware conflict that caused my router (and everything connected to it) to acquire a new IP address! This takes more than two hours and calls to Linksys Tech Support to restore. Three hours later, still green light on  WAN port, green flashing power and amber flashing Internet I call T-Mobile again. This guy says give it up to 8 hours to connect. I tell him the first T-mobile expert said a maximum of 2 hours. No real response. This guy says there is a known conflict with Spectrum. I tell him the first T-Mobile expert said that was all resolved, ticket closed and Spectrum swears there are no ports blocked. No response.

                                                       

                                                      Bottom Line: Being self-employed I lost not only an entire day's work but a 14 hour day (up until 2 AM).  This doesn't count all the other hours lost the previous two weeks with T-Mobile, Spectrum & LInksys agents.  I've ticked off Linksys, they essentially told me that my router is past the free tech support period and they have accommodated me as a courtesy for something that is a T-Mobile issue and if I need their help in the future I HAVE to buy a service plan.   I have the original Cellspot packaged up in the materials I received the second Cellspot. Now I also have to send that one back and will have to go buy packaging for that one. I either have to pay a premium to UPS for pickup or drive 50 minutes one way to the nearest UPS store. And I have to patch the holes in the wall from the mount. And I am still finding devices that have to be reconfigured because of the IP address changing as a result of using the Cellspot as a bridge.

                                                       

                                                      IF YOUR CELLSPOT DOES NOT CONNECT AND ENGAGE WITHIN TWO HOURS, CUT YOUR LOSSES AND FORGET IT.

                                                        • kjbob1852

                                                          Maybe the problem lies in the fact that youre trying to use a Spectrum

                                                          Modem and and your own router. Why not use a Spectrum router/modem? Thats

                                                          what I had to do. I tried using my own to no avail. I got the Spectrum and

                                                          yes I had to wait 5 days for it to sync the 1st time but now I have 5 bars

                                                          and it resyncs within a few hours if we have a power outage. Plus with

                                                          every tech Ive spoken with not one has said it should sync in 2 hours. They

                                                          have all said a minimum of 4 hours and as much as 8 days.

                                                            • iridenc

                                                              Well - prior to Spectrum it was Time-Warner and they ran Internet to your house via cable and modem - period. A customer had one Ethernet outlet port to use at their discretion. I chose rather than have one LAN computer or a Ethernet hub for more than one computer that I'd buy a router.  When WiFi became an offered service the choice then became to discard my personal and paid for router and pay TWC a monthly lease for a device that was dismally inferior in quality and performance or continue to use my own superior device for free. As time passed and more wireless and smart home devices became available and routers got faster, more robust and reliable I of course upgraded. When Spectrum acquired TWC and I upgraded to 300 Mpbs Internet with over 20 connected wireless devices (security cameras, thermostat, Amazon Echos/streaming TV devices, smart plugs, LED lighting, etc.) I just never considered swapping a highly functioning and fully paid for home network over to whatever Spectrum had to lease.

                                                               

                                                              In the last 48 hours I've spoken to three different tech support specialists in T-Mobile's dedicated Cellspot department. Two of the three assured me that two hours was a maximum and even if you read the accompanying literature there is reference to two hours (contact T-Mobile if not connected in that timeframe). The third T-Mobile expert said that two hours or less should be the expectation but that eight hours was the absolute maximum. Obviously it can take as much as 8 days, and according to users on the forum much longer. I'm just repeating what I was told by T-Mobile and it's also obvious that have no Standard Operating Procedure or script. Happy you have yours working so well.

                                                          • stevetjr

                                                            The funny thing here is that using standard problem solving if the Cellspot works without issue on the internet providers and only has issues on Spectrum (Charter, Spectrum, Brighthouse, TW which are all the same company) then logic would dictate that the issue is not with the cell spot but rather with Spectrum regardless of what Spectrum says, that most likely it is something on their network. 

                                                             

                                                            As I mentioned earlier, I know people used to have an issue with Wi-Fi calling on ATT DSL but worked on other providers and the fix was as simple as using non AT&T DNS servers. 

                                                            1 of 1 people found this helpful
                                                              • iridenc

                                                                You could be absolutely correct. But since Charter/Spectrum/TWC/Brighthouse/et. al. has over 30 million US Subscribers and probably over 40% of the US market, standard problem solving (not to mention economics and common sense) would seem to dictate that T-Mobile would be more concerned with making sure Cellspots were compatible with Spectrum and of course Comcast (nearly 90% of market combined) than the little local ISPs , but who knows?  Although I'm not in love with either company (at least at the moment) based on my experience Spectrum technical support is much more astute, well trained and consistent (representative to representative) than T-Mobile by a wide margin. So if I had to bet on which one was more knowledgeable and forthcoming about an issue I'd have to go with Spectrum. And, now that my Cellspot has finally connected and I know Spectrum changed nothing, I am unable to change anything on Spectrum and nothing has changed with the router since initial set-up, the preponderance of  evidence suggests a T-Mobile issue. Who knows?

                                                                • iridenc

                                                                  Sincere apologies, but I have so much time, energy and frustration invested please indulge one last word. Consider this analogy. You go to the Furniture Store IT-Mobile) and buy an entire living room suite (cellular service) delivered. You get home and there's your nice new furniture sitting out in your yard. You call the furniture store and say, this is great but I was sort of needing this stuff inside my house. Furniture store says no problem, just make sure your doors are unlocked (ports are open) and we'll move it inside for you tomorrow. You leave for work, leave your doors unlocked, come home, furniture is still in the yard. This goes on for days. You call the Furniture Store, hey we tried but your doors (ports) were locked. Every morning you leave for work, check to make sure your doors unlocked, come home, furniture on the lawn. You keep calling the store. Store insists the door is locked. Wasn't locked when I left. Well you have to call the company that made your door, it's locking us out. You call Andersen Doors (your ISP) and ask if your doors are locking themselves after you leave for work. Andersen kindly assures you that is an impossibility. Furniture stays outside, store insists they are trying but can't get in, you test and know the doors are unlocked, Andersen thinks you are tripping, but you still got no living room furniture. Days or weeks even pass and you are ready to hire a lawyer and get your money back from the furniture store. You pop home at lunch one day before the court date and here is your great new furniture sitting in your living room.

                                                                   

                                                                  Does basic problem solving suggest that those doors were locking themselves after you left for work so you blame Andersen (your ISP) ?   Or is it more likely that the Furniture Store (T-Mobile) was at fault (crew was sent but not coming or store was blowing you off, etc.).. I'm sorry but I have to give Andersen Doors (Spectrum) a pass on this one. Furniture Store got to man up.

                                                                    • david0979

                                                                      I agree with your posts here.  I just set up 3 of these Cellspots.  All 3 on spectrum.  1 - Spectrum Modem with Router/Wifi all in one unit,  2/3 Spectrum Modem Personal Router/wifi after the modem.  Best case scenario was set up the forwards and wait 24 - 36 hours.  Worst case scenario for me was about 72 hours.  Calling T-Mobile,  even when being escalated to "T-Mobile Expert"  as my caller Id showed,  resulted in no help.  I think they really do have 1 or 2 people (or a super small group) in the company that has to provision these,  they get backed up and that's why the for the new ones anyway.  Haven't had the pleasure of it going down for a power outage or cable outage.

                                                                       

                                                                      Nothing I can think of on the Spectrum network would all a sudden just let it start working after 24 hours.  I think the signal is getting to t-mobile,  they just can't get them set up in time.  But just speculating.  We will never really know who is pointing the finger correctly at the other company.  Unless someone out there has set them up on both spectrum and another ISP within a short time,  and then we could compare the two.

                                                                       

                                                                      I enjoyed the Furniture analogy

                                                                        • iridenc

                                                                          Thank you very much and I think you nailed. it.  I'm NOT a techie but I do know if your router has a DMZ (demilitarized zone) you can assign a device there and absolutely nothing gets blocked. There are websites to check port access. So if you got something (in my case a wireless IP camera) you can move it to the DMZ and see if you can reach it through those websites. That proved beyond doubt that Spectrum wasn't an issue. And when I moved my Cellspot to DMZ it was doing it's thing.  So I agree there is some kind of resource deficiency at T-Mobile (manpower or servers, something) that causes these delays.  Think about it.  You can put your WiFi password into Alexa once and within 10 minutes she's telling you how to make green bean casserole, when it's going to rain next or reminding you to take out the trash.  Why would it take hours, days, weeks to route cell service though the same WiFi that you're already using WiFi Calling?

                                                                            • smplyunprdctble

                                                                              I will respectfully disagree.

                                                                               

                                                                              While I agree putting something in the DMZ of your router should work, think about a larger picture.  There have been no complaints from people who have Comcast.  There have been no complaints from people who have AT&T (DSL, Fiber, whatever).  There have been no complaints from people who have Cox.

                                                                               

                                                                              The only complaints are Charter (and it's subsidiaries).

                                                                               

                                                                              If you're on Charter and can't log in to Netflix, but every other provider can, is the problem a Netflix problem?

                                                                              If you're on Charter and can't connect to GMail, but every other provider can, is the problem a GMail problem?

                                                                               

                                                                              The answer to both those questions is a resounding "No".

                                                                               

                                                                              Now, what causes Charter to not work for 7 hours, but at hour 8 everything connects?  I don't know.  I don't have any knowledge of the workings of the Cellspot.  I don't have any knowledge of what crazy things Charter blocks (whether intentional or unintentional).

                                                                               

                                                                              Unless T-Mobile has logs sent to them to figure out what takes so long connecting (I don't know people's opinions on privacy here - some would be for it, some would be against - I mean, look at all the tracking angst that comes up every handful of months about your phones), nothing can be done except "it should work."  This is the same reason Netflix would give you if you can't connect.

                                                                               

                                                                              My opinion is T-Mobile needs to somehow work with Charter to figure out what is going on.  But, I find it hard, with my client/server knowledge, to blame this directly on T-Mobile.

                                                                      • iridenc

                                                                        You absolutely cannot make this stuff up.  I was on the phone after midnight with a T-Mobile Cellspot Specialist. One of the best I've encountered. He basically confided that Cellspot just isn't going to work in some instances and we agreed it was best to send it back and give up    I disassembled and boxed the cellspot in preparation for return. This morning I just wanted to convince myself that I hadn't missed something before shipping it back. I unboxed, plugged up the power and ethernet cable so my router/network could discover and I checked all my settings. Yep, 100% per LInksys and T-Mobile, everything right and didn't change a thing. Got busy and had to go run errands, part of which was getting outer packaging material to send the cellspot back. On my return a couple of hours later I went to disconnect and repack the Cellspot and the entire front panel glowing GREEN. No lie! I disabled WiFi calling, had five bars, checked signal strength and it was 25%-35% better than it's ever been. I left my initial Cellspot on four days and nothing but two flashing lights  This one was on for 14 hours and nothing but two flashing lights. Plugged it back up for over 3 hours and nothing but two flashing lights. Somewhere between hour 3 and hour 5 it connected. Absolutely no changes made on my side for close to two weeks.

                                                                         

                                                                        With my apologies to millennials who cannot possibly understand, I have solved the mystery. It's the only plausible explanation. T-Mobile must have contracted Cellspot service, likely to some contemporary of mine.  The dude is probably in the heartland of USA, maybe Iowa or somewhere, definitely a rural area. He's probably using an old Dell Inspirion tower with Windows Vista and has AOL dial-up.  Every T-Mobile Cellspot is trying to connect with him for setup.  Now if he's busy downloading Pink Floyd MP3's or something important there just is no room left for any Cellspot setup. Or, if he's out cruising the countryside on his Softail or even just on the porch swing smoking a blunt and Vista locks up with the Blue Screen of Death (BSOD) then it's naturally going to take a while to recover. It's one of the few logical explanations on why some Cellspots connect less than two hours, some take days or weeks or some never do.  Mine must have just caught a rare window of time where Vista was stable, AOL stayed connected and the contractor wasn't distracted.

                                                                         

                                                                        It's still a crap shoot but relieved and shocked it's working

                                                                        • tmo_mike_c

                                                                          I checked and there's been some reported issue with a delay in activation/registrations. Making sure the device has the most recent software is the first step. The delay shows as 2 hours though so a Trouble Ticket will need to be escalated with our Team of Expert if it's going on longer than that. If you're having other troubles, and the steps in the thread posted earlier didn't resolve the issue, you'll need to Contact Us and have a ticket filed to get this resolved.

                                                                          • magenta3017443

                                                                            A month or so ago I experienced this registration issue as I'm with Spectrum for home internet.  It took around 24hrs for the Cellspot to register after a few power blinks which cause the device to power cycle.  Last night we had another power blink and the device recycled.  Much to my surprise it reconnected within 4 minutes. 

                                                                             

                                                                            Not sure if this Spectrum issue has been fixed, but that's what mine did last night.