Missing Account Info

jonathan777

    Hi,

     

    I am currently missing a couple of features from my t-Mobile account. Currently I am only able to see the main page of the account and it seems to be outdated. I am unable to see EIP balances for devices as also the individual usage for each line. Also in my personal account I am unable to see the data stash accumulated for each line. As instructed by Customer services in the past I tried to login with the phone number and then the e-mail address but the result seems to be the same.

     

    Please see screen shots below

     

     

     

    Busi 1.PNG

    Busi 2.PNG

    Busi 3.PNG

    Busi 4.PNG

    Busi 5.PNG

    Busi 6.PNG

      All replies

      • tmo_mike_c

        Re: Missing Account Info

        Wow, that's odd but we wanna get this taken care of for you. Are you logging in using this link or did you sign in another way?

        1 of 1 people found this helpful
        • tmo_amanda

          Re: Missing Account Info

          Hey, jonathan777! One other thing I wanted to add on is that the issue may be due to your permissions as well.  You can take a look at how to change those here: Set up line permissions .

          1 of 1 people found this helpful
            • jonathan777

              Re: Missing Account Info

              Hi Amanda,

               

              Thanks for the response, i tried to do this in the past but still did not solved the issue. According to support when I contacted them only they mentioned that only one line in the account can have the Master permission and this main line is the only one that has it. In the past I did not had any problems with this. It is very strange

            • magenta5742841

              Re: Missing Account Info

              It appears T-Mobile has stopped giving the information about DataStash amount remaining on the webpage and is forcing you to call their support center. where i imagine they will try to up sell you on the new service Tmobile ONE....

              1 of 1 people found this helpful
                • jonathan777

                  Re: Missing Account Info

                  It is quite bothersome to be calling them like i am doing right now I had this issue in the past and after a couple of calls I did manage they managed to fix it but then again the problem came back. And yes they tried to sell me the T-Mobile One but it is very expensive compared to the old current plan. However the business account is very cheap compared, I pay 25 for each line in that account regardless.

                • tmo_mike_c

                  Re: Missing Account Info

                  That's correct about the data stash usage. It's no longer available to view on MyT-Mobile.com or the T-Mobile App. It still works the same and will automatically start after your data allotment is used. Are you looking for other usage info you're not seeing or was it just data stash?

                    • jonathan777

                      Re: Missing Account Info

                      Hi Mike,

                       

                      Yes is correct I was wondering what did happened to feature in the account. I will add that it will be troublesome in the future having to call customer service every time I want to know any particular information about the account as wait times tend to be long.

                       

                      In the Business Account I am unable to see anything past that screen. I don't know if this was normal or not. Wait time when calling Business CS seems to be shorter in perspective but again I have to call to know any information in the account which I could easily find previously just by logging in.

                    • jonathan777

                      Re: Missing Account Info

                      Yes that's correct on the Business Account I am only able to see usage for the main phone line and that is the only information provided in the My T-Mobile site. I would like to know like the EIP Balance of each individual line and usage for each line. Clicking on usage at the bottom of the page or other links does nothing in the page.

                       

                      InkedmyTmobile_LI.jpg