Calls not forwarding to GV

tbuhlayzik

    Switched from ATT and brought my iPhone 7 Plus with me.  With ATT, all VM would go to Google Voice.  Since switching, even though I follow all the settings (at least thinking i do), my calls are still held locally.  I need to be able to get VM at my computer, when my phone is not accessible, hence the need for the GV option.  Any help or recommendations?

     

    Example of what i need;

    Phone is in car or even turned off or out of battery (dead).  Someone calls, i need their message to show up on my GV while logged into my Google account,where i am able to read and listen from the computer.  When on the phone, i use the GV app to retreive/read/listen. 

     

    Thanks. 

      All replies

      • smplyunprdctble

        Re: Calls not forwarding to GV

        Turn Google voicemail on or off - Google Voice Help

         

        Have you re-set up Google Voice as voicemail for your number?  You have to turn GV off and back on if you port.

         

        If you've already re-set up GV, how long ago did you port?  It's not recommended to set up custom VM until your phone has officially ported instead of during the "dual service time" -- I recommend a week after the port has been initialized.  This is because your phone has a temporary number during the port process and your virtual number is your number porting.  Once T-Mobile officially has your number, your phone gets the real number and you can set up services like this.

         

        GV does work on T-Mobile.  It's what I use for my voicemail.

          • tbuhlayzik

            Re: Calls not forwarding to GV

            Thanks.   So I reset GV.  Even uninstalled it.  Reassociated with my google account, my number shows up but now I realize I can’t toggle on the two features I think I’m looking for:  

             

            Any any ideas why I can’t toggle over?

             

            do I need to turn off T-Mobile VM?  If so, how bc I’ve tried To at least find preferences for VM and couldn’t.  

             

             

            E2783114-C632-4AF8-A07B-7184541B5D7F.jpeg

              • smplyunprdctble

                Re: Calls not forwarding to GV

                I don't think there's an official way to turn TMVM off - you just need to set the Call Forwarding options on your phone so they'll go to GV for voicemail.

                 

                I have an Android device, so it does it automagically in the GV app.  I don't know how the iDevices do it.  Last I knew, GV help gave the dial codes for a selected carrier to change the call forwarding options for voicemail.  Then again, it was YEARS ago the last time I touched my options, since they're stored on the network side.

                 

                My memory VAGUELY recalls it being as part of the setup that's in the help link I posted above, but I cannot fully recall.  And, my google searches aren't producing the exact info I want.

                 

                the::unwired - HOW TO: Diverting Voice Calls by using USSD Codes

                 

                It might be **004*DESTINATION_NUMBER# from your dialer -- or the various options in it (61, 62, 67).  Like I said, the GV help back in the day gave all the settings because some folks didn't have smarticle phones.

                 

                Either way, you're going to have to dial the USSD code from your phone to tell T-Mobile's system how to divert if you don't answer.

            • tbuhlayzik

              Re: Calls not forwarding to GV

              Got it working.  Had to go into GV legacy, click on the button right of the T-Mobile number and enter the **004.... combo and it worked.  Thanks.