Galaxy S8+ Won't send texts on Apt Wifi

donkeytron

    I can't figure this out so any help would be appreciated.

     

    When I arrive at my apartment and it automatically connects to my wifi, which every device and even the internet on the S8+ works fine, 9 out of 10 times i am unable to send text messages. It just says failed to send no matter how many times.

     

    Turn off wi-fi, wait a few minutes, then I can send it fine. I can then send fine AFTER doing that, even if on wifi.

     

    Or if I reset the phone and stay on the wifi, i can send texts.

     

    It is very strange but very annoying to do almost every time I come home. Thanks.

      All replies

      • tmo_mike_c

        Re: Galaxy S8+ Won't send texts on Apt Wifi

        Hmm. Do you always leave your Wi-Fi on even when there's no Wi-Fi network around? I suggest making a habit of restarting the phone once a day to see if that makes a difference. Also, try using a different Wi-Fi connection to see if the same thing happens.

        • tmo_mike_c

          Re: Galaxy S8+ Won't send texts on Apt Wifi

          Hi there.

           

          Just want to make sure this is resolved for you. If you haven't already, please test this on another Wi-Fi connection to see it's working without a restart. Thanks.

          • donkeytron

            Re: Galaxy S8+ Won't send texts on Apt Wifi

            I don't seem to have this issue when connecting to other wifi connections - however, this is the one I connect to the most often of course as it is in my home and connects every time I arrive. Even this connection works when resetting, so I'm not sure how much of a test it really is to connect to a different network and see it working, but it seems to. Thanks.

              • tmo_mike_c

                Re: Galaxy S8+ Won't send texts on Apt Wifi

                That test just helps us see if the issue follows your phone to another connection or if only happens on one connection. Can you try restarting your modem and router, then testing it a few times to see if the messages work better?

                  • donkeytron

                    Re: Galaxy S8+ Won't send texts on Apt Wifi

                    Hi, after resetting the modem and router, nothing has changed.

                     

                    I even have a new S9+ via tmobile's promotion, but this issue continues.

                     

                    It is for SMS messages. 9 out of 10 times it won't send while connected to wifi. It *will* work after I disconnect on the phone, wait, and then re connect to the wifi. This makes no sense to me, but is an issue to have to do this every time I go in and out of my apartment for basic text communication which is the vast majority of how I communicate.

                      • donkeytron

                        Re: Galaxy S8+ Won't send texts on Apt Wifi

                        Also, android has a messenger app that lets you send via browser, and it is an issue there as well.

                          • tmo_mike_c

                            Re: Galaxy S8+ Won't send texts on Apt Wifi

                            Just so I'm clear, you're using an S9+ now and this is still happening? Have you tested on another Wi-Fi connection other than your apartment's? If you have your Wi-Fi calling enabled, are you able to send messages more consistently?

                              • donkeytron

                                Re: Galaxy S8+ Won't send texts on Apt Wifi

                                Hi there, this is correct. It is no better now that I have an S9+ so it is not phone related.

                                 

                                I do have Wi-Fi calling enabled.

                                 

                                I have not experienced this with other Wifi networks, but of course I am not on them nearly as much as my apartment and may have not noticed it. But I don't recall every not being able to send a text except on my home.

                                 

                                If this can't be sorted, is there a way to tell the phone that the messenger app cannot use the wifi, and force it to send messages via the mobile network while i'm still connected?