US Cellular no longer a roaming partner for T-Mobile in Maine?

magenta5514211

    For over 10 years, my T-Mobile account functioned fine in Midcoast Maine, roaming on US Cellular, for the last year using Moto G5 Plus. In the last two months, I've experienced intermittent outages of coverage (ex: emergency calls only, or cannot connect to network operator) but these were short, several hours each and then the phone would reconnect again and sometimes I'd get texts in the middle of the night as they finally "come through". The bigger issue is that for the last WEEK, I have no had no service. It's gone completely. No phone calls, no texts, no data, nothing at all. Same on a family plan connected Nokia phone, so it doesn't seem to be a Moto G5 Plus issue. It's as if T-Mobile and US Cellular's roaming agreement just ended. Does anyone have any ideas or suggestions for me? Thanks in advance.

      All replies

      • drnewcomb2

        1. T-Mobile and USCC have an agreement to develop bilateral LTE roaming. There's a specific list of T-Mobile's phones supported by USCC's VoLTE. I'll look around to see if I can find it.

        2. T-Mobile regulates where customers can roam by a technique called LAC-blocking. When they deploy native service anywhere near a roaming service area they will block the roaming partner's LAC covering that area. T-Mobile has been deploying new 600 MHz service in Maine. Maybe they've turned off USCC roaming in that area.

        1 of 1 people found this helpful
        • tmo_mike_c

          drnewcomb2 is right about certain devices can connect to that roaming partner. I'm not seeing any Nokia devices are compatible to connect. The stronger signal is going to be outdoors in this area for the most part. Just out of curious, have you tested switching your connection to 2G to see if you get any service at all? I totally want you to have the best signal we offer, but I'd just like to see if you're even getting signal on 2G.

          1 of 1 people found this helpful
            • gick101

              I'm happy to find this discussion.  The issue that started the thread is the same one I'm having when visiting western Maine.  I get no service at all on my BlackBerry KeyOne since this summer.  Meanwhile, my family are able to get US Cellular coverage on their iPhone 6S phones.  I've tried changing the network type, but no difference.  Roaming works fine on other networks in Maine.  Is there any way to request US Cellular enable roaming for other phone models?  It prevents me from being reachable for work calls and emergency calling doesn't work either.

                • drnewcomb2

                  It turns out that T-Mobile is not allowed to confirm that they do (or do not) have a roaming agreement with a certain unnamed cellular company that is headquartered in but does not provide service to Chicago. (Yes, everyone understands how silly this is.) Having said that, have you confirmed that USCC actually still provides GSM service in Maine? I can't find any indication that they do. Back when T-Mobile was still talking about roaming on USCC, they published a list of phones that would be compatible with this roaming. I don't recall seeing any BBs listed.

                    • gick101

                      Thanks for the reply.  That is interesting about not being able to confirm whether TMO has a roaming agreement with that unnamed cellular company HQ'd in Chicago.  Made me chuckle.

                      I haven't looked at whether USCC still provides GSM service in ME, but I don't see why they wouldn't.  Like the customer who originally started this thread wrote, it worked until this summer.  For me, that was on the same BlackBerry KeyOne (running Android OS v7 - Nougat).  It also still works for members of my family on TMO, they're on iPhones.  So what changed or why did they stop support for some models of phones but not others?  Very curious and frustrating.

                        • drnewcomb2

                          First, I suspect that US Cellular wants to hide from their customers the fact that T-Mobile roams on their LTE signal. If you can get US Cellular coverage on a T-Mobile plan, why pay for USCC? This is why T-Mobile is not allowed to discuss which carrier T-Mobile roams in Maine. It's in the roaming agreement.

                           

                          Are your family roaming USCC's GSM signal or LTE signal? Do their phones say "G" or "E"? Is your BB a model BBB100-3? It might help if you update your BB to Oreo. Not sure about that. You can move your SIM from the BB to one of the iPhones to get your SMS and check voicemail.

                            • gick101

                              I don't recall if my family is Roaming on USCC's LTE or GSM signal.  For me, it looks like I'm out of luck .I was in western ME today and immediately dropped from Roaming on ATT to no service at all when I entered Oxford County.  When I stopped, I tested my SIM in an Android Pixel and a Galaxy S6 with same results (no service at all for voice or data), no matter the settings I chose. When I returned to an area with TMO LTE, i called TMO support and spoke with a rep who found an email from this July 2018 that indicated USCC would only support Roaming from very new Android devices from a limited # of manufacturers, including Moto and Samsung, that supported 600mhz .Frustrating to find out that change was made without public communications.

                              It's concerning to me to have no service at all, not even emergency calling when attempting to roam on USCC.  Seems like a life/safety issue. 

                              I wish I knew why Roaming on USCC is working for my family's iPhone 6S phones, as I can't find evidence they support 600 mhz.

                                • drnewcomb2

                                  I'm not sure if the rep you spoke with had the best information. The info I've been given includes the Samsung Galaxy S6 (SM-G920T) on the list of phones that are supported by a certain roaming agreement, but the BB was not on the list. It also includes a number of iPhones but not Google phones. I don't know what exactly would be required for a phone to be on the list, a particular flavor of VoLTE maybe. It could have been that he/she was looking at a supplemental list of newly supported phones. I don't have a way to test it. The nearest USCC service is about 400 miles from where I live.  

                                   

                                  I've been poking around the net and have noticed that some owners of the BB Keyone have had issues using them with T-Mobile's LTE CellSpot femtocells.

                                   

                                  Clearly the situation is less than optimal. You did try your SIM in a Galaxy S6, which should have worked. RootMetrics' maps show USCC's LTE is pretty spotty in Oxford Co. It's available in Bethel and Hanover but not Newry. It looks like the whole USCC LTE roaming agreement has been a mess from the get-go.

                                   

                                  BTW, tagging your concern onto the end of an existing thread may not be the best way to get an "official" response from a T-Mobile rep. After a thread gets marked as "answered" they tend to not look in at new discussion. You might want to start a new thread. I just noticed your question because I had tried to answer the OP.

                      • tmo_amanda

                        Hi, magenta5514211!

                         

                        I'm just swinging by to see if you had any other questions after looking over the helpful info that has been posted on your thread. 

                        • oldsoul1989

                          I was in S.E. West Virginia which is also US Cellular territory about 3 weeks ago and though it showed up under Network Operators it wouldn't let me connect to it. I had service from the tunnel all the way to Ghent but lost service completely near the toll booth. Didn't have service for about 35 miles until I got to the Greenbrier County line then I had Band 4 and 12 but during those 35 miles which includes the Beckley area I couldn't connect to USCC or AT&T at all. I was able to connect to AT&T about 2 miles up Rt. 60 after losing T-Mobile service. I have postpaid.