Group messaging not working on brand new Moto G6

cflaniken3

    I have tried everything - including conversations with Tmobile and Motorola but cannot get group texting to work on my new Moto G6. My wife got the same phone and is also having this problem. Is anyone else having this issue? Any fixes?

      All replies

      • rbkh

        Re: Group messaging not working on brand new Moto G6

        I have the exact same issue of a Moto G6 I just bought. Any solutions found to fix it?

        • cflaniken3

          I finally figured out a fix for this. I hope T-mobile takes note of this because I'm sure many people will experience the same problem.

           

          The problem has to do with the phone's APN settings - which need to be tweaked.

           

          1. Access your Android phone's settings (gray settings icon that looks like a gear).

           

          2. On the settings menu - select "Network & Internet"

          3. On the "Network and Internet" menu - select "mobile network" (which should say "t-mobile" beneath the words "mobile network")

          4. On the "mobile network" menu - select "Access Point Names" (often abbreviated APN).

          5. On the "APNs" menu - you should see two options: "T-mobile US" and "Tmobile MMS". There should be a green dot next to "T-Mobile US". Select that "T-Mobile US" option (NOT the Tmobile MMS).

          6. This will open an "edit access point" menu, and you will need to make the following edits:

          First - click on the MMSC option and add the following text: mms.msg.eng.t-mobile.com/mms/wapenc

          Second - click on the "APN type" option. It will probably say something like: "default,supl,hipri,fota" (without the quotation marks). You will need to tweak the end of it so the whole thing instead reads "default,supl,hipri,fota,mms" (without the quotation marks). As indicated here - there are no spaces between these commas.

          Third - after making these two adjustments to your APN - make sure you click on the menu dots (three vertical dots) at the top right hand part of the "edit access point" menu. This will open up a drop down menu - and then you should select "Save". If you don't do this - the settings will not take effect.

           

          This should resolve your problem! If these directions are hard to follow - let me know and I'll try to describe things in more detail and/or include some screen shots. Let met know how this goes!

          • cflaniken3

            Response to the two questions above:

             

            1. APN settings are used for communication between a phone and the network. The problem on the Moto G6 concerning its interactions with the T-Mobile network is that there are two APNs - and the APN that's actually in use by T-Mobile (the one with the green dot) has zero information for MMS sending/receiving unless you add it manually.

             

            2. Important note: if you have "wifi calling" turned on when you're using your phone - it may be preventing MMS messages from going through even if you've fixed your APN settings. Try disabling your wifi calling and see what happens with MMS after that.

            1 of 1 people found this helpful
            • italianstudent

              This solution also works for MotoE4.  I used it on 2 of them and it worked for both.

               

              Thanks.

              • bright37

                I tried the solution about but still having an issue viewing group text messages on my motog6.   My APN hast "fast.t-mobile.com" instead of the "default,supl,hipri,fota". Should I tried changing and adding the mms to the end of what is already there or add the default?