T-Mobile USA app version 7.0.1.78 for Android "issues"

sfware

    Recently, I upgraded (with great trepidation ;-) to the latest T-Mobile USA app version 7.0.1.78 for Android, from version 6.7.1.5.

     

    I have sent feedback from the app at least twice now, but I'm not sure if/when the app feedback is reviewed and/or acted upon (but I have my guesses ;-).

     

    Earlier today, the app was not working. Recently it was. And so it goes...

     

    Although I can live with the app, I am thinking about uninstalling it, as it has had errors from time to time, no longer has info. in the Android notification bar and is more of a "marketeering like web site" (versus a useful Android app). Disappointing, to say the least. If it's a good working app, I might use it. If the app is just a glorified marketing web site, I'll just use the web site (if useful and working ;-), thank you very much!

     

    Here are some recent screenshots.

     

    The first one is my "usage", selected from the app home screen. Notice that it is blank. Nada. Nothing. And note the missing T-Mobile icon that used to be in the notification bar (see my last/third image for what it used to look like).

     

    Screenshot_20180609-150505.png

     

    When trying to use the "ACCOUNT" option in the app, here's what was displayed:

     

    Screenshot_20180609-150021.png

     

    The timestamps are out of order because I did not take the original black usage usage screenshot - went back to it and it was still blank.

     

    Anyway, just for "completeness", here's a screenshot from the old app, with the notification bar icon, and well, yet another error:

     

    Screenshot_20180607-072415.png

     

    Anyone else like to comment?

      All replies

      • dc5fan

        Yeah, simple, the app ain't working! For the past days I get "Cannot connect". But a question I asked a day or so ago are some or no members able to use the app?  It worked for ma a week ago. I am to understand that there is to be some kind of pow wow this week. I am sure it will be brought up.

        • tmo_chris

          Sorry to hear y'all are having issues with the new app! I am not showing any current issues that match the issues you are reporting so we definitely want to get these up in front of the devs. If you have not already, please contact us so our tech care folks can open up the appropriate support tickets.

          • sfware

            The new T-Mobile USA app is frankly, a P.O.S. (and I'm not referring to Point Of Sale ;-). Although I appreciate all of the effort that goes into developing, deploying, supporting, maintaining and upgrading the app, etc., I have deleted the current (cr)app from my phone. Good riddance! You may start your "Happy Dance" now. ;-) Back to just USSD codes and my.t-mobile.com for me, thank you very much.

             

            Have you and/or others reviewed the Google Play reviews or the new app? Most are 1 star - but I did see a 3 star review. I would give it a -1 if I could, but I digress...

             

            The "time suck" involved in opening a ("black hole" ;-) ticket is not viable - not willing to do call or chat support - no thanks. I would be willing to work with the LEAD T-Mobile app developer via email (with some VERY generous "incentives" from T-Mobile). Last time I tried to send an email to the generic T-Mobile app developer address, it was never answered (which met or exceeded my expectations ;-).

             

            The prior app at least had Android notifications and somewhat easily accessible useful info., when working, or about 60+% of the time. The current one, well, it's a crap shoot - only working about 50% (or less) of the time. And to get to useful info., it's multiple interactions with the app. No thanks.

             

            Last evening, I spent another inordinate amount of time trying to get the app to work correctly. I was in a never ending loop of try to do 2FA, the app thinking my id was invalid (The provided user_id is not found), logout, login, etc., etc. Screen shots available, but not willing to post as it has some P.I.I. Eventually, I was able to get into the app. It was just another P.I.T.A. No thanks.

             

            Earlier today, the app would only let me do 2FA with a text message - it would not let me do 2FA with security questions. And once in with 2FA, it just had the "beautiful" magenta spinning loop on all of the app options (Home, Account, Bill, Shop, etc.), except for More (again, screenshots available, but not posted here). I did send another app "Feedback", but I know how well (NOT?) that works!

             

            My guess is that 90%+ of your app users do not let you know when it fails - they just move on. Same with web site fails.

             

            I really do want T-Mobile to be successful, but...

             

            Later.

            1 of 1 people found this helpful
              • dc5fan

                My experience with the app is better, but not perfect. I think it was Chris who suggested me to use the cell network instead of WiFi to access the app. That worked! Now the app doesn't work completely, but it does give me the "Use by" money in my account that the site doesn't show. I am on the Pay as you go $3 a month. Due to my eyesight I don't do the data and messaging. A couple of days ago I chewed up about $6 on a call from a friend of mine. I tried using the app to put more money into the account, but I got the dreaded "Cannot connect". I went to the site and NO problem. On hindsight I would rather use the site instead of the app due to security. BTW I have the app version 6.8.0.16. I don't know if that version might work better than the 7. .

                • dc5fan

                  Did you receive an update Saturday or Sunday? I now have access to be able to purchase from the app. I used my credit card to add funds. Worked! The version is 7.1.0.99  I posted something yesterday morning.

                • tmo_chris

                  Hey sfware

                   

                  Our dev teams do not typically offer support to the end user as they are not equipped to handle that kind of volume but we do have a pretty robust support module for getting these types of bugs in front of them. The best way to get these concerns addressed is going to be by speaking with our over the phone support folks.

                  • magenta2476652

                    App just updated and has all my husbands info (phone number, data usage and messages and his name associated with his number) and not a word of mine.  My number doesn't show anywhere and neither does my name.  What's up with that?