My phone (Galaxy S7 Edge) consistently doesn't alert to incoming calls after switching from ATT

rollrams

    I have an unlocked AT&T-branded Galaxy S7 Edge and switched to T Mobile a few months ago to get better service where I live. I do indeed have better service now, which is a good thing. However, I've noticed that my phone never rings/alerts on some portion of my incoming calls. I don't know exactly how often this happens because it doesn't result in a missed call notification. I only find out about it if the person leaves a voicemail, which I am then alerted to, or if someone (like my wife) tells me they tried calling 5 times but I didn't answer and I show no record of calls/missed calls. While I can now make calls with great clarity from my home, you can imagine that it's frustrating to not consistently receive them.

     

    Can anyone chime on whether this is something I can address somehow (I do not have Do Not Disturb on, I've tried rebooting), or, as I have a suspicion, that this is an issue with my ATT-branded phone being brought over to T Mobile? I have also noticed that when calls come in, my phone switches over from 4G LTE to regular 4G. I'm guessing this is, again, an issue with the phone/hardware/differences between ATT and T Mobile? I'm not sure if that plays a part here.

     

    Besides the calls that go unnoticed, sometimes I'll receive a whole slew of (often group) text messages all at once, which are date stamped over the past 30 minutes or so. It's like the phone gets disconnected from T Mobile, and then when prompted gets back on. It seems like this is worse when on wifi, but I don't know if that's the case.


    In any event, do I just need to bite the bullet and get a TMobile phone? I was hoping to avoid that - I don't know if I would have switched (from ATT) in the first place if I had known I'd need to buy a new phone. The cost of the service went up already, which I was willing to deal with to have phone service that actually worked...

      All replies

      • smplyunprdctble

        The switch from LTE to 4G is because of protocols, my guess -- back in the day, some phones would drop from 3G to E when a call came in because calls only worked on the 2G network.  I'd wager something in your ATT branded phone is similar.

         

        If I had to guess, I'd think the missed calls is somehow related.  If you're at home and are able to use your WiFi for data for a bit (or don't mind the lower speeds), try changing your default connection type from LTE to 4G or so.  That may help confirm it's the phone's setup.  If it is the phone, there's nothing that can be done to resolve it.

        1 of 1 people found this helpful
        • eplerd

          If you have a really technical friend (programmer, gadget freak, etc) they should be able to flash (load) T-Mobile firmware onto the phone to "convert" it to a T-Mobile phone. ( [ODIN] Stock Nougat Firmware [SM-G935T] S7 E… | T-Mobile Samsung Galaxy S7 Edge  )

           

          I did this for my friend's two S7's with similar issues - calls came in and they never knew it till they saw voice mail indicator despite having plenty of signal at home.

           

          I believe this is due to the internal phone software (OS/Firmware) not using the same frequency bands that T-Mobile uses (internal modem files are different).

           

          The T-Mobile firmware load on their phones changed them from SM-G930A models (A for AT&T) to SM-G930T models (T for T-Mobile) and loaded all the custom T-Mobile software and removed AT&T's.  Of course this required a full backup of all of their data (photos, apps etc) using Samsung SmartSwitch (free application) on a laptop and putting phone into a special "download" mode to do so - not for the faint-hearted, but certainly beats spending $800 or so to get a new phone (unless you WANT a reason to get an S9 LOL)

           

          Once this process was done my friend's phones boot up with T-Mobile "splash screen" (White background with ping TMobile logo) and play their jingle and have all the software an S7 Edge bought at a TMO store would have.

           

          DISCLAIMER - if done wrong it CAN (rarely) "brick" the phone (make it unusable) but generally that can be fixed with reflash by Samsung rep at a best buy store.

          This IS RARE, but can happen if the person doing it messes up (also any files in "private" area of cell need moved before backing up or they get erased).

           

          Hope this helps...

           

          Dave in Tampa

          • tmo_marissa

            Hey, rollrams! Just wanted to check in here and see how things were going. Did you have a chance to try out smplyunprdctble's suggestion of switching the default connection type? What were the results? Can I also double check to make sure your calling preferences aren't set to use WiFi in any way? Lastly, when you set your phone up for T-Mobile, did you use the APNs located here: Bring your own device setup guide?

            • tmo_amanda

              Hey, rollrams!

               

              I see you're new to our Support Community; welcome! A couple different suggestions have been made on your thread. Have you had a chance to try out the steps that smplyunprdctble mentioned above? We don't want you to buy a different phone to work on our network unless it's absolutely necessary.

               

              Keep us posted!

              • tmo_mike_c

                Hi there!

                 

                I see you've gotten some really awesome suggestions from our Community folks here. Did you still need help? Please give us a reply back and let us know if the suggestions above helped you out. Thanks!

                • rollrams

                  Nothing here has prompted a fix of the situation. I don't know what I was hoping for - maybe either confirmation that I have an issue common with bringing android phones from other carriers and/or something I'm clearly missing that can fix the situation. Neither of those things have materialized. However, in the BYOD app it does say, by inputting my IMIE #, that my phone may not be compatible. I thought I had looked around and read that an AT&T Galaxy S7 Edge would work, but maybe I'm remembering wrong. It appears to be clear that, for whatever reason, my phone isn't perfectly compatible with T Mobile. I'm going to have to consider buying a new phone or going back to AT&T (it is cheaper due to corporate discount).

                  • tmo_mike_c

                    Hi again.

                     

                    Have you tried a factory reset on your phone? My apologies I don't have any other suggestions, but I'm thinking that could really help. Please let us know if you've given that a shot.

                    • eplerd

                      rollrams ,  No need to buy a new phone.

                       

                      I TOO recently switched from AT&T to T-Mobile and brought a Samsung Galaxy (but an S8-Active).

                      What I found is that if WiFi is turned on the phone tries to activate WiFi calling which of course won't work as it has AT&T's WiFi Calling firmware on it which isn't compatible.

                       

                      TRY TURNING OFF WiFi and see if that resolves the issue - no need for factory rest like mike suggested.

                       

                      I found if my WiFi is on at home I DO NOT GET CALLS (I'm anti-social and mainly get sales calls so I don't mind much LOL).

                       

                      When I turn off WiFi the phone rings fine!***

                       

                       

                      I DO think I have a solution to MY issue and that is to install the latest T-Mobile firmware onto my S8 Active like I did for my friend's two S7's.

                      It's a little tricky but I've delved into firmware updates, rooting, etc in the past but this made my friend's SM-G930A (At&T) boot up and show it is now a SM-G930T (for T-Mobile) AND even removed the AT&T bloatware and installed T-Mobile's much smaller set (so more free space on phone).

                       

                      Anyway, if you don't want to mess with firmware updating (wouldn't blame you - it's kinda tricky/scarey) just try the WiFi off and see if THAT helps!!

                       

                      Dave in Tampa