S9 Speakerphone Issues

justmeily

    Anyone else having issues with using speakerphone on the S9 or S9 plus? Most of the time the person I'm talking to tells me I sound muffled or I'm underwater. Online forums seem to indicate that this is related to the HD/VoLTE calling, however it doesn't seem like there's a way to turn it off. When I call customer service they say it's not a known issue. Any ideas?

      All replies

      • westromphil@gmail.com

        Re: S9 Speakerphone Issues

        Hi Justmeily,

        I had the same issue and called customer service. 

        They told me to change the following setting.

         

        Open settings

        Tap on Connections

        Open Mobile Networks

        Tap on Network mode

        Change this setting from LTE/3G/2G to 3G/2G.  You cannot make this change while on a call.

        For some reason, this setting is actually 4G/3G/2G, but the S9 doesn't say that.

        When you make a call, it will still show HD call, but not HD plus like with the LTE setting.

        This has helped me a lot with the muffled speakerphone issue.

        Hope it helps you.

        • jay968

          Re: S9 Speakerphone Issues

          I know this is a fairly old thread but to be honest I find it appalling that the suggested solution is to turn off one of the major reasons for purchasing this phone (LTE). This is NOT a solution but just an avoidance of the problem.

          I recently purchased an S9 and am finding it to be probably the worst phone I have ever owned. Hardly a day has gone by when I have not had some issue that I have spent hours trying to resolve. Some I have just thrown my hands up and given up on.

          The speakerphone absolutely stinks and is basically unusable unless I put my mouth right up to the microphone, thus pretty much defeating the purpose of a speakerphone to begin with.