Samsung Galaxy S7 Edge Soft Bricked After Security Update

magenta4664115

    Anyone else have this problem? There was a security update T-Mobile released a few days ago for the Samsung Galaxy S7 Edge, and apparently my phone decided to update itself two days ago. I left my Samsung Galaxy S7 Edge on overnight, and when I woke up the next day and tried to turn it on, the phone got stuck at the T-Mobile boot screen and refuses to go any further. Looks like it's faulty firmware that didn't work on my phone for whatever reason.

     

    I've tried wiping the cache partition and even went out of my way to flash the new G935TUVS4BRC1 firmware onto the device via Samsung Odin, but nothing has worked so far. I haven't rooted my device or done anything out of normal use. I am trying to avoid performing a hard reset on the device as that would wipe out the important data I have on my phone. Looked into data recovery options but they look like they're going to run me at least $1,000... for a problem that I didn't cause.

     

    T-Mobile, is there any way you can make this right? I need the data on my device as the Google Authenticator codes on there provide me access to important accounts. What can I do here?

      All replies