Can't activate Visual Voicemail

snowkilts

    Hi, I recently bought a new phone (Huawei Mate 10).  I downloaded the VVM app but it will not activate.  It tries for a few minutes, then says "We are experiencing some issues with activation.  We will retry in a few minutes." 

     

    Any ideas?

      All replies

      • tmo_lauren

        Re: Can't activate Visual Voicemail

        Hey there!

         

        Have you already tried checking to see if there are any updates available for the app in the store? Have you tried a device restart? Is there any other issues you are having with data based apps?

         

        Once we know some of that, we'll go from there!

         

        -Lauren

        • magenta5325185

          Re: Can't activate Visual Voicemail

          Same here. The app would not work on my P20 pro phone.Hopefully the "engineers" can fix this soon.

          • huskymom11

            Re: Can't activate Visual Voicemail

            I was also having this issue and figured it out.  You need to go into your phone settings and turn off Visual Voicemail for the phone:  Settings > Wireless & Networks > call settings > additional settings > voicemail... here you turn off Visual Voicemail and try again.  Good luck! 

            1 of 1 people found this helpful
            • 5035101309

              Re: Can't activate Visual Voicemail

              I have a Huawei mate 9 and about a month ago I totally wiped my device.  Since then I have had the same activation issue and msg with the T-Mobile visual voicemail app.  I have tried a number of things and was passed off to a engineer.  I did a network reset for the sim.  Next thing they want me to try is putting the sim in a working phone and seeing if I can activate on that device.

                • magentatechie

                  Re: Can't activate Visual Voicemail

                  Hey there, 5035101309, did you try the suggestion from huskymom11 above?

                  Settings > Wireless & Networks > call settings > additional settings > voicemail... here you turn off Visual Voicemail and try again.

                    • jesusmylord

                      Re: Can't activate Visual Voicemail

                      My visual voicemail was turned off automatically in the call settings.  T mobile did a reset on their end, and I wiped device cache, and it appears to finally be working a day later

                        • magentatechie

                          Re: Can't activate Visual Voicemail

                          So glad to hear that!

                            • 5309030506

                              Re: Can't activate Visual Voicemail

                              T-Mobile ! This is absolutely ridiculous !! You can tell by the number of followers that this is a MAJOR issue! I have tge exact same issue. Iver and iver and iver! When these people asked for help they were given the runaround like it was aan error only for that person who was brave enough and had patience enough to write for help. It is an error effecting thousands of people. Why the hell dont you fix the issue? I have invested many many hours fighting with the tmobile site looking for a solution  Finally fiund these threads and i just can not believe it was identified as needing a fix and sooo pissed that the engineers didnt bother to answer! I have very much had it with the customer service and lsck thereof! The site is pretty much useless every single time  just trying to pay my bill takes hiurs! Dont even get me started on talk time limit gone over and disconnecting me from an emergency call from my disabled mother and tgen unable to even call or use website to add money to see if my motger eas still alive. Ive had it! Years and years ive been a loyal customer  As soon as i find another carrier that i can get data and unlimited talk and text reasonably  i am soo done with tmobile! You obviously dont care. I don't ever know why i bother to comment. Get a clue and make your website and customer services in line!! It is visually pleasing but tgat juust dousnt get it!!  I just wish i had not invested so very very many hours of my valuable time!!!

                      • zaidz80

                        Re: Can't activate Visual Voicemail

                        Same issue here. I have Mate 10 pro. Tired of trying. The Visual voicemail option is not available under the additional setting!!! I assume that the T-moble network is blocking Huawei phones for some reason.

                        • juiceit

                          Re: Can't activate Visual Voicemail

                          I cannot get visual voicemail on iphone se with t mobile 55+ plan.  It looks like this has been a t mobile problem for years now and it still isn't fixed or available.

                          • magenta6616543

                            Re: Can't activate Visual Voicemail

                            PROBLEM SOLVED!!! Pixel 3 native VVM would not activate.  Tried everything, clearing caches, uninstalling phone app (latest update), reinstalling and all of that with variants of installing/uninstalling T-mobile VVM app (which prefer not to use in lieu of phone vvm).

                             

                            The issue was.....PHONE ENCRYPTION.  I use Gmail for both personal and work (MS Exchange account). My work exchange account as a cert that forces phone encryption.  I removed my Gmail work account and INSTANTLY, VVM came to life.

                             

                            I have not yet reinstalled my work account but will.  The alternative email app for exchange I will use is Nine which allows for app-based encryption rather than system-based encryption.

                             

                            So, if you're having issues, consider if you have an app that is forcing full-system encryption.

                             

                            Hope this helps someone.

                              • magenta6616543

                                Re: Can't activate Visual Voicemail

                                Update...kind of back to square one.  After my I removed my exchange account and was using native vvm successfully, i felt confident I could try a couple other android exchange email providers such as blue mail or Nine (of which I was already familiar).  I tried Blue Mail to see if it gave me the option for just app-level security versus the system level that is auto chosen for Gmail, Outlook and perhaps, others.  Turns out there was no setting and it went through the setup process rather smoothly.  After install, I found that VVM was no longer activating.  I thought I'd do what i'd done before with Gmail, i.e., remove the app/account so I did but still no luck.  So at this point, i just did a factory reset knowing I already have my data backed up thinking that would be my last ditch effort and actually start fresh without back up (which I did)...the VVM would not activate.

                                 

                                So this is really, really strange...even on a fresh factory reset, not using any back ups, it doesn't work...yet I know it "does" with T-Mobile because I had it with my Pixel 2 and just yesterday very briefly after I removed my Gmail exchange account...hmmm, like a dog with a bone on this one but gotta get my work done.