LTE to E

schackers

    Having trouble lately...my phone is on E and i cant do anything. Anyone know why? Its normally LTE from the locations i frequent.

      All replies

      • mrt905

        Re: LTE to E

        Have you visited a T-Mobile store to verify if other customers are experiencing the same issue in the area, or it may actually be your phone that's causing the issue.

        1 of 1 people found this helpful
        • thelimerunner

          Re: LTE to E

          What kind of phone are you using?

           

          Have you tried manually selecting the network mode to LTE instead of 2G (E)?

          1 of 1 people found this helpful
          • dragon1562

            Re: LTE to E

            As others have mentioned what phone are you using? Is anyone else in the area having a issue? Have you tried contacting T-mobile support to see if there was a upgrade or outage in the area? You can contact them via phone or over social media.  Contact Us

            1 of 1 people found this helpful
            • tmo_chris

              Re: LTE to E

              Just checking in here to see how things are going. Did you still need help with this?

              • tmo_marissa

                Re: LTE to E

                Hullo, schackers, and happy Monday! It looks like our Community members had some good questions here. If you're still having trouble with your network connection, a few more details could help pinpoint the cause and next steps for you! Please let us know if you still need some assistance. Thanks!