T-Mobile USA App for Android 6.7.1.5 not working

sfware

    Since upgrading to the T-Mobile USA App for Android 6.7.1.5, it no longer works on an unlocked non-rooted Motorola G3 (Motorola G 3rd generation) with 2GB RAM and 16GB ROM. The prior version of the app (maybe 6.0.1.40?) worked most of the time. I have tried every known researched and suggested resolution options, including, but not limited to, deleting and reinstalling the app (probably at least a dozen times), rebooting the phone, changing T-Mobile password, clearing cache and data, force stop and restart, booting into recovery mode and clearing the phone system cache, deleting other apps, etc., etc., etc.

     

    I have called T-Mobile support (very nice and trying to be very helpful), have engaged Executive Response (very nice and trying to be very helpful) and tried all known T-Mobile support options. So getting support is "an issue" when the T-Mobile app is not working, the my.t-mobile.com "Message Us" always says "Session expired" (will start a new discussion later on that one) and the Support Community access is/was deactivated and no T-Mobile email support option. A big thanks to Meisha via T-Mobile support call center and tmo_marissa for getting my Support Community access reactivated!

     

    Anyway, when I upgraded the app and try to run after allowing all options, I always get into a recursive situation where the first attempt to run the app says "Getting your info" then "... technical difficulties ...", exit with "Not now", then the second attempt says "And done" then "... cannot authorize your account ...".

     

    Here are the screenshots in the order of this wonderful (not!) recursive problem:

     

    Screenshot_20180322-083938.png

     

    Screenshot_20180322-082821.png

     

    I select Not Now and here is the second set of screenshots:

     

    Screenshot (Mar 22, 2018 08_40_43).png

     

    Screenshot (Mar 22, 2018 08_28_44).png

     

    Anyone else experienced this and can offer a solution?

    Thanks!

    Steve.

      All replies