Outbound callerID blocking my number despite settings

privacy789

    I, too, am having a still unresolved issue with Tmobile blocking my phone number when I place outbound calls.  This has been going on for welll over 2 weeks. Many calls to Tech Support haven't resolved it. 

     

    Ever since I started with T-mobile in 2013, my outbound callerID was to SHOW my phone number but block my name from appearing.  Settings on my phone (LG G2) had it set for "network".  Now whenever I call someone or business they either do not answer or answer cautiously because ... my call appears on their phone as "anonymous".

     

    One agent said he issued a trouble ticket but that was a good 8 days ago.  He did mention that about the time I experienced this, there was a "network update".  He also submitted "unknown caller" for the name field.

     

    Could someone please get this sorted out?  Thanks in advance.

      All replies

      • tmo_mike_c

        Aw man. We definitely don't want folks to avoid your calls because of your caller ID. The ticket is a good last resort to get this resolved and there should be updates on the ticket after about 3 days. Have you reached out to tech care folks to see if there is any news? There is a way to get it updated and sent back to engineering if this is still an issue.

        1 of 1 people found this helpful
        • tmo_lauren

          Just wanted to check in on this!

           

          -Lauren

          • miket

            I haven't used the "gewneral" GSM codes in ages - because most phones now  have most common codes built into their menue system.

              Here is one site that lists most of the codes:  GSM Feature Codes      Do a Google search - "GSM Codes"

             

             

            Caller ID / Call Display


            If you wish to either show or hide your phone number on outgoing calls then you may either set this on your phone's menu or manually enter the code before dialing. These codes will override whatever menu setting you have on a per-call basis.

            Do not display: #31#[phone number]
            Display: *31#[phone number]
            Status: *#31#

            North American GSM service providers also support the landline codes for this feature (these also work on CDMA and iDEN phones):
            Do not display: *67[phone number]
            Display: *82[phone number]

            There are also codes to show or prevent incoming numbers from being shown on your handset if you subscribe to this feature. I'm not too sure why you'd want to do this, but just in case you do:

            Do not display: #30#
            Display: *30#
            Status: *#30#

             

             

            1 of 1 people found this helpful
            • tmo_mike_c

              Hello again.

               

              Just checking to see if you have any updates on this. Please let us know if you still need some help.

              • tmo_marissa

                Hi, privacy789! Just wanted to check in and see if you'd noticed any change or update since that ticket was submitted. One thing that might be worth noting is that there are two major Caller ID vendors, so when we perform an update (like changing the name field to "Unknown Caller") those updates will happen with any customer that subscribes to service from a company that uses the same vendor as T-Mobile pretty quickly. However, the other vendor's clients will not see the change in your Caller ID until their particular carrier/landline company performs a routine update to their Caller ID system. For some companies this is quarterly, and for some it might happen every six months. Mike is correct, there are escalation processes we can follow if this isn't getting resolved for a person you're calling who uses the same vendor as T-Mobile, so if you're still having trouble, we'd definitely like for you to reach out.