NAS on TCM-A1900 permission problems.

wacojohn

    I hope this is posted in the right place.

     

     

    Problem machine .. W10-64.

    Working machines .... W7-64, W7-32

     

    When accessing the router from ANY machine, this is what shows (it's in the Samba Share page).  Permission columns are blank.:

     

    noperm.PNG

     

    This does not seem to effect the two W7 machines, but the W10 machine .. is a different story.

     

    I can do just about anything with any machine with Windows Explorer.  Access NAS folders, write to the NAS, delete, anything I want.

     

    Each machine has EaseUS Todo Backup Home 10.6 installed.  Even with that, I can back up to the NAS from either W7 machine, but not the W10 machine.  I get an error:

    failed.PNG

    Easus support tells me to be sure I have write permission ... and I would say I do because I can write to the NAS with W Explorer on any machine, and I can backup to the NAS from both W17 machines.  Kinda tells me the NAS is writeable ... even though picture number 1 doesn't indicate ANY permissions(???)  Easus says If I can't fix the problem with proper permissions, they will do a remote access to my W10 computer ... and I am not anxious to do that.

     

    so, really, I can't figure out what is wrong with W10.  It worked just fine, .. until I upgraded the NAS to a newer/bigger drive.  The new drive is an 8TB NTFS drive.  It is not only shown under NETWORK in W Explorer on ALL machines, but it is also MAPPED as drive M: if that helps.

     

    I think I need to know how to check the W!0 permissions for the NAS ... but really don't know how.  Since W7 works fine, need to see what kind of permissions W10 is allowing ... I guess. Also, the lack of permissions in the router (picture #1) seems odd too.

     

    Any help is immensely appreciated in advance.

      All replies

      • smplyunprdctble

        Re: NAS on TCM-A1900 permission problems.

        I'm going to have to rack my brain.

         

        I saw this a year ago with my Windows 10 machine and a WD NAS.  I eventually discovered the correct keywords to search and answer my problem (it was a Windows problem, not a NAS problem).  There was something turned off or disabled on the Windows 10 machine that didn't work (I actually had one Windows 10 machine that did work, which made everything all that much more complicated).

         

        I think it had something to do with the default share permissions being read only and Windows was like "oh, I can see something, I won't ask credentials".

         

        Because I'm recalling something in my past, I think the drive change is a red herring.  Hypothetically, if you put the original drive back, you'll experience the same problem.  But, this is still something you need to test.  If it works with the original drive.. well... there's a possibility the new drive has something odd with it (maybe it's the FS format, maybe it's a size limit, who knows, but it doesn't seem like this is probably the case because W7 is fine).

         

        The other thing that TM support would have you do if you're blaming the router is to factory reset the router to see if that resolves.  I'm not ruling out this idea, but I have a feeling it won't work.

         

         

        I'm assuming your drive map on Windows is read-only as well, not just your backup software having problems?

         

        For giggles, have you tried unmapping the drive and re-mapping it from the Command Line?

         

        net use <driver letter> \\<servername>\<sharename> /user:<username> <password>

         

        Example:

        net use w: \\myserver\fileshare /user:MyID MyPassword

         

         

        1 of 1 people found this helpful
        • tmo_amanda

          Re: NAS on TCM-A1900 permission problems.

          Hey, wacojohn!

           

          I must say, I'm completely clueless as to how to fix the permission issues. It sounds like smplyunprdctble may be able to help but he had a few questions and a suggestion for you to try. Please get back to us as soon as you can so we can figure out how to solve this.

          • tmo_mike_c

            Re: NAS on TCM-A1900 permission problems.

            Hey there!

             

            Just checking in to see if this was resolved. Please give us an update and let us know how things are going. Thank you.

            • tmo_mike_c

              Re: NAS on TCM-A1900 permission problems.

              Hello again.

               

              Just wanted to see if you've checked out smply's post to see if that was helpful. Please let us know. Thank you!

              • wacojohn

                Re: NAS on TCM-A1900 permission problems.

                I am really sorry for the late reply. I was not notified of a reply from you. Got lucky andtook a look just now.

                 

                The good news is that it all seems to be working now. The bad news is I don't know what fixed it. With 4 computers, 3 operating systems and 1 router it was a baptism of fire with public/private networks, file sharing, and a networking rookie like me, I just started trying things.

                 

                First, I  learned it is not a NAS device. It's merely a USB drive connected to a router. There is, apparently a big difference. Truthfully, I cannot document what I did, but thank you for your time and attention.