Subject headers for MMS messages

mrrogers327

    Currently on my Galaxy s7, all MMS messages by default display <Subject: NoSubject>. Is there a way to disable the display so that MMS messages look like regular text messages?Community

      All replies

      • tidbits

        Re: Subject headers for MMS messages

        T-Mobile branded?

        • dragon1562

          Re: Subject headers for MMS messages

          Well it should show up as a (random.img) header unless in a group chat. Generally speaking there is not as far as I am aware. Has this always been like this or did it just start happening? Is this a T-mobile branded phone like tidbits asked?

          • tmo_chris

            Re: Subject headers for MMS messages

            This is pretty strange. I couldn’t really find anything on the internet about this except that if you are using Hangout as your default messaging app that you can try clearing the Hangouts app cache and data and testing again.

            • tmo_mike_c

              Re: Subject headers for MMS messages

              Hi there!

               

              Just checking to see if you've tried the suggestion above. Please give us a reply and let us know. Thanks!

                • mrrogers327

                  Re: Subject headers for MMS messages

                  Hi,

                   

                  so I completely removed hangouts from my phone through force stop and

                  uninstalling updates, and lastly turned off the app. However the mms

                  messages still display the no subject header.

                    • tmo_mike_c

                      Re: Subject headers for MMS messages

                      Ah okay. I appreciate you testing that out. I could find much on this with your particular phone. The only thing I could find was related to other Samsung models with an option to change the header in the settings. However, this may only be for a group message you started on your phone before you sent it. Sorry my friend. I wish I had more I could offer.

                      • tidbits

                        Re: Subject headers for MMS messages

                        mrrogers327 wrote:

                         

                        Hi,

                         

                        so I completely removed hangouts from my phone through force stop and

                        uninstalling updates, and lastly turned off the app. However the mms

                        messages still display the no subject header.

                        Contact Samsung as it's an International thing, and not a T-Mobile thing.  I have the S7E to Note8 and they do not have a subject line and no way to add one. Here's probably the best place to ask.

                         

                        Cell Phones - Samsung Community

                          • brhodes1

                            Re: Subject headers for MMS messages

                            I disagree about it being a Samsung problem.  I seem to think this is a T-Mobile issue.  With that being said, it COULD be a Samsung problem but one which only applies to T-MOBILE phones.

                             

                            I have a Verizon branded S10 which I purchased from the Verizon store the day of it's release approximately 2 months ago.  Last week, I switched my service to T-Mobile and put in my T-Mobile SIM card.  When receiving picture messages or any messages in a group text, I get these annoying subject headers.  This never happened with my Verizon SIM card in.  I know some people blamed the Hangouts app but I do not have that app and I have never used that app on this phone.  I tried clearing the cache of my Messages app and that did not work.

                             

                            Any help on this issue would be of much assistance.

                             

                            Thanks,

                            Bob

                              • tidbits

                                Re: Subject headers for MMS messages

                                It's a Samsung problem. It's a known issue for a long time. Your S10 is Verizon branded and their MMS setup is different. If you had an unlocked S10 you would have the problem with all carriers.

                                 

                                I have an unlocked version with AT&T, Verizon, and T-Mobile Sims and I have this very problem. I also have a International Sony XZ2 which has this problem only on AT&T. Ironically if I use MVNOs it happens with T-Mobile NVMOs and not AT&T MVNOs.

                                 

                                I used to work for the DoD doing interference work, but I retired from it.

                            • tmo_mike_c

                              Re: Subject headers for MMS messages

                              Hi there!

                               

                              Have you tried reaching out to Samsung about this? Please let us know what you find out. Thank you!

                          • tmo_chris

                            Re: Subject headers for MMS messages

                            Just checking in here to see how things are going. Did you get a chance to speak with Samsung yet?

                            • tmo_mike_c

                              Re: Subject headers for MMS messages

                              Hey!

                               

                              Have you heard any word from Samsung? Please keep us posted and let us know what they've told you? Thanks!

                                • magenta4354518

                                  Re: Subject headers for MMS messages

                                  This is a known issue with T-Mobile for years. Search the internet and you'll see plenty of complaints on different forums. I had a Samsung Galaxy Note 3 branded with T-Mobile, with no issue. Now I have Huawei Mate 10 Pro unlocked and the issue exists. It seems more common for non branded phones in general and is an exclusive problem to T-Mobile. I spoke with support,  troubleshooted with no luck, resetting and checking all messaging settings. Huawei support said it was likely my carrier.

                                    • tidbits

                                      Re: Subject headers for MMS messages

                                      magenta4354518 wrote:

                                       

                                      This is a known issue with T-Mobile for years. Search the internet and you'll see plenty of complaints on different forums. I had a Samsung Galaxy Note 3 branded with T-Mobile, with no issue. Now I have Huawei Mate 10 Pro unlocked and the issue exists. It seems more common for non branded phones in general and is an exclusive problem to T-Mobile. I spoke with support, troubleshooted with no luck, resetting and checking all messaging settings. Huawei support said it was likely my carrier.

                                      It has to do with international devices not made for the US device.  Just because a device sold in the US doesn't mean they modified the code from their international counterparts.  International devices could add a toggle to turn that off or not, but they don't.

                                        • magenta4354518

                                          Re: Subject headers for MMS messages

                                          While that may be true, no other carrier has this issue with the headers in messages. I don't even have a way to edit the subject line if I really wanted to write one, it's just there looking ugly by default. Huawei never intended to provide the feature nor expected to support it from what I can gather.

                                        • cliff29

                                          Re: Subject headers for MMS messages

                                          We sure hope that T-Mobile is reading this thread!  My husband and I have Moto Z Play phones (one is two+ years old, one less than a year old) and we had NO problems with that "No Subject" line using the same phone and the same Chomps MMS app while using Straight Talk service.  (We used Straight Talk for over 11 years with several unlocked, non-Straight Talk,  phones.)  We feel your pain.

                                           

                                          Now, T-Mobile "Expert" Teams are telling us to try our SIM cards in other phones and/or try a new SIM card and that if those things are ok, it's our "handset."  They've said NOTHING acknowledging that this has been a problem for many phones over many years.  (We've WASTED hours in two T-Mobile stores + on the phone with Customer Care and with the Tech Team.)

                                           

                                          I don't know if our phones are "international" but they are unlocked.  That should not cause a problem.  Wasn't for Straight Talk.

                                           

                                          T-Mobile -- Please have some of your "Experts" a) fix this problem, b) acknowledge that this problem exists with some phone types and/or c) suggest a text app that will work appropriately on T-Mobile's network with ANY phone that is brought to your network.

                                            • dragon1562

                                              Re: Subject headers for MMS messages

                                              Straight Talk uses all four carriers networks for their service. Depending on what SIM you had you could have been using say Verizon's network. I would suggest using the default messenger app that comes with the device. Also making sure to check your APN settings on the affected devices. The reason for testing other devices is useful is because it helps to see if it is a device issue. Which it very well could be in regards to settings on the device. Also, T-mobile has a BYOD policy like every other carrier. They can not guarantee your phone will work with their network. No carrier can and it's unrealistic.

                                               

                                              Like I said though I would check APN settings and maybe even do a network settings reset on the device. As well as trying the default messenger that came on the phone.

                                        • per2070

                                          Re: Subject headers for MMS messages

                                          I've had my Samsung S8 since 12/2017 with Verizon as my carrier and didn't have that problem. I just

                                          switched the same phone from Verizon to T-Mobile 2 weeks ago and this problem of, <Subject: NoSubject>,

                                          just started.  It's not only Group Conversations, it's individual Conversations as well but intermittently on

                                          the individual replies, one reply in the individual conversation might present the <Subject: NoSubject>

                                          and the very next reply may or may not present that header?  So I'm thinking it's not an International

                                          Samsung problem and could be T-Mobile specific, in my case?

                                          • per2070

                                            Re: Subject headers for MMS messages

                                            Forgot to mention that my wife's phone has the exact same issue.  It's a Samsung S8 too, bought both together 12/2017.

                                              • per2070

                                                Re: Subject headers for MMS messages

                                                Update: Seems the problem was that MMS was not Configured on our phones.  Reason being is that I bought these phones Online!!  The T-Mobile SIM

                                                cards were sent to me in the mail and all I was to do was install them and have them activated. That was all done correctly and the phones were working.

                                                The step that was 'missed' was that I was suppose to go to the T-Mobile store for them to configure MMS on the phones, didn't know that.  Just spent an

                                                hour on the phone with their subject matter expert and got the issue resolved.  We configured the phones for MMS manually and ALL is well.  Here's

                                                the instructions that I followed that worked FOR ME; no more <Subject: NoSubject> header:

                                                 

                                                • To set the Access Point Name (APN) and turn on data settings, follow these steps:
                                                • Go to the Home screen.
                                                • To open the menu, swipe up or down on the screen.
                                                • Choose Settings.
                                                • Choose Connections.
                                                • Choose Mobile networks.
                                                • Choose Access Point Names.
                                                • Choose ADD.
                                                • Under Name, enter T-Mobile MMS
                                                • Under APN, enter epc.tmobile.com
                                                • Scroll down.
                                                • Under Multimedia message proxy, do not enter anything
                                                • Under Multimedia message port, do not enter anything
                                                • Under MCC, enter 310
                                                • Under MNC, enter 260
                                                • Under Authentication type, check Not set.
                                                • Choose APN type.
                                                • If this screen appears, enter mms (note: in lower case) and choose OK.
                                                • If this screen does not appear, check MMS and choose OK.
                                                • Choose the options symbol.
                                                • Choose Save.
                                                • Return to the Home screen.
                                                • To finish the process and activate the settings, you need to restart the device. Your Samsung Galaxy S8 will then be configured to use of MMS.
                                                • For instructions on how to restart your device follow the next steps.
                                                • To reboot the Samsung Galaxy S8, press and hold the power button on the side of the Samsung Galaxy S8.
                                                • Choose Restart.
                                                • Choose Restart.
                                                • The Samsung Galaxy S8 will automatically reboot.
                                                • If this screen appears, enter the PIN code and choose OK.
                                                • If this screen does not appear, go to the next step.
                                                • If this screen appears, swipe your finger over the screen to unlock it.
                                                • If this screen does not appear, go to the next step.
                                                • The Samsung Galaxy S8 is now ready for use.
                                                • The device is set up for MMS. If you have data coverage, you can send a message to test the connection.
                                              • abbo

                                                Re: Subject headers for MMS messages

                                                I just purchased my first unlocked device. Galaxy S10+ directly from Samsung because the T-Mobile carrier versions were sold oit at the time. I have been with T-Mobile for 18 years. This was the first time I have ever seeln this issue with subject: no subject for group texts only. 

                                                 

                                                I tried other suggestions and none of them worked for me.

                                                 

                                                For the time being, I installed google messages app and I don't have the issue I did with default message app installed.

                                                 

                                                I did not test any other third party messaging apps but Google messages will work for me just fine.

                                                 

                                                Wierd how annoying that extra subject line can be

                                                • saral13

                                                  Re: Subject headers for MMS messages

                                                  Has anyone been able to successfully solve this issue

                                                  M

                                                  • magenta8623558

                                                    Re: Subject headers for MMS messages

                                                    I just spent an hour with Samsung Tech and after not able to help me with the issue they said it's the problem is with T-Mobile and they sent me the link to this forum.

                                                    I start having this annoying subject header when I switched to using unlocked AT&T Samsung Galaxy S10+ phone with T-Mobile SIM.  Never had this problem with T-Mobile brand phones.  So it's not just international phones, but it appears the problem is with any phones that are not T-Mobile phones.  So far there's no fix to this, just have to live with it for now.

                                                    • brhodes1

                                                      Re: Subject headers for MMS messages

                                                      I disagree about it being a Samsung problem.  I seem to think this is a T-Mobile issue.  With that being said, it COULD be a Samsung problem but one which only applies to T-MOBILE phones.

                                                       

                                                      I have a Verizon branded S10 which I purchased from the Verizon store the day of it's release approximately 2 months ago.  Last week, I switched my service to T-Mobile and put in my T-Mobile SIM card.  When receiving picture messages or any messages in a group text, I get these annoying subject headers.  This never happened with my Verizon SIM card in.  I know some people blamed the Hangouts app but I do not have that app and I have never used that app on this phone.  I tried clearing the cache of my Messages app and that did not work.

                                                       

                                                      Any help on this issue would be of much assistance.

                                                       

                                                      Thanks,

                                                      Bob

                                                      • martyg68

                                                        Re: Subject headers for MMS messages

                                                        Any news on this?  Using Verizon branded phone; flashed to T-Mobile using T-Mobile SIM and having the same issues with subject line. 

                                                        • martyg68

                                                          Re: Subject headers for MMS messages

                                                          For whatever reason this has stopped being an issue; now it's working as normal and I didn't change anything, just started working.