Who do I call to complain about poor technical support and solve the problem?

prettyez

    Hello and thanks for reading this.

    I'll try to make it short.

    Was extremely happy for about a year and 2 months. From the service and the customer service.

    About 2 weeks ago my personal cellspot stopped working.

    I've had it!

    In those 2 weeks I wasted my time on numerous calls (many of them by request by my T-Mobile support representative), including to my Internet provider.

    3 representatives told me they are going to call me back for continuing the process and never did.

    I have in now my house 2 brand new mini towers, none working and nobody to talk to.

     

    What I would like to accomplish here:

    I'd like to have my case assigned to one (and only one) knowledgeable, polite and efficient representative, that will stay with me from the first talk till we solve the problem and I have my reception back.

    I work very hard for my money and here I'm paying T-Mobile for a service that I don't get.

    Thanks in advance for your help.

    Saul

      All replies

      • snn555

        Well. This is a customer to customer Forum, but if we know the issue we can help. I've had a booster, LTE cellspot and a wifi cellspot.

         

        Let us know what we can do.

          • prettyez

            Thanks snn555 for your kind offer, I very much appreciate it.

            (I thought T-M read those posts.)

            I'd like to try first to let the TM customer support do their job (if I succeed to get them to do it)...

            If it won't work I will be more than happy and very thankful to ask for help again here.

            Again, thanks a lot.

            Saul

              • tmo_mike_c

                Wow, this is a sad story but we do wanna help you as best as we can here prettyez . What's going exactly with the mini towers? Are they not powering up or are you connected to them and just not able to use the service? Please give us some specifics so we can help. Thanks!

                  • prettyez

                    Thanks tmo_mike_c

                    I had an older mini tower that worked perfectly for about 5 months.

                    The new tower TM sent to replace the malfunctioning one didn't succeed to start at all.

                    After troubleshooting it with TM tech support over the phone they sent a new one. Also this one didn't succeed to start.

                     

                    My Internet provider is Comcast/Xfinity. I use an Arris model TG1682G modem from Comcast and an Apple 3TB AirPort Time Capsule router for my home network.

                     

                    The problem: (with both of the newer towers) after connecting all wires to the tower (power+ Ethernet cable from Xfinity modem+ GPS) and after the tower finishing it's setup, only the power light is blinking green and the Internet light is steady orange, all other lights are off (the only time all other lights came on was when the tower was just connected and it started the setup, or when it is trying to restart).

                     

                    What I did: called Comcast+ went to my MacBook Pro laptop and did the proper check up to make sure that all 4 ports on the back of the modem are open. They are. Also made sure that the Comcast modem/router is set to DMZ (it is, according to Comcast tech support rep).

                    Restarted/reset all peripherals (Comcast modem/router; Apple router; TM mini tower) several times.

                    .After many conversations to reps from TM and Comcast I tried also to pull my hair only to realize that I can't, it's too short!

                     

                    Thanks for your help, hope we are going to be able to solve the problem here.

                    Saul

                      • prettyez

                        Update.

                        Today I got a call from a TM rep.

                        He said the engineers ran all tests on their side and still seeing all those 3 ports (500; 4500 and 123) as closed.

                        What I need to do is call Comcast and request to refresh all my router settings. After the modem/router is working, connect the CellSpot and we'll go from there.

                        I will call Comcast on Monday.

                        Will update here on Mon or Tue.

                        Saul

                          • tmo_mike_c

                            I'm glad a T-Mobile rep reached out to you about this. Thanks for doing the troubleshooting and explaining everything so thoroughly. This is a good plan. I look forward to seeing what happens after Mon. or Tues. so we can figure out where to go from here. Thanks for keeping us updated. I'm glad you have short hair by the way. We don't wanna be the cause of premature baldness, cause that's not our style.

                              • prettyez

                                Hey Mike.

                                As of this morning it's working!

                                I am going to explain what I did, for maybe if someone else run into this exact situation.

                                Yesterday I talked to the Comcast Wireless Gate dept. (take care of Wi-Fi issues and so). Made sure the 3 ports needed on the back of their modem (123, 500 and 4500) are open and that the modem is in DMZ (as told by T-Mobile tech once). They were.

                                After resetting all devices (including modem, at the beginning I tried just to disconnect power to the modem and it didn't help, nothing changed, but after also taking out the backup battery, it succeeded to do a full refresh). But, still the CellSpot mini tower was not working.

                                I then requested to put the modem in Bridge Mode and then did again a refresh of the devices and finally the mini tower started working again!

                                 

                                But after some hours it went back to the same malfunctioning as in the beginning.

                                This morning I again contacted CC tech support and made sure all requirements still OK.

                                Now this time the tech explained to me that there is no situation when the modem can be with all 3 ports open, in DMZ and in Bridge Mode, it's either or.

                                So, what I did, since the modem ports were useless for my purpose, and tiered of calls to the companies I decided to try something on my own: I connected the mini tower Ethernet cable to my router (Apple Airport Time Capsule) instead of CC modem and.... voila!!! it's working since!!!

                                 

                                I'm waiting at least 24 hours to see it's continuing working and I'll come back and update.

                                Thanks.

                                Saul

                                1 of 1 people found this helpful
                    • nvictor32

                      are you dealing with Apple items,? if you are it's the worst items to buy, I will never buy anything from Apple, most of them have a worm, and no one wants to deal with a worm, listen I could be wrong, if you're not dealing with Apple, then I better read what you typed because I could be misunderstanding and I have to stop that.  I may be able to help you. computers are what I live for, ever since I lost my wife many years ago, and it sounds like you have a good system, as long as it's not an apple, I will read all you have and I will get back to you good luck