San Francisco LTE problems on t-mobile galaxy phones

dfreezy

    I have t-mobile branded note 8 in downtown SF and only get data if connected to wifi.  Is anyone else having these problems?  I have tried everything from changing APN to ipv4, 4/6, epc, and everything I found online to no avail. I will have full bars all over the city but speedtest will say connection problems before it can even finish it is so slow. My lyft app cannot follow my movements, no maps, no nothing without wifi. Is this common and I really need to switch providers or something to do with my phone?

      All replies

      • tmo_mike_c

        Oh man dfreezy, this definitely isn't a common problem but there are some things that can be done to help fix this. Is this only happening in the downtown area of SF? Is this only a problem when you're connected to LTE? Try switching it to 4/3G/2G and see if you're able to connect to the web.

          • dfreezy

            Very interesting! I can't believe I didn't try this earlier, thanks for to

            help. It is definitely only with 4g LTE. I switched to 3g and I get better

            speeds than i ever get on LTE no matter where I'm at.  It is not fast

            (562kbps down on 3G HSPDA+) but when I switch back to LTE this time I got

            235kbps down and 4kbps up, but only after 2 previous tests timed out, as is

            the most common outcome with both speedtest and opensignal tests for me

            without WiFi.

             

            As for locations, I had for awhile thought it was just downtown congestion,

            but have travelled out of the downtown area and have the same problems.

            Even when directly under a tower with full signal I often cannot even order

            an uber or lyft without finding a wifi spot.

              • tmo_mike_c

                Thanks for testing that out. Sometimes is if issues like this follow you where ever you go, it can point to something strange going on with the device. What's the software version on your phone? Depending on how far you're traveling, you could be on the same tower or towers that might have some congestion. In which case we'd need to have Service Complaints filed to have our network engineers to sort out what's going on with the LTE.

                  • dfreezy

                    I'm on a N950U Note 8 running Nougat with the december BQLA update.  I have

                    problems with multiple towers and even ones that are in far less

                    concentrated areas. I use LTE discovery and OpenSignal to check different

                    towers and it does seem to be the device. My problems began around the time

                    of the previous november update, and Iwas hoping they would go away with

                    the december one but it hasn't.  I'm considering trying a rollback or the

                    new samFAIL 2.5 root if I can't find any solutions, but would much rather

                    not deal with the other issues with root. Do you know when the oreo update

                    is coming for the note 8 by chance?

                      • tmo_mike_c

                        Oh man, I wish I had some specifics on Oreo for this phone, but I don't have any info on it. I do appreciate you giving and update on what you've tested. While you were with the other T-Mobile device, were did you try your SIM in their phone to see if you could get faster speeds? That's the only other step that could give us further confirmation that this could be stemming from the device. As for rooting, I gotta be honest, I'm not an expert on that. That's also not something we can recommend as this can damage the device and void the warranty.  In regards to the apps, I don't see this as being a restriction on the network level. These are both apps that should be able to give you speed results so searching for service message is a bit odd. I can see this happening if you're phone is struggling to get signal period, but  not if you're showing full bars. So, this may be so this makes me think this isn't some kind of back end network restriction.

                         

                        If you go to your Google Play app, click menu, then scroll down and select Account, do you have a list of options that shows Payment Method? I found an option on my phone to change it there, but I wanna make sure I'm going to the right option that you're using.

                          • dfreezy

                            Solved! I just wanted to let you know what it was so for furute queries you

                            can suggest this solution.  Somehow they had disabled internet on my

                            unlimited data plan, and they found it when I went back to the store a

                            second time yesterday, and just switched it on and everything was fine.

                            Not sure how this happened, but just glad it is fixed, I'm getting great

                            speeds now even indoors.  Thanks for all your help.  Next I'll try to get

                            the direct billing figured out. I do know about the google settings, and

                            have gone through the process of wiping the data cache in the google app,

                            and re adding the t-mobile method. htis works but then if i try to pay with

                            it it still says "not eligible' under it in the subscriptions settings and

                            cannot be selected.  Not a big deal though, thanks again for the help!

                        • dfreezy

                          OK, did some field testing today.  I went to the east bay, and in a very

                          unpopulated area, along with another t-mobile customer, who had great

                          speeds on a galaxy s8 on same towers, figured out for sure it is my

                          device.  I also rode the BART transit back where they have service on the

                          train and tested it there as well.  Here is what is new.

                           

                          I can use phone but mms does not upload or download and no apps can use the

                          data connection and will say "no data connection at this time' or similar

                          things.

                           

                          Speedtest will give just hang on searching for server.  But I discovered

                          that the opensignal app for some reason works! I was getting around 5mbps

                          down and up on speed test apps both in the east bay, on the transit in the

                          tunnel, and in SF on the return, but the apps would all still hang and have

                          no data, even though the radio was obviously functioning a channel was

                          available at some level.

                           

                          So i need to figure out why the opensignal app can access the radio and the

                          os cannot.  Maybe Opensignal is accessing the Native API and accessing the

                          kernal more directly and the problem in in the Dalvic jvm api or

                          something?  I only know a little bit about the os stucture, but I guess i

                          can start digging more. I think maybe opensignal is open source also which

                          could help me, but all this seems like a lot to figure out

                          programmatically.  I could use an experts help for sure.  It does seem to

                          be an os issue and not a radio or carrier issue though, unless there is

                          some kind of restrictions placed by t-mobile at a higher level on my data

                          plan?

                           

                          I do have another weird problem possibly related. I had recently changed

                          phone numbers, and ever since, I'm unable to link google play payment

                          method to direct carrier billing, even after going though the procedure of

                          clearing the data cache and re-adding the method.  It just won't let me

                          choose it from the app store and makes me use paypal or credit card.  hmm..

                          in fact the problems only occurred after the number change now that i think

                          of it. could the data plan still be linked to the old line or something

                          weird.  Ok, now I'm grasping at unlikely straws, sorry.  Just wanted to

                          provide the new information. Thanks for the help so far!