auto refill or refill by credit card doesn't work

magenta3836211

    I trying to refill my account by credit card but if i click the "use a credit card" button or "auto refill" button then they automatically go back to t mobile home. What can i do?

      All replies

      • tmo_marissa

        Yikes! I don't have any information about payment outages that line up with the timing of your post, but I can definitely do a deeper check. Are you using MyT-Mobile, or the T-Mobile app? Did you have any trouble logging in to either, or is it just the payment issue causing problems for you?

        Hopefully you've had a chance to straighten this out by now, but if not, we'd definitely like to have you Contact Us, not only to get the balance squared away but also so that we can get a ticket filed for the online issue! Please keep us posted on how things are going. Thanks!

        • tmo_mike_c

          Were you able to get this resolved? We wanna make sure you got the help you needed so please give us a reply and let us know how things are going. Thanks a bunch!

          • tmo_chris

            Just checking in here to see how things are going. Please let us know if you still need any help.

            • magenta4003030

              I continually have this issue and I can usually stop it eventually if I hit the X button to stop the page from loading however now I cannot, so m service is out. I am getting fed up. Different devices (phone, laptop) browser version, request desktop site, mobile browser version, all the same. 

              • traveler_chris

                2-7, 8, 9 refill by credit card still doesn't work. I had to do it over the phone and they seem to charge a fee! I wanted to recharge $37.79 and the total I had to agree to is $40.51. Very frustrating. T-Mobile please fix this. We need our phones!

                  • tmo_marissa

                    Hey there! Thank you for the update, and I'm so sorry that this is still happening! I wanted to ask if you could describe what happens when you're trying to refill on the website -- is it redirecting, as the OP described? Were you able to try the refill app or refilling by calling the automated service, *233, or did you have the same trouble with that as well? We've been seeing a few reports like this and want to see if we can pass the issue along, so any details help!

                    On a side note, I'm sending a PM your way regarding updating your username, please take a peek in your inbox in a few! Thank you.

                     

                     

                    - Marissa

                  • traveler_chris

                    I am still unable to refill and now it's 3-21.

                    • traveler_chris

                      Normally I use Google Chrome to refill my account. It hasn't worked since January. Whenever I click "refill" it takes me to my forms of payment but doesn't let me click, it just reverts to the account summary. Very frustrating. Today I decided to try doing it through IE. I got in and it let me refill!!!! So if you are having an issue, like me, try a different browser.

                      I hope this helps.

                      • magenta5940343

                        Refill online is NOT working 4 months already!!!!  NO ONE in support can help! When I schedule a call to talk with support, they call by their robots and keep me on a line FOREVER!!!! why they call me if they are not available to speak??

                        Thinking about switching to different company. tired of irresponsible service.

                        • bete_ito

                          I’m trying to buy a refill for a prepaid sim card. But my credit card is from Brazil. My order is accepted but canceled after. How could I to do the refill because my son is studying in the USA but I’m living in Brazil?

                          • magenta6683034

                            I have seen recurrent problems with credit card refill on the my.t-mobile.com website. My credit card is a US card, but the problem is with the web app,

                            which has waaaaaay too many tracking elements and many failure modes. The list of trackers includes the following:

                            clicktale.net

                            foresee.com

                            doubleclick.net

                            demdex.net

                            liveperson.net

                            facebook.net

                            impactradius-event.com

                            dynatrace.com

                            tiqcdn.com

                            googleadservices.com

                            Given that an increasing fraction of the public is using blocking technology like adblock plus, ghostery, or eff's privacy badger, you should not expect this website to work. You should decide whether this website is for customer service or customer annoyance, and make product decisions that are appropriate.

                             

                            I also saw JSON parsing errors in the Javascript:

                            Uncaught SyntaxError: Unexpected token < in JSON at position 0

                                at JSON.parse (<anonymous>)

                                at Function.parseJSON (js.min.406200118725.js:1)

                                at a (js.min.406200118725.js:1)

                                at Object.success (js.min.406200118725.js:1)

                                at c (js.min.406200118725.js:1)

                                at Object.fireWith [as resolveWith] (js.min.406200118725.js:1)

                                at k (js.min.406200118725.js:1)

                                at XMLHttpRequest.r (js.min.406200118725.js:1)

                            I can only conclude that this web app simply isn't up to industry standards, and it repeatedly fails on different browsers and different machines.

                            • d.b.

                              Firefox user here. I managed to solve this problem by turning off Content Blocking for the payment site:

                               

                               

                              - eCustomerSupport is separate from T-Mobile, so you have to disable it separately;

                              - You'll have to stop the page from loading completely before it redirects (i.e. hit Stop as soon as the URL in the address bar changes);

                              - If you're in a private browsing window, the blocker will only be disabled as long as you're logged in to the current browsing session. Mozilla support says a non-private window allows for making permanent exceptions, but I haven't tried it.

                               

                              Not sure if this applies to other browsers and their privacy settings. If the equivalent actions on Chrome or whatever Microsoft is calling its browser now are successful, please let the rest of us know.

                               

                              (P.S. - magenta6683034 has a point.)