Seattle Coverage Issue

magenta3202918

    No coverage, despite being in an area T-Mobile's coverage map shows good coverage.

     

    T-Mobile's Coverage Map:

     

    T-Mobile Coverage.JPG

     

    Actual T-Mobile coverage collected by OpenSignal. Typically I have no coverage at this location and have to drive to HWY 181 before signal is restored.

     

    OpenSignal Coverage.jpg

     

    Device is a Moto 5G

      All replies

      • tmo_lauren

        Re: Seattle Coverage Issue

        Hmm.


        Thank you so much for reaching out! Has there ever been coverage in this area for you, or has it always been problematic? Have you experienced these issues on multiple devices, or is your Moto the only device it's been tested on?

         

        We'll go form there and see what we can figure out.

         

        -Lauren

        • tmo_chris

          Re: Seattle Coverage Issue

          Hey there Are you still with us?

          • magenta3202918

            Re: Seattle Coverage Issue

            Hi tmo_chris

             

            Yes, I've reached out multiple times both on the forums as well as the call center and this is still an on going issue. Please resolve or update T-Mobile's coverage maps to reflect actual coverage.

              • tmo_chris

                Re: Seattle Coverage Issue

                Excellent! If you reached out to our over the phone representatives, they will have recorded this issue and reported it to the engineers. Did you happen to get a service request number for this?

                  • magenta3202918

                    Re: Seattle Coverage Issue

                    As stated, this issue is not resolved, your assumption about how the call center representatives is referring this issue to the engineers is incorrect. Every phone contact I have had with the call center refers me to work this issue with through the forums. No Service request number has been provided and so my understanding no one within T-Mobile has referred this to the engineering department and end customers are not given direct access to the engineering department. (Do you have a direct line to the engineering department you can provide?)

                      • tmo_amanda

                        Re: Seattle Coverage Issue

                        Hey, magenta3202918!

                         

                        It's incredibly odd that our Customer Care team has been referring you back to the Support Community solely because we do not have access to customer accounts and cannot file a tickets for coverage issues. I'm sorry you've been given the run around as I know you probably want this solved ASAP. When you work with Tech Support, they'll review your account (to ensure a data plan is in place) as well as look at the specific coverage areas you're not getting a strong signal with relation to the towers. You can get in contact with Tech Support by dialing 611. You also have the option of contacting our T-Force team via Facebook or Twitter. If you choose to go that route, you can simply link them to this thread (I think the screenshots you've sent would be handy) and prevent you from repeating yourself. All you have to do is click the Facebook or Twitter icon in my signature and it'll take you directly to our T-Mobile page.

                        • tmo_chris

                          Re: Seattle Coverage Issue

                          Just wanted to check in here to see how things were going. Did you get a chance to speak with our T-Force team yet?