Gear S3: Unable to use Samsung Pay after latest update

bingo7

    I'm unable to use Samsung Pay after the latest Gear S3 update (S/W Version: R775TUVU1AQI2).

     

    All my cards vanished and now when I'm trying to Add a card, the gear s3 app on my phone gives an error "Your Gear is not responding. Try Again."

     

    Several retries and restarts later, the situation is still the same.

     

    On top of it, both software and hardware reset as described in Master reset: Samsung Gear S3 frontier are not working.

     

    When attempting to perform a S/W reset, the watch briefly shows preparing and then goes back to previous screen.

    With the H/W reset, it just reboots without reset.

    I have followed both the instructions with my other Gear S3 and it resets fine (using both methods).

      All replies

      • bingo7

        Seems like there is an issue with the Tizen Operating system and some apps.

         

        I uninstalled all the apps which did not come by default and ran the S/W reset step and it worked.

         

        I was then able to reinitialize and restore my watch (I had taken a backup before the reset) and add my credit cards back.

         

        The last OTA update did mess things up for existing apps.