Not getting texts on time and then getting 20+ of them

whistler

    I have an Alcatel Pixi 4 (6) which I've had for a few months with no problems.  I've been using the stock messaging app.  For the last 6 weeks now I am not getting texts when they are sent to me - it takes 2-7+ days, and then when I get a text I get dozens of them for a week or more.

     

    This happens with many different senders. I can send texts and they go out on time and not repeatedly.

     

    I have already done a factory reset which wiped my phone, and then I went to a T-Mobile store where they put in a new sim for me, and checked the settings on the phone.  (I got 25 texts from Tmobile telling me about the new sim since Saturday, and they haven't stopped.)

     

    On reddit someone suggested using another text app called Textra, and that didn't work either.

     

    I don't have many apps on the phone and didn't add any in the last 2 months.

     

    I'm not a savvy phone person, so I've never done anything like rooting it or wifi calling (which my phone doesn't have, I think).

     

    If anyone has advice or ideas... I'm all ears. Thanks

      All replies

      • whistler

        ps idk how to edit the orignal post

         

        I have android 6.0.1 - the phone has never received an update afaik

         

        And I have about 4k total messages on my phone. I used an sms backup text app, so that's how I know how many texts I have.

        • tmo_marissa

          Eek! This isn't a good development -- it's hard to use text to communicate when your messages aren't rolling in as they should. Can you tell me a little more about your phone -- is this the T-Mobile branded device? If it's an unlocked device, then is it possible that the APN settings went off somehow and need to be updated?


          I know you haven't added any apps recently, but can you pinpoint anything else that happened around the same time that messages stopped being reliable? Can I also ask if we took a look at your location and checked for any possible impacts to your service based on spectrum changes?

           

          It's great that you reset the device; but a huge bummer that this didn't get you any results. How are you doing on device memory after setting everything back up? Did you have a chance to test in safe mode after the reset before restoring everything? Typically, a master reset and a fresh SIM are the last steps we'd work through before recommending a warranty exchange; so I want to make sure we've also done our due diligence looking at settings or the network as possible issues here!

            • whistler

              This is not a T-Mobile phone. It is unlocked. I live in San Francisco - I assume the location is not the problem. Device memory is 8gb of 16gb

               

              The T-Mobile store checked the settings after the sim was changed out. I assume the APN is correct.  These are the screenshots from the current APN settings, and I threw in a picture of what's happening with the phone (that message was sent  on Nov 8th.)

               

              I added a bunch of the usual apps when I got the phone in March.  I did not add any apps since March except Lyft/Uber.  Problems started in September.

               

              After the reset - I waited and didn't add any apps and messages still weren't working.

               

              (Please keep in mind I never had a smart phone before, so I added the apps I thought I needed.)  Anyway around the time the phone started going wonky I removed many of the apps that I had never used. Removed apps were like snapchat, whatsapp, instagram, and kik.   I have tried reinstalling those apps after the factory reset and sim change to no avail.

               

              I don't know how to get to safe mode, but I could certainly figure it out if you think it will fix the phone ...

               

               

              Screenshot_20171112-105739[1].png

              Screenshot_20171112-105749[1].pngScreenshot_20171112-110840.png

               

              Screenshot_20171112-105757[1].png

                • tmo_marissa

                  So, from what I can see, that looks OK (the settings, not sending the same message over and over )! Do you see anywhere that you can enter SMS settings? Can you shuffle around and try to find somewhere to double check your SMS settings against the ones outlined here: BYOD T-Mobile data & APN settings?

                    • whistler

                      From your link -

                       

                      Preferred settings

                      Internet and Picture Messaging:

                       

                      The APN and MMSC screenshots are above.

                       

                      SMS center: +12063130004 - screenshot added. idk if important but they are greyed out ??? And if I touch the #206 or SMS Service Center nothing happens.

                       

                      Screenshot_20171112-125236[1].png

                        • tmo_marissa

                          Hmmm, so it doesn't seem like these can be modified, or maybe they're automatically input in this device by merit of entering one of the other settings? When you initially started using the phone with T-Mobile service, do you remember entering that number then (it looks like it's correct!) or did we send you settings over the air?

                          I'm sorry to say I'm at a loss here -- when it comes to non T-Mobile equipment, we can provide the settings and we can troubleshoot for network issues and general device trouble, but specific device settings aren't something we have resources to help with. My generic recommendation would be to troubleshoot the network first (file a trouble ticket, work with our Tech team to confirm that there weren't any recent spectrum changes that might have turned down something that your phone was connecting to), but it sounds like you've already reviewed the area with us. The next step would be to check APNs, then test a new SIM, then a master reset and operating in Safe Mode afterwards. If the problem isn't present in Safe Mode, then you can add apps back slowly and use process of elimination to figure out which app might be causing the problem. If the network and SIM are ruled out, and the issue is still present even in Safe Mode, then we'd refer back to the manufacturer for a warranty repair/replacement.

                          It's just such an unusual thing to stop working suddenly that I'm trying to think of any way you could rule out the equipment as the problem!

                          • tmo_marissa

                            Howdy, whistler. I just wanted to check in here and see how things were going. Were you able to rule out the network and settings or apps as a cause of this problem? I hope things have improved!

                              • whistler

                                This problem has not been fixed.  I have to believe that after a factory reset and new sim that there are some issues with T-Mobile and my phone choice. I was also unable to get data in Canada for 3 weeks in March and no data in Turkey for 3 weeks. Although I could text and make/receive calls.

                                 

                                I spent hours and with support both online when I was in Canada trying to get it fixed to no avail, and in stores when I came back.

                                 

                                The real problem is that the phones offered by T-Mobile are not big enough for old people to read. I need a 6" or more phone. And I ain't spending 800$ on a phone that if I drop once is toast. (Granted I have never dropped a phone, but there's always a chance.)

                                  • tmo_marissa

                                    Gotcha. I agree that if you've ruled out the device and SIM, then at this point the best bet is to troubleshoot the network with our Tech team and have a ticket filed for this. Do you know if a roaming data ticket was filed when you were in Canada? Since tickets are location based, now that you're back we'd want to have you reach out for one with the correct home address so that our engineering team can take a look at that area.

                                    I hear you on wanting a device that fits your needs but doesn't cost almost a grand. We announced the REVVL Plus recently -- it will have a 6 inch screen and should be released in just a few days, if you're in the market for a new phone. You can take a look at some specs here: T-Mobile REVVL PLUS.

                                    That said, if your primary focus is on getting your existing device to cooperate, I can't blame you one bit. At this point we would need you to Contact Us so that we can get a ticket filed and see what's going on with the network in your area. Please make sure you mention that it worked before and has stopped, but you're at the same home address!

                                      • whistler

                                        In regards to the SMS problem - I live in San Fran and I drive during the day around SF. I know it's not a tower or location issue or there'd be tons of people complaining.  idk why SMS became a problem after 6 months of use, but it is what is is.

                                         

                                        I was in Calgary and Edmonton in Canada - I spent hours and hours on the phone when I was there and after I got back from Canada. It definitely was a phone issue. Keep in mind this was back in March, so I don't recall everything but they ran a bunch of tests (towers and stuff like that), and provided me with tons of support (gave me codes to use on the phone).  I tried all the different cell networks but ultimately I just couldn't get data in Canada.

                                         

                                        No data in Turkey (Istanbul) either... but I didn't expect to get any data anyway.

                                         

                                        Thanks for the heads up on the REVVL Plus - that would be a winner but I already ordered a Lenovo Phab 2 (6.4" screen) for 200$ (LTE Bands 2, 4,12) but if it turns out to be a dead phone - I'd definitely wait for a REVVL Plus.