Unable to configure cellular on Apple Watch Series 3 with iPhone X

decent4u

    My new iPhone X doesn't let me enable cellular on my Apple Watch Series 3. it fails with the error "Unable to configure Cellular Plan". See the attached .gif for the whole process.

     

    T-Mobile technical support also seem clueless about this. Even resetting the apple watch and setting it as a new watch (or restoring from an existing backup) fails to configure cellular on the watch. I can skip cellular and continue the setup just fine and watch works as expected in all other areas, excep cellular can not be enabled.

    Nov_04_2017_14_27_01.gif

      All replies

      • decent4u

        Few more data points:

         

        Before the new phone, cellular was successfully enabled (through the same process) on the phone. When data was transferred to the new phone. I did not explicitly disable or remove cellular plan from the old phone. I assumed the transfer will take care of this. Once I saw this problem, I went back to the old phone and unpaired the watch and also reset it (delete all content, settings and data plan) and pair it again with the new phone. That started showing this problem.

        • tmo_chris

          Thanks for taking the time to post to our community! It is a bummer to hear that you are having so much trouble trying to get your watch to work! The good news is that we have seen this error in the past and have a few simple things we need to check on the account side. If we can't fix it with a few account related updates, we can escalate this up to our engineers and they can get it fixed for sure.

           

          If you have a moment, please contact us and have the rep you speak with look at internal DOC-437039 at the very bottom. This will have all of the information they need to generate the ticket for you. Rest assured, this is something that we can definitely fix for you.

          • kulti_man

            Provisioning Issue with Apple watch Series 3 paired to IPhone X- No incoming calls with watch cellular plan, but Outgoing and messages are working.

            Apple watch 3 descended with a thunder bringing challenges to T-Mobile and left them groping in the dark as how to configure electronic SIM cards. In reality, these SIMs are not meant for manually configuring in the system. The watch was working in October 2017, with my previous iPhone 7 Plus balancing on embarrassing call dropping issues, I waited for Apple's OS 4.1 which should have solved. The issue. But with IPhone X and Watch series 3 from November 6th, a new issue of watch unable to receive incoming calls, with iPhone away, surfaced. Reset and un-pairing has been done for iPhone and watch more than 5 times at Apple genius bar, spending 5 hours  of time  twice. Apple even replaced the watch I originally received from T-Mobile. Net result was worse than before. No Cellular Plan in watch for 5 days from November 22nd 2017. On 27th T-Mobile support brought back to original condition of “No incoming calls” with cellular data alone. A new phone number was issued automatically by the system and I had to plead with support to cancel the previous DIGITS plan number. Four tickets were raised from November 6tth with a promise it will be solved. It boils down to provisioning problem in the system to receive incoming calls. With iPhone X switched off, the call immediately goes to voice mail. Testing was done with WIFI and Bluetooth turned off, keeping iPhone X ON. I loosing trust on T-Mobile to solve this hitch in time.