Branched to a new discussion.

No Service and Data

hehexd

    I have been at Santa Cruz for a month and my signal and data were fine. All of a sudden on Wednesday morning my phone had no bars but I was only able to make or receive calls under wifi calling. I visited a T-mobile today where the employee called a customer care representative. The employee turned my phone off and the representative sent a signal directly to my phone. When my phone was turned on again my phone was able to make calls and receive data again but 30 minutes after leaving the store I had the same problem again. Now when I turn my phone(after a shutdown) on it gets full bars and 4g for a few seconds before going back to the problem from before.

      All replies

      • drnewcomb2

        Re: No Service and Data

        Wow. That sounds like something is defective with the phone. What make and model phone is it? Is it a T-Mobile phone or did it come from a different source? This is one case where I might give a new SIM a try first but would expect the phone would probably need to be replaced.

        1 of 1 people found this helpful
        • tmo_marissa

          Re: No Service and Data

          Hey, hehexd! I think drnewcomb2's "wow" is an appropriate response here. How are things going for you? I know it's just been a few days, but if you're still having trouble, have you had the opportunity to swing back by the store and see if a new SIM improves the situation?

           

          - Marissa