Missing Usage Details

maybay

    Every time I try to see my usage details for each of my phone lines on the My T-Mobile website, I get the message "unable to process the request at the moment" and that I should check back later. This has been going on for at least 2 days. Any one else having this problem?

      All replies

      • tmo_chris

        Re: Missing Usage Details

        Well that is no good at all! Which browser are you using? Have you tried using another browser or perhaps clearing your current browsers cache, cookies, and history?

          • maybay

            Re: Missing Usage Details

            I am using Google. I will try clearing it.

              • maybay

                Re: Missing Usage Details

                I cleared all the available options Google gave me and I still cannot see my usage details.

                  • tmo_chris

                    Re: Missing Usage Details

                    Thanks for trying that. Do you have any other browsers you can try like Firefox? If you have the same issue using an alternate browser, please contact us so that our support team can escalate this up and get it resolved.

                      • maybay

                        Re: Missing Usage Details

                        I tried Firefox and still got the same results. I will contact T-mobile through your link. Thank you.

                        • maybay

                          Re: Missing Usage Details

                          I talked to a tech person at Tmobile the same day I originally posted about this. He filed a work order to look into it. I still cannot see any of the current usage details for any of the lines on my account. I don't want to see last month's details from the bill. I would like to see details from the last few days. I have been able to see these before, but for some reason, I can't see them now. Help?

                            • tmo_chris

                              Re: Missing Usage Details

                              I am glad you were able to get in touch with our support teams and that they were able to open up a support ticket for this. Unfortunately, at this point, we will need to wait till our web teams can get this bug fixed. Did you happen to get an ETR when you called to report this?

                                • maybay

                                  Re: Missing Usage Details

                                  I  did not get an estimated time of resolution. Maybe someone is still working on it.

                                  • magenta4069952

                                    Re: Missing Usage Details

                                    It's not letting me log in to my previous call details when I go to usage

                                      • magenta3716219

                                        Re: Missing Usage Details

                                        For months I've tried to get someone to solve this problem and all I get is

                                        "we're working on it." I've gone to two stores in person, called multiple

                                        times and had far too many online chats. Everyone has a different excuse.

                                        Everyone tells me the problem will be solved. Everyone has lied. The

                                        problem is not resolved. Not even a little bit. It doesn't matter whether I

                                        use the app or go to the website. I still cannot call up data usage for

                                        messaging, and when I can, it gives me only a fraction of the incoming and

                                        outgoing numbers.

                                         

                                        On Thu, Feb 8, 2018 at 2:37 PM, magenta4069952 <no-reply@t-mobile.com>

                                          • meghanm127

                                            Re: Missing Usage Details

                                            Did they ever resolve this issue for you?? If so, do you know what they did? This started happening to me yesterday and I can't get a straight answer from any customer service rep. First I was questioned on why I want to see the recent activity, which I told them it doesn't matter why, the fact is I was able to do so until yesterday. Then I was told that it was a system update and would be available within 2-4 hours. After two more attempt, I got a rep who actually looked into a few things for me and told me she would have to put a ticket in, but didn't have an estimated time of when it would be looked into and that they will not contact me when it is corrected because it is a national ticket system. To just check back every once in a while to see if it is corrected. Every time I check back, I get more and more frustrated. I rarely have an issue with my account and with T-Mobile, but it seems like when I do have an issue, I cannot get a resolution in a timely manner.

                                              • tmo_chris

                                                Re: Missing Usage Details

                                                Hey meghanm127

                                                 

                                                For these types of web issues, the best course of resolution is with a web support ticket which is sounds like you had filed. For usage detail issues, it is possible it can take a full billing cycle to correct as the system will need to be refreshed and the newly corrected info to display.

                                                  • meghanm127

                                                    Re: Missing Usage Details

                                                    hi @tmo_chris Thank you for that information.  I understand issues happen from time to time. My frustration is that I am being told different reasons when I contact customer support and finally a ticket was entered for it. I also understand this is a low priority issue to T-Mobile, but for some of us, it's important to be able to see that information. I use that feature to see the usage and activity on the other two lines on my account which are for teenagers. I don't understand why it will take a full billing cycle to correct if I was able to see this information up until yesterday. I can still see previous months, just not the current month's activity. My cycle does not end for another two days.

                                                     

                                                    Like I said in my previous post, I rarely have an issue, but I am very disappointed in T-Mobile right now.

                                        • magenta2856214

                                          Re: Missing Usage Details

                                          I have cleared all cookies etc...used all kinds of browsers. I think the issue is something with the website and that current usage is visible for only some customers while others are struggling and cant get the issue resolved. I have called customer service several times but nothing helps. Or do we all need to wait for the next billing cycle for changes to show up?

                                    • magenta2835900

                                      Re: Missing Usage Details

                                      This has been happening to me since 9/26. Does anyone have an update? It's very frustrating.

                                    • bellbty

                                      Re: Missing Usage Details

                                      I have had the same trouble. It's been at the least 3 days that I have not been able to see usage details. I have tried on various web browsers and even in the t-mobile app. Nothing shows even if I try a few hours later. Let me know if submitting a web support ticket works.

                                      • magenta2839325

                                        Re: Missing Usage Details

                                        Ive been having the same problem! Its so annoying ive contacted support twice and nothing has been fixed! Its frustrating . I thought i was the only one! This problem needs to be fixed already! It should not be taking a month!

                                        • magenta2846899

                                          Re: Missing Usage Details

                                          I have the same problem. I cant see messages from this month only past month's. Should I contact tmobile or it just a bug on their website?

                                          • magenta2841698

                                            Re: Missing Usage Details

                                            I am having the same issue and I have been in contact with support and I was able to open an incident. No solution provided. The customer Rep does have the ability to reset your webpage menu functions. It might help you out but it was a no go for me.  Now, rumor has it, there was an update that broke, it might be related to the application deployment to iPhone in someway or maybe IPhone Operating systems related.   I guess we won't know until it's fix.

                                             

                                            Well, they provide me a solution I'll let you all know.

                                             

                                            Unable to process the request at the moment. Try after some time.

                                             

                                            Your not alone.

                                            • magenta2856214

                                              Re: Missing Usage Details

                                              I have had the same issue. Have not seen my current usage fie almost a week. Contacted customer service and they said they would work on the problem. Its been days and nothing is fixed.

                                                • magenta3716219

                                                  Re: Missing Usage Details

                                                  I have had the same problem as well. I downloaded the mytmobile app on my iphone and I cannot retrieve the "view line details." On rare occasion I can retrieve some of the details but most is missing. I've called customer support to no avail. Was told a "ticket" would be opened and I'd hear back. That was at least a week ago and I've heard nothing. I even went to a T-mobile store and the rep was not able to solve the problem so he too called customer service, which had him try the same things they had already had me try, including trying to access the information on the computer. No one at T-Mobile can resolve this problem. We only recently switched from Verizon and on the Verizon app I was readily able to get the information. Perhaps it's time to switch back to T-Mobile.

                                                • 828lisanate

                                                  Re: Missing Usage Details

                                                  I am also having this issue.  I tried to use the online 'message us' and everytime I do it says You are no longer logged in. Log in again to view the conversation. - however, I am logged in.  Ugh. I have tried on many different browsers, cleared cache and all history settings - still cannot view usage details.  Please provide an ETR, as this appears to be affecting many tmobile users

                                                  • magenta2878627

                                                    Re: Missing Usage Details

                                                    Having the same issue, but only on one line. Is there some sort of setting that needs to be changed or something? Apparently, nothing is being done about it.

                                                    • annson

                                                      Re: Missing Usage Details

                                                      Same here. 2+ weeks now. Ticket in since Sunday, but still broken. Can't view past usage either. Interestingly, I was able to view past history once when I was already on a different month and got there through billing section. But as soon as I got to current month, I got the error message and all previous months come up blank. Not sure why it's so hard to figure out what is going on. Wonder what my bill will show when it comes up soon.

                                                      • magenta2835900

                                                        Re: Missing Usage Details

                                                        I have no idea what is going on with this. I've had a trouble ticket in for twelve days. And I haven't been able to view my usage details since 9/26. That was 17 days ago. Every time I message T Mobile they tell me they are working on it but can't provide an ETA on when it will be fixed. This is beyond frustrating.

                                                        • magenta2835900

                                                          Re: Missing Usage Details

                                                          Also, T Mobile, will those of us affected by this be seeing a credit on this month's statement for the inconvenience?

                                                          • purple102612

                                                            Re: Missing Usage Details

                                                            Started having the same problem on 10/04 when my billing cycle reset. Have inquired at least 3 times about this and nothing is fixed. On Friday they said give it 72 hours ... tried again this morning ... same damn thing. Sent another message to support and all I get is no ETR but rest assured this is at the top of their fix list. #eyeroll ... 14 days should have been plenty of time to have this fixed.

                                                              • annson

                                                                Re: Missing Usage Details

                                                                Mine also started when my new billing cycle kicked in, but mine was way back on the 27th. Still no access to usage. I find it hard to believe they've put any of their competent technicians on this matter, because it would have easily been solved by now. It's just a simple display of data from a database. It works with some accounts, so just trace down the bug that someone introduced and fix it. It shouldn't take 3 weeks or more to do that.

                                                              • annson

                                                                Re: Missing Usage Details

                                                                I'm curious about something that might be related. Is everyone that is having this issue also on the Family Allowances plan that also gives you Netflix? I asked if I could get the Netflix without the added Family Allowances nonsense since it's just another point of failure and I will never utilize it, and the response was to sign me up for it. If this is related to the bloat forced upon me, then I'm gonna be pretty livid.

                                                                • magenta2835900

                                                                  Re: Missing Usage Details

                                                                  I don't think this issue will be repared until the next billing cycle. Just my opinion. This is ridiculous.

                                                                  • magenta2835900

                                                                    Re: Missing Usage Details

                                                                    I meant repaired.

                                                                    • astroboy2017

                                                                      Re: Missing Usage Details

                                                                      I've been having this issue since end of September.  Called TMO support several times, but no help.  This is ridiculous!

                                                                      • darkbird122379@aol.com

                                                                        Re: Missing Usage Details

                                                                        Yeah, it's been on the fritz for almost 3 weeks now, T-Mobile needs to get their shittogether.

                                                                          • annson

                                                                            Re: Missing Usage Details

                                                                            I'm actually at the 3 week mark now and not a single person at T-Mobile has any idea what is going on nor do they know whether this will ever get fixed. They hope, but there's no information. I need the usage logs for submitting into work, but that basic functionality is beyond T-Mobile's capabilities. I'm praying that the bill will have the information so I can submit the info using that. Employer doesn't like me turning it in delayed, but I told them there isn't anything I can do.

                                                                             

                                                                            How many T-Mobile technicians does it take to screw in a lightbulb?

                                                                            We may never know. They're all too busy collectively trying to get usage details working again, but are failing miserably at that.

                                                                            • magenta2835900

                                                                              Re: Missing Usage Details

                                                                              Screenshot_2017-10-18-14-24-24.png

                                                                            • jackietreehorn55

                                                                              Re: Missing Usage Details

                                                                              Ok... so I think most of us as account holders understand and accept the apology, however is there an update as to this problem as it has been consistent for the last few weeks.

                                                                               

                                                                              What is the current status of the Diagnostics to identify the problem and then to issue a correction to the problem so that account holders are able to view and access the data usage history in there my T-Mobile accounts. Understanding that this is a electronic and data problem and may not be resolved quickly but would like to know status.

                                                                                • astroboy2017

                                                                                  Re: Missing Usage Details

                                                                                  As jackietgreehorn55 said, we understand things happen especially with IT related issues.  The problem here is that I didn't know if I'm the only having this issue until I found this discussion group.  I also tried to escalate this beyond the phone support and I couldn't.   The support folks were diligent in getting back to me but with same information every time.  I hope this gets fixed soon.

                                                                                • magenta2940552

                                                                                  Re: Missing Usage Details

                                                                                  It is absolutely unbelievable that TMobile cannot fix this issue quickly. It has been 3 weeks and nothing has been done. I'm not sure they understand how crucial this information is to many of us. This is unacceptable. Something has to be done quickly. Maybe they just don't think this is an important issue to their customers.

                                                                                  • purple102612

                                                                                    Re: Missing Usage Details

                                                                                    Haha still nothing ... anyone surprised?

                                                                                    • magenta2948797

                                                                                      Re: Missing Usage Details

                                                                                      Time to bid Tmobile goodbye. Waited too long for this.

                                                                                      • tmo_chris

                                                                                        Re: Missing Usage Details

                                                                                        The fix is coming soon folks. I wish I had an exact date for y'all but I do not Please hang in there.

                                                                                          • magenta2954385

                                                                                            Re: Missing Usage Details

                                                                                            Chris, I also work in IT, this is a simple fix from T-Mobile side. You don't want any TMobile Customer with connections to News Media or the Law to broadcast that Mobile has been depriving their customers their rights for timely information about their accounts. If I were you guys, alert your CIO before Legal gets into the scene.

                                                                                          • astroboy2017

                                                                                            Re: Missing Usage Details

                                                                                            Looks like it's working as of 4AM PDT today.  Well, at least for me.  It's been 26 days since it broke on 9/26.  I certainly hope this doesn't repeat next bill cycle.

                                                                                             

                                                                                            BTW, I'm going to bookmark this thread so that I can raise some voice with those affected here.  Thanks!

                                                                                            • bellbty

                                                                                              Re: Missing Usage Details

                                                                                              Seems to be up and running! Finally. -  NorCal

                                                                                              • magenta3967363

                                                                                                Re: Missing Usage Details

                                                                                                I had the same problem, this is what I did to see my current data usage.. disable wifi and make sure your T-Mobile cellular service is active, then try again. It worked for me, hopefully it will work for you.