FDFL (Free Data for Life) Lost on iPad Reset -> No Service -> FDFL Lost = 10 Calls to Your Philippines Call Center = Zero Resolution!

fastuser01

    3 weeks now - multiple calls - multiple promises - zero resolution. TMO Service & FDFL lost on simple iPad Reset

     

    Two part problem. First, is your outsourced contact center in the Philippines

     

    #1 - Does anyone at TMO actually vendor manage your outsourced call centers? If so, try calling with anything other than a problem that requires a restart of your device. If I ever thought about porting in to TMO, for this sole and single reason, I WILL NEVER under any circumstances consider it given the hell they've put me through. You are saving a few bucks of labor cost, but really, what is your net gain if anything in the end?

    • You ask any question that is not in the script, and like a broken record - they just repeat the same question
    • You ask for a supervisor, and you're put on hold and you get someone else that has no clue. ROUND AND ROUND WE GO....
    • You have an issue that requires anything more than restarting the device - expect to get transferred, put on hold, or a ticket logged to nowhere being opened, etc...
    • "Not to worry" is the trained tag line to reassure you even when you're upset. False promises.
    • When the script runs out of options... The fun starts... assumptions, blind-transfers, and the game of "hot potato" all with the underlying goal of AHT reduction (if you ever wonder why call center agents get ansy after ~5 minutes on a call, it's because they're racing against a clock. They're timed and measured on this!). To add insult to injury, they never followup even when they promise to do so. The icing on the cake .... somehow the second to last agent though the pricing plan problem (FDFL lost) is are Tech Support issue... LOL REALLY?)
    • And here we are...10 Calls Later - Rinse. Wash. Repeat!!!! ISSUE STILL NOT RESOLVED! So I am trying a different approach before sending an email to your executive escalations inbox.
    • Now the above is said, let's move on to how all this drama started....

     

    #2 - SOLVED! - The Original Issue - "No Service" after an simple iPad reset (This is solved - but it lead to another problem #3 - FDFL being lost)

    • The saga started with a simple "Erase All Content and Settings" on my iPad Pro 9.7 (A1674). This had FDFL.
    • After the device was reset, TMO service would not appear and the iPad acted "new" and "Setup Cellular Service" was the only option
    • Attempting to setup TMO service - add to account, update account, whatever - would take me into the MIM screen for my account as if TMO's network already knew I was activated.
    • While the "Setup Cellular Service" window was open, I had service for purposes of completing the activation and TMO recognizing the device, but the device itself didn't recognize I had TMO service, so it would fall back to "No Service" once the screen was closed
    • Essentially something was out of sync between TMO Provisioning & iPad Apple eSIM Provisioning
    • Keep in mind this has the Apple eSIM, no standalone SIM - everything is stored on the device and or stored centrally
    • So I call (800) 937-8997 Thursday, Aug 10, 2017 at 5:06 AM PT and spend  23 min 11 sec trying to get the original "No Service" problem resolved. I explained everything above. They tried everything and said someone would call be back and that logged a ticket. Right.
    • Fast forward... 5 days later. Can you guess? NO CALL!!!
    • So I call (800) 937-8997 AGAIN. This time on Tuesday, Aug 15, 2017 at 8:11 PM at again at 10:17 PM. I spend a total of 1.5 hours on a call with agents and eventually a supervisor.
    • Supervisor tries everything the last agent did. Still could not resolve. Phone number was changed. Same issue.
    • In the past I had this problem before. The only way they could resolve was to kill the subscription (CTN), and start a new one.
    • The supervisor killed the current subscription (Original line with FDFL ended in 9070) and setup a new subscription with new line that now ends in 6698
    • This resolved the "No Service" issue, but as a consequence, FDFL was lost int he process as the rate plan is expired and of course, they're powerless to help add it back

     

    #3 - NOT SOLVED! - The Current and Still Unresolved Issue - FDFL Still Not Added To My Account!!!

    • So, to summarize this far... No Service problem resolved. New subscription. New Line. New Plan -  I got back the 5GB for 5 months, but the FDFL plan now was gone!
    • The supervisor's answer was "Not to worry" we can get that back and a ticket to nowhere was logged
    • I was assured the FDFL plan would be added back, and an offline team had to do this and it would be done in 5-7 days
    • The supervisor promised to personally e-mail and call me to followup.....
    • So....10 days later (3 days after SLA)- you guessed it!!! NO CALL. NO CALL. FDFL problem STILL NOT RESOLVED!
    • I call in again today...3 times. and get bounced around back and forth along with the famous "I need to transfer you to tech support for your plan problem"

     

    Can someone please click the two buttons needed to add this plan back to my account? or is there a number to call to reach folks that are actually empowered to resolve my issue on the spot versus attempting to placate me with a "ticket" to nowhere.

     

    Thank you!

      All replies