Using ZTE Axon 7 mini overseas, change APN

netivaan@bellsouth.net

    I purchased the Axon 7 (mini) because, as far as I know, it (full size and mini both) is the only phone that can have 2 SIM cards and be enabled for Wi-Fi calling on the T-mobile network, as long as it is updated to Android 7.1.1 (nougat).  The Wi-Fi calling worked when I tried it in the USA. Then I went to the Caribbean West Indies (St. Lucia) and tried to turn on Wi-Fi calling there.  It would not work.  After many hours on the phone with both ZTE USA and T-mobile, I was able to determine that by accessing the notifications, where a red telephone/wi-fi icon showed up at the top of the home screen, an error code was displayed.  With this information the T-mobile representative was able to somehow send information to my phone as I restarted it, and voila, Wi-Fi calling is enabled.  The error message said there was no internet connection, however, there certainly was an internet connection.  In the meantime, as advised by the ZTE representative, I had also gone through some complicated steps to make a new APN (Access Point Name), with the help of the T-mobile representative, who informed me that it was really not necessary.  The place where you can change the APN is Settings/Dual SIM settings/scroll down to "Cellular Networks"/ Access Point Names/tap the + symbol.

     

    The APN choices originally on the phone were "T-mobile US LTE", and "T-mobile US tmus".  When I choose "T-mobile US LTE" the Wi-Fi calling now works.  So it was not the APN settings that made a difference, it was seeing the error code and having the T-mobile representative reset something in the phone, so that Wi-Fi calling can recognize that there is an internet connection.

     

    This took a lot of time, so just in case it helps someone else I am documenting my experience here.

      All replies

      • netivaan@bellsouth.net

        Update: the Wifi calling has never really worked well in St. Lucia, on the ZTE Axon 7 Mini, using T-mobile.  I have to restart my phone every time I come back to the house, then go to dual SIM card settings, and re-register to a certain network (tried them all one by one to see which one would work) which is only sporadically available. The networks here are Digicel and Flow.  As I have a Flow modem, I choose Flow 3G, then get a message to search again, and if it shows up I choose a network which is "xxxxx 3G" (xxxxx is 5 numbers). It's not ideal.  When I was using an i-phone 5s wifi calling worked without any hiccups, but I wanted a phone capable of holding 2 SIM cards.  The Axon 7 is advertised as working for wi-fi calling on the T-mobile network, and it does so very well in the USA, not so well in St. Lucia.