After activating Digits, SMS are not delivered to 3rd party SMS apps.  How do I fix it?

obelix25860

    I activated Digits and now incomming SMS don't show up on any 3rd party SMS apps - they show up on Digits (Web) and on the stock SMS app, but not on third party apps.  I normally use Textra for SMS, and MightyText to SMS from my PC and none of them will receive SMS - tried other 3rd party SMS (like mySMS, goSMS) and same problem.

     

    It looks like incomming SMS only get "delivered" to the stock samsung messages app, but not to any third party SMS apps.

     

    I'm running a Galaxy S8, with the 7/19 (or 7/20) software update (which is where all the problems started!).

     

    I've tried disabling Enhanced LTE Services (you need to use a Nova Launcher widget for that on the S8) to see if it's an RCS problem ... but that didn't work.

     

    Any ideas?

     

    tmobile-admin is there a way to completely disable digits on my line (like remove it completely) to see if that solves the problem?  I've tried logging out of Digits on the phone, turning it off from my.t-mobile.com, etc. and nothing ...

      All replies