iPhone using Duplicate Sim will not ring using "Minutes and Data"

laestrella

    I've had this issue since starting the EAP. I really wanted to believe I was doing something wrong but I have tried everything. I have signed out of the app, restarted the phone, uninstalled the app, but still no luck.

     

    Hoping someone else in my situation can reproduce this issue:

     

    I'm running iOS 11.

    I'm using a duplicate sim that's cloning my primary number. (Wondering if this is the issue, because when asked to identify the phone I put my Primary Number not the duplicate sim dummy number)

    I've installed the Digits EAP app and activated my Virtual Number.

     

    I place a call from another phone to that Virtual Number and the phone looks like it's going to ring (I see a splash of green like when you're on an incoming call, you know at the top of the screen) but then nothing more. It disappears. I have that Virtual Number activated on another phone so I know it's ringing. I can also see a missed call in the iOS Recent call log. So the call does somehow start to register on the phone it just never rings like something is stopping it.

     

    If I switch from using "Minutes and Data" to "Use Data Only" calls come through just fine.

     

    Anyone else having this issue? Please say yes!!

      All replies