Digits on Blu R1 Plus

magenta2081496

    This is actually a question I was able to answer and I am posting to help others who encounter the same problem.

     

    I am using a Blu R1 Plus running Android 6.0 as a Digits phone. This is a current model. The primary phone for my line is a Galaxy S6. The Blu R1 Plus did not ring when there was an incoming call to the primary number. The Galaxy S6 rang, but the Blu R1 Plus didn't. I spent quite a bit of time talking to T-Mobile support and they could not solve the problem. A Google search uncovered a Reddit thread by diegoanza that had the solution. I will paste a link at the end if T-Mobile will allow an external reference.

     

    The solution that worked for me was to turn off Voice over LTE (VoLTE) on the Blu phone. To do this go to Settings > Wireless & networks > More > Cellular neworks and move the slider to turn off Enhanced 4G LTE Mode. Then Digits worked as it should, ringing both phones when there was an incoming call. I'm not sure what I will lose without Enhanced 4G LTE Mode, Maybe HD voice? But it will be worth it to be able to use the Blu R1 Plus as a Digits phone.

     

    Note to T-Mobile Developers: Please fix this. My guess is that this is not a problem restricted just to this specific Blu phone model. If T-Mobile is going to follow the philosophy of "Bring your own phone", then features like Digits should work on Android phones from all manufacturers.

     

    Link to source:

     

    https://www.reddit.com/r/tmobile/comments/69auhd/blu_r1_hd_plus_volte_doesnt_work_with_digits/

      All replies

      • tmo_evan

        Re: Digits on Blu R1 Plus

        If you can provide the first 8 of the IMEI for the device (aka the TAC code), we can make sure to add this to the list of device.  The main issue for a lot of these devices is that while they are technically capable of doing VoLTE, the implementation isn't tuned well to the T-Mobile network and the device registers for services that it shouldn't which in turn causes issues. 

         

        Unfortunately there are a lot of these devices out there in the wild and while we're working to enable them all properly, sometimes there are fundamental issues with a device and sometimes it just requires us to block particular services on the backend to solve.

         

        Thanks for reporting the issue and letting us know.

        2 of 2 people found this helpful
        • magenta2081496

          Re: Digits on Blu R1 Plus

          Unfortunately, the issue is not resolved. The problem continues as before. When I enable Enhanced 4G LTE Mode the BLU phone will not ring when there is an incoming call. When I disable Enhanced 4G LTE Mode the BLU phone will ring when there's an incoming call.