Text messages stuck "sending"

radarweaver

    Was wondering if anyone else is having this issue.  When sending text messages they sometimes get stuck "sending" and never go through.  This happens both on / off WiFi and I have tried both with and without wifi calling.  I've also changed the network settings off LTE to 4g/3g/2g and even just to 2g to try and resolve this.

     

    This is happening on my S8, wifes S8, and our sons S8+.  Started within the last two weeks and according to TMO store rep it's a firmware issue that Samsung is aware of but I'm not seeing others with this issue complaining so it makes me wonder.

     

    Any feedback would be helpful thanks!

      All replies

      • drnewcomb2

        Re: Text messages stuck "sending"

        This sometimes happens to me. It seems to happen when I'm on the verge of changing from one mode to another (e.g. LTE-HSPA-GSM). I've even robooted the phone and the message was still stuck. Eventually it would either fail or send.

        1 of 1 people found this helpful
        • tmo_amanda

          Re: Text messages stuck "sending"

          Hey, radarweaver!

           

          Thanks for joining our Support Community! Seeing how texting is a primary form of communication these days, I'm sure this is pretty frustrating for you and your family. I'm sorry this isn't working as it should. I'm actually working with another user that is having the same issue as you on their Samsung Galaxy S7. I appreciate you letting us know what steps you've already taken to attempt to get this fixed. It's a bummer none of them worked but what I'd like to do is forward this over to our Samsung guru to see if they have any additional insight because you've done about all the troubleshooting we would have had you do. I'll likely hear back from them on Monday or Tuesday and will follow-up with you on this thread then.

           

          Edit: I'm sending you a private message to gather a few specific details about each of the devices. You can check your inbox here.

            • agb

              Re: Text messages stuck "sending"

              Same problem here Galaxy S7 edge with all the updates installed and the stock message app. When it fails, all I see is the spinning circle until it times out, then there's an exclamation point noting the failure. Resending never works. Doesn't matter if I have wifi on or off (only seems to fail when I'm on the LTE network and never on wifi), in other words, when I'm out and about and not connected to wifi is when this happens.

               

              I  have digits (multi-line settings ) running on the phone.

               

              I've confirmed the message center number: 2063130004 and reset the app cache. Seems to work for a bit (sometimes a few days) then fails again)