Amazon Fire

willf

    Just a thought, but has corporate considered putting the Digits app into the Amazon Appstore?

    Just another avenue of getting the service to be more widely available and used.

     

    Cheers all!

      All replies

      • magenta2078993

        Re: Amazon Fire

        Same question. I got hooked with the 'works with any device with an internet connection' ad still shown on the DIGITS page. Just tried it on the Fire. Google Play Services is required to use DIGITS on an Android. Amazon doesn't allow GPS to run on their droids. Unless rooted.

          • willf

            Re: Amazon Fire

            The issue isn't Google Play Services.  It's only required if you install it via the Google Play Store. The app is installed via a simple APK. Hence the suggestion of TMO submitting it to Amazon for their Appstore.

             

            Technically, there are no issues installing it away from Google Play other than possibly not being able to connect to your Google account for contacts. The APK is available on several of the generic app stores as a direct download of the install file.

            Several of those third party stores/repositories even show as having the most current version of the Digits app. And even though my experiences with those app stores have been good, I would never recommend to anyone who is NOT an advanced Android user to take the chance and install anything but an official release, which is why I'm not linking to any of those markets.

             

            I'm just pointing out that it's not Google Play stopping installation, just the availability of official release on other app marketplaces.

             

            I throw this back to the devs and management at TMO...

            Get this up on the Amazon Appstore. There are enough people out there who have Fire tablets who do not have or want another Android tablet but would want this to work for their convenience on the tablet they already have.

          • magenta2078993

            Re: Amazon Fire

            No, I downloaded DIGITS from Apkmirror.com, not the Play Store. I try to stay away from GPS. However, several phone or assistant apps for Android do require GPS and Google Talk Service to be on the device, but not necessarily the Play Store app. For example, Jarvis, IFTTT, Pushover, Line2 APIs use GPS.

             

            The Digits app threw an error because it stated GPS was required. I am actually an Echo and MS Developer, so I wasn't going to let this one go.

             

            I just got it working on the Amazon Fire! This is how it should work without rooting it:

            Go to apkmirror.com and download the following 4 apps: Google Account Manager, Google Services Framework, Google PlayServices, Google Play Store (if using apkpure app, this may not be required). Install them in the order listed above. Open up Play Store and login. Then download the DIGITS app. It will work.

            If using apkpure or apkmirror to install Digits vs Play Store, use either to install the DIGITS apk and Play Store should not be required. I haven't tested this.

             

            If the above doesn't work as expected, this is what I actually started with last night:

            I had DIGITS installed last night on the Fire, First, before the Google Apps above. I used apkpure to install DIGITS.

             

            I have the MS Arrow launcher on my LG phone. I despise the Fire launcher, so before I installed the Gapps above, I had already installed Arrow and then DIGITS. However, Arrow Launcher would always be overridden by Fire Launcher. Today, I installed the LauncherHijack v2.1 apk,

            It instructs you to go to Accessibility and turn on the Home discovery option.

            I then restored a cloud backup of the Arrow launcher from my LG phone, which also has the DIGITS app installed. The backup restored the apps from my LG onto the Fire. If the app is already on the Fire, it seems to update the cached content. If an app is not installed, it shows a market link of the app and does not actually install the app.

             

            Now, I'm not sure if this Arrow stuff is required, but I noticed that when I disabled DIGITS on my LG, it also disabled it on the Fire. It might just be a caching of the Launcher. I re-enabled DIGITS on the Fire, left the LG DIGITS disabled and made a call to the house just now. It worked fine.

             

            Next, I need to figure out how to get DIGITS to work on the Windows phone that T-Mobile sold me. Strange that they ONLY have the T-Mobile Account app available for the Windows phones that they sell.

            1 of 1 people found this helpful