silensventus

    Hello,

     

    Let me preface this with I have been reading and trying every suggestion for this seemingly common issue, for the past two and a half hours.

     

    I have:

     

    Cleared cache

    Restarted/powered off totally

    Checked android version. Software up to date and there has not been any recent updates applied.

    Turn on and off all possible combinations of wi-fi/cellular use and connection options (use 4g, use 3g, use 2g...etc....still no network)

    Started in safe mode to rule out third party apps (of which i have very few)

    Made sure it is not trying to connect to any wi-fi network. (I am currently at work and have turned off auto-connect for any wi-fi and "forgotten" all three of the ones available).

    etc...etc

     

    If there was a suggested "fix", I have tried it to no avail. I see it has been an issue at times for years across many android versions, phone types and carriers.

     

    Right at the top of screen on phone you can see the little "4G" flash on and off every few seconds. There is no network connection when trying anything that requires said 4G network. Device has no IP address...etc...etc. I have "full bar" indicators.

     

    The last time Accuweather widget updated was 12:41AM today. I always have Wi-Fi off, until I am home. But for the past three nights I had not turned it on, as i was only home for an hour before I had to leave for the night. I returned home at 10 last night, went to bed at 10:30, checked email (via 4G), plugged in charger and went to bed. On the way to work tried Pandora and "no network". Figured it was them. Got to work and then saw the flashing icon and here we are.

     

    I have not tried a factory reset. Some people stated this did clear the issue. However, I do have a few pictures I wish to save, so if I do that, it will have to wait until later.

     

    We have a mobile hot spot available to us (I am in desktop/tech support) so I made that one the only one available and connected to it with no issue. Anything network related at that point worked, as expected. Email, internet, etc. I DID notice that the 4G icon was also present at the same time???? If that means anything to anyone. For all I know, I believe I have casually noted it being there before when I am home on the weekend and I run full wi-fi connection during that time. But not truly sure. Phone can also receive an incoming call when the "flashing" is going on (not connected to wi-fi. And I do not use wi-fi calling anyway)

     

     

    SO........any new methods people have seen to resolve this?

     

    Thank you.

      All replies

      • silensventus

        Well, as I have seen in my 30+ years of support, the device magically is working now. True some people reported they had the issue after an update (which I had none) and then they just left it alone and it started working. Another person thought they saw it occur after a particular phone call. They got another call and the issue went away.

         

        SO....who know but I WAS just on the website after being here and updated a few account settings and all of a sudden I heard the message tone on my phone. Hmmmm, "A message from T-Mobile confirming my change? Wait a minute, how did that come through!!??" Sure enough, "T-Mobile is back in the upper left and 4G with it's down and up arrows are solid and working.

         

        Still any thoughts for the future if occurs again would be appreciated.

          • tmo_mike_c

            Well, if it was magic or not, I'm glad to hear it's working silensventus. It's possible there could have been network upgrades our engineers were doing in your area at the time. During those times, you can have a little trouble using the service until it's done. Changes like this don't normally last very long so this could be what happened with you. Please let us know if you need more help or have any other questions. Thanks!